Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Sign in to follow this  
ATVNetwork

2019 Polaris Outlaw 50

Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Topics

    • By renob4x4
      2 position adjustable
      Part number 2879887
      $125.00
       
      Local NE Phoenix AZ cash sale only




    • By renob4x4
      Polaris service manual for 2014-2016 Sportsman 325 / ETX / 450 HO / 570
      PN 9926803 R04
      Is in new condition. $75.00
       
      Local NE Phoenix AZ cash sale only



    • By jwline
      Friday evening went riding, rode for a good hour or so everything was fine. I went to take a short ride to the restroom (less than 100 yds away) and all of the sudden everything flickered and then just died out. Accompanying the problem I noticed the killswitch completely locked up. Once daylight hit took the killswitch apart to find it had shorted out and melted the plastic inside. Has anyone else had anything similar to this and if so what did you do to fix the situation? I have a new killswitch on the way to replace the obvious problem but was wondering could there be a bigger issue at hand. We tested with a voltage meter to make sure everything was still getting power from the battery and as far as we could tell it was.
      Any advice/info would be GREATLY appreciated.
      Thanks.
    • By technofarmer
      Hey there, i have recently put a new drive belt on my 11 Polaris Sportsman 500 H.O.    It has 44 miles since putting the new belt on and should be nearly broken in as i hear it takes 50 miles to do so?  Anyhow it has had a little trouble with slipping since i put the new one on a few months ago. Now whenver i go down a hill the belt seems to be getting caught in one clutch if not both and then it has to run a high rpm just to go a low speed.  Today it did that again going down hill, i stopped, put it in neutral and when going back up the hill i had to turn it off, put it in neutral, let it roll back down the hill a little, then restart it, low range and it was slipping but thankfully i was able to make it up the hill. 
       
       So what might the problem be? Is this a need for another new belt? New clutches and belt? Or just get something else? BTW the brand new belt i put on it, is a factory one, an exact replacement for the original.   

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...