Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Poul

1995 Suzuki LT-F4WDX gas coming out vaccum hoses

Recommended Posts

I'm the happy owner of a 1995 Suxuki, - but due to work travel it has been sitting in a corner for more than 10 years. I'm trying to get it back to life, and I have it firing up, but it is rough on the idle (rich), and gas is coming out of the hoses running up to the shifter area. I assume I have to do some work on the carburetor, but I would appreciate any help pinpointing the issue. I have ordered a manual. Thank you in advance.

Share this post


Link to post
Share on other sites


Spot on, - I'm up and running again.

Still a ways to go before it is back to is own self, - have to work on the brakes etc. but it is running smooth again.

 

Thank you very much.

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Micah Gafford
      I bought this ATV from a friend who had it stored in their shed for a few years. I've been going through it getting things ready to fire it back up and get it driving around. So far I've changed out fluids, removed and cleaned gas tank. I am waiting on a fuel fitting to be ready to able to put the gas tank back on and fire up the engine. I'll follow up once I get to that point with whether or not that went smoothly.
      Right now however I've got a brake problem. The brakes were locked up. I took the brake line off the master cylinder and made sure that it wasn't locked up, it works. I proceeded to try and flush them no luck. Then I just disconnected the brake lines. They appear to be blocked up. I don't know if the hose portions deteriorated or what. I've found the front left and right brake lines, although $70-80 each doesn't make me happy... I can't find anyone selling the rear brake line 1930751 or the primary 1930760 that goes to the inverted flare cross fitting. This leads me to wonder if I should buy parts and tools to make my own brake lines.
      Two questions:
      If I should decide to make my own can you point me to any tutorials out there on doing that and what size are these lines with the flared fittings?
      Can anyone else find the two brake lines i listed for sale somewhere?
    • By Ajmboy
      A little bit of click bait there with the title because in the grand scheme of things, what the hell does a virus have to do with your ATV except maybe give you a little more time to ride if you are out of work or school!
      In all seriousness, how's everyone doing? Here in lower NY, its getting a little crazy...
      Schools are closed all week, might be longer as they issued every grade that didn't have one, a chromebook and google classroom (preparing for remote learning) Some stores are out of things like disinfecting wipes, sprays, rubbing alcohol, tylenol, toilet paper, pasta, and other basic necessities. (panic buying in full force) Many people (including myself) are working from home, no more travel for the next few weeks. Interesting times and I hope no one gets sick! Stay healthy!
       
       
    • By cgilley
      Ran it out of gas last month... Works fine for 3 or so days then refuses to start.... Changed out the sparkplug and it will run for 15 or so seconds before shutting off.... Cleaned out the fuel system and injector and it misses when idling as well as shutting off at idle every so often... It is giving me no other issues and sounds and runs fine while riding... Only issue is cutting off at idle.....
      Ideas anyone??
    • By weblex
      Friends, being the owner of a far from new ATV, I often come across a search for various owner's manuals, service guides, parts manuals, etc. It is not easy to find suitable documents for every quad. Therefore, I present to your attention a website that contains various instructions for ATVs from well-known manufacturers: https://www.ATVownersmanual.com
      Currently only 3 manufacturers are represented here: Can-Am, Polaris, Yamaha - and only about 1200 instructions for various models. Little later other brands and missing instructions will be added.
      What will be convenient for you: all documents are in PDF format. If necessary, you can download them to your computer and use offline. The documents are structured by brand, year and model. There is no advertising (yet).
      I am happy to hear criticism and recommendations. If you have missing or rare instructions, send them to PM or to the website's email: info [...at...] atvownersmanual [...dot...] com.
    • By Bryson Bailey
      Hey I have a Kawasaki buyou I put a new carburetor on it and a brand new spark plug coil and still firing up could you know what my problem is anyone please
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...