Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

payne

What is this?

Recommended Posts

Hi, buddy of mine gave me this for my daughter. I'm looking for parts for it but dont know where to start. Anybody know what size/manufacture it is? Definitely some Chinese model I'm guessing. Thanks.

20180930_171354.jpg

Share this post


Link to post
Share on other sites


Yeah that's definitely some Chinese quad. It's going to be hard to match something up to that without spending some time online to see what's similar. I tell people to look through google images after searching "Chinese kids ATV". Also search for "chinese atv parts" and you'll find some sellers who you might be able to reach out to and give them the link to this topic to see the picture or send them a picture, they may know quicker what it looks like and what parts may fit.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Ed Zeppeli
      Hi all,

      I picked up this quad after the previous owner couldn't get it going.

      The issue is that I can't get it to fire at idle or at all.

      I've...

      - replaced plug. Decent blue spark. Also tested with spark tester inline.
      - rebuilt the carb. PO had already bypassed vacuum lines from petcock. There's fuel at the cylinder
      - Checked compression with new gauge. reads 190 psi
      - cleaned all contacts I could access.
      - am currently jumping with car battery. Solenoid jumpered.
      - checked cam timing at TDC and adjusted valve lash
      - put gas directly into cylinder to see if it will fire at least momentarily

      Motor turns over well. Plug gets wet. 

      Motor may fire once or twice but smokes through exhaust a bit as if it's trying to fire or combusting.

      This leads me to suspect timing. As mentioned I checked the flywheel mark versus cam marks. Perhaps someone has been in there before because I can't find a 'T' on the flywheel but there is a very visible paint mark which aligns with TDC position on piston. Possibly a slipped flywheel/woodruff?

      Is it possible that if it had seen previous repairs, that the timing could still be off? I'm reluctant to dig into the flywheel/stator area if there's something else I could have missed but all signs point me to that area. Would a bad CDI cause spark timing to be off?

      Anywhere else to diagnose incorrect spark timing?


      I've scoured these forums and elsewhere but I'm posting just in case there's something I've overlooked up until now.

      Thanks very much for reading!


      Warren
    • By gregorio
      I've got a Polaris and a Honda that I use regularly on my ranch so they see a lot of abuse.  Fortunately, there is still a Honda dealer nearby but the nearest Polaris dealer is over 1.5 hours away.  They charge way too much money ($1800 for battery, alternator, wire harness and fluids change) so I am starting to learn how to do my own repairs.  The Internet is a wonderful and scary place when it comes to shopping.  Where can I go for a fair deal? Is there a list of preferred vendors that advertise on the forum? 
      Thanks,
      Greg
    • By Chad Dickerson
      I am goin nuts here! I have a 04 400 air cooled 4x4 , I'm a atv,car,truck,mower mechanic for yrs,just sayin. Ok it cranks and kinda fires now and again then after 5 min of cranking and stopping itl start if u touch throttle itl did then u start all over! If u let it warm up sumtimes u can throttle it up other times it just does! Just depends on it? When it stays running it runs awesome,no problems except it just does randomly like u shut key off? Sumtimes itl start right back up others itl do the no start thing! IV put new plug,adjusted valves and hot tanked carb? I'm at a loss here guys! Please any other ideas? I don't think it's anything to do with flywheel? It's not the auto it has a hi low reverse lever on left fender and foot shifter? Help please lol
    • By JacobSlabach
      i know this isnt an atv but same type of thing.  I have a riding mower im fixing and selling for my aunt and it has a dead battery.  i jumped it off my atv and when i turn the key nothing at all happens.  i tried jumping the relay still nothing.  this is with the seat down.  you wouldnt think this mower would have issues as its a top-of-the-line brand and almost brand new (aunt found it for a good price, still got tits on tires, just sat for a couple months in a mechanic shop
    • By Ajmboy
      Just got this one and am sharing...

      Visit 4wheelparts.com Use Code: POLARISORV at checkout *Exclusive offer ends 6/17/19 at 11:59 pm CT
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...