Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

lewjones46

sportsman 500 6x6

Recommended Posts

got one that is overheating -put new themosat in ,didn't help,took it out still didn't help,pump looks ok ---ant suggestions/

Share this post


Link to post
Share on other sites


The only thing that would be left is the pump.   It may look ok but prob the culprit.  

Have you checked the pump drive to the pump. There is a shaft that drives that pump. You need to pull the pump and crank the engine to make sure the shaft is turning. 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Lellwyn Griffin
      Thinking about buy a used 07 Prairie. Any feedback or suggestions on what to look for?
       
       
      Sent from my iPhone using Tapatalk
    • By schwartz10
      2011 Brute Force 750 I. Having an overheating issue. When fan sensor is unplugged by thermostat fan will run and cycle. When its unplugged it will not run and cycle. Need help. Really dont want to take to dealership.
    • By marek porowski
      Good morning everybody 
      I’ll be looking to get a cover for my Polaris sportsman touring that can be used while I take my atv to the lake for ice fishing. 
      min using an open flat trailer and 
      I want to protect it from the road salt 
      I know Polaris makes a nice cover but it’s kind of on the expensive side. I’ve seen some covers on amazon and eBay but was wondering if anybody has any suggestions 
      Thanks 
    • By Zachary Coombs
      Hello, I’m new to this forum, I have a 2007 trail boss 330 that’s been overheating after about 5 minutes of riding. No problems before it overheats from a cold start but then it backfires and loses power. The fan comes on but the temp light doesn’t. I’ve had someone clean the carburetor, I’ve replaced the spark plug and air filter and put in a new battery. I also tried cleaning the radiator with a hose, Any help is appreciated, Thanks
    • Guest
      By Guest
      It seems like a gas problem but I've changec, fuel injector, gas cap. I have lots of fuel pressure but after four wheeler has run for 20-30 min I have no power and sometimes stalls and won't start. Any ideas?
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...