Quantcast
Jump to content


2006 Can-Am Outlander Max 400 Oil leak After Oil Change


johncb

Recommended Posts

  • Admin changed the title to 2006 Can-Am Outlander Max 400 Oil leak After Oil Change
  • 4 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Forum Topics

    • By JohnnyB
      Greetings, 
      Have a 88 LT80 that been sitting for a couple years. Bought a new piston, cylinder and head. Installed these, rolled it over and it quickly locks up.  Took carb apart. It was full of what appears to be 2 cycle oil. Cleaned it, but keeps locking up and 2 cycle oil continues to seap from exhaust port.  When i installed new cylinder, I noticed crankcase was full of oil.  I'm now wondering if that oil is what's getting sucked up into cylinder.  Should there be no oil in crankcase?  If that the case, how is crank and rod lubricated?  Sorry, never worked on a 2 stroke. Thanks!
    • By semicolon
      Hi, I am having issues with my TRX350D fuel pump.  It suddenly stopped running so I have replaced all the fuses and cleaned all the terminals.  I have fitted a new pump, fuel cut-off relay and rectifier.  Still nothing!!  The pump runs when attached to a battery.  The engine will start on the choke and the filter fills with fuel but it will  not rev and dies when the choke is closed. I have power to the relay but nothing at the pump black/white wire when cranking the engine.  Any ideas where to go from here would be very much appreciated!!
       
    • By mga
      I see quite a few ads for that  Tribotex additive. It's kind of expensive, has anyone used it it their ATV or any other vehicle?
    • By NZrider
      My king quad 700 runs rough when cold then won't start some times but not often when it's hot. And occasionally smoke's a lot when it's cold I'm guessing that's rings but I'm worried unless it's causing the other problems
       
       
       
      All help is appreciated thanks
    • By Slitzer
      How often do you change oil in front/rear diffrentials and gearbox?
×
×
  • Create New...