Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Admin

QUADCRAZY Log in and site issues

Recommended Posts

You may have experienced issues with our site in the past 24 hours. We are performing some maintenance and fixing issues. We appoligize for this.

This will be on and off for the next day or so... We'll keep it live during the main parts of the day for everyone.

Thank you for your understanding.

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Bryson Bailey
      Hey I have a Kawasaki buyou I put a new carburetor on it and a brand new spark plug coil and still firing up could you know what my problem is anyone please
    • By weblex
      Friends, being the owner of a far from new ATV, I often come across a search for various owner's manuals, service guides, parts manuals, etc. It is not easy to find suitable documents for every quad. Therefore, I present to your attention a website that contains various instructions for ATVs from well-known manufacturers: https://www.ATVownersmanual.com
      Currently only 3 manufacturers are represented here: Can-Am, Polaris, Yamaha - and only about 1200 instructions for various models. Little later other brands and missing instructions will be added.
      What will be convenient for you: all documents are in PDF format. If necessary, you can download them to your computer and use offline. The documents are structured by brand, year and model. There is no advertising (yet).
      I am happy to hear criticism and recommendations. If you have missing or rare instructions, send them to PM or to the website's email: info [...at...] atvownersmanual [...dot...] com.
    • By Venom
      Does anyone make aftermarket engine parts for the Suzuki Quadsport LT-Z50?
      Pistons, Valves, etc...?
      I have found rings and complete gasket sets.... I need an oversize piston kit and valves..
      One company is selling a piston, but upon further inspection it is an LT50 piston that they are saying is for the 2006 Suzuki Quadsport LT-Z50. Yet the LT50 Piston is not interchangeable with the LT-Z50 according to the pistons listed by Suzuki.
      Any help would be appreciated
    • By Chris Cowell
      What’s up fellas new to the site where should I post my question. I’m having issues with my 2012 yfz450r quad having ZERO power. Screen won’t even come on 
  • Similar Tagged Content

    • By Flanstone
      I just bought two 1985 TRX250's from my father-in-law. One runs great, the other not so much. The one is having issues with the shifter. The shifter seems to be resting lower than normal. When I press the shifter downward, it just pops back up. Any thougjts as to what the issue might be?
    • By Anthony Marceau
      Hi everyone! I have a 1986 yamaha moto4 200 that's been sitting for a while! Cleaned the carb, replaced engine oil, put fresh gas in it. Got it running and went for a ride! It was running great just a little backfire once in a while! I barely made it home on the way back and now the bike won't run at all since then! It will start if I give a little bit of throttle but dies instantly as soon as I let go off the throttle! And even if I try to rev it up it'll sound like its not getting enough gas.. it revs up a couple hundred rpm's and backfires through the carb.. it almost sounds as if I was trying to take off from zero in 5th gear! Nothing is seized though! I dissasembled the head and the piston and cylinder are fine! Rebuilt the carb, replaced the ignition source coil.. I don't know what to do anymore.. compression test shows 90 psi Specs are 128 psi but i'm not sure if I trust my compression tester.. any ideas? Thanks!!
    • By Admin
      It has come time that we make some changes around here, things are a bit old and running on old technology. There have been so many advances in coding and platform technology that we are way behind the ball. We need to get up to speed.
      We will be upgrading QUADCRAZY to a newer forum driven platform. When that does happen, we will be moving over our members and forum topics/posts only. At this given time, we are not planning on bringing over any videos, pictures, or personal messages. Our forum is the most important and visited section of this community. This will allow everyone to have a fresh start with newer photos and videos to share in the community and build some new content and friends. Our ETA to launch our new site is by October 1st, but that is TBD still. Please save all of your information that is not in the forum.
      I wanted to give everyone enough opportunity to digest this and start thinking about any info that they may need that is not in the forum. As we make progress, Ill post some images of our upgrade work and keep everyone posted. More to come!
    • By quadcrazy
      As we close the 2014 year and plan for 2015, we have decided to shut down a few sections here on QUADCRAZY. Effective immediately, we are closing our Blogs, Groups, Events, Polls, Photo Battle, Quiz, and Music sections. These are not widely used by our community and often attract spammers. Any questions and posting should be primarily made in our forum section as we move forward.
      In 2015 we will focus on making sure our forum continues to be the primary spot for our members to gather, ask questions, and share their ATV experiences. We are also exploring ways to update our community to newer and more up to date platforms as technology is changing, mobile connectivity is growing, and some of our sections are not as "mobile friendly" as we would like.
      It's been about 10 years now for QUADCRAZY, we're looking for another great 10 years to come. Please continue to support us by visiting www.quadcrazy.com and participating in our forums.
      Thank you and Happy Holidays from the QUADCRAZY family to yours!
    • By cherpe
      I have a 2002 450 foreman es. When doing several shifting into reverse like when plowing it starts to become troublesome to get back to a foreward gear.Have to keep pressing the shift buttom several times to get out of reverse.Has anyone had this issue ?Is there a fix to this problem? Thanks
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...