Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Admin

QUADCRAZY Log in and site issues

Recommended Posts

You may have experienced issues with our site in the past 24 hours. We are performing some maintenance and fixing issues. We appoligize for this.

This will be on and off for the next day or so... We'll keep it live during the main parts of the day for everyone.

Thank you for your understanding.

Share this post


Link to post
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Anthony Marceau
      Hi everyone! I have a 1986 yamaha moto4 200 that's been sitting for a while! Cleaned the carb, replaced engine oil, put fresh gas in it. Got it running and went for a ride! It was running great just a little backfire once in a while! I barely made it home on the way back and now the bike won't run at all since then! It will start if I give a little bit of throttle but dies instantly as soon as I let go off the throttle! And even if I try to rev it up it'll sound like its not getting enough gas.. it revs up a couple hundred rpm's and backfires through the carb.. it almost sounds as if I was trying to take off from zero in 5th gear! Nothing is seized though! I dissasembled the head and the piston and cylinder are fine! Rebuilt the carb, replaced the ignition source coil.. I don't know what to do anymore.. compression test shows 90 psi Specs are 128 psi but i'm not sure if I trust my compression tester.. any ideas? Thanks!!
    • By Admin
      It has come time that we make some changes around here, things are a bit old and running on old technology. There have been so many advances in coding and platform technology that we are way behind the ball. We need to get up to speed.
      We will be upgrading QUADCRAZY to a newer forum driven platform. When that does happen, we will be moving over our members and forum topics/posts only. At this given time, we are not planning on bringing over any videos, pictures, or personal messages. Our forum is the most important and visited section of this community. This will allow everyone to have a fresh start with newer photos and videos to share in the community and build some new content and friends. Our ETA to launch our new site is by October 1st, but that is TBD still. Please save all of your information that is not in the forum.
      I wanted to give everyone enough opportunity to digest this and start thinking about any info that they may need that is not in the forum. As we make progress, Ill post some images of our upgrade work and keep everyone posted. More to come!
    • By quadcrazy
      As we close the 2014 year and plan for 2015, we have decided to shut down a few sections here on QUADCRAZY. Effective immediately, we are closing our Blogs, Groups, Events, Polls, Photo Battle, Quiz, and Music sections. These are not widely used by our community and often attract spammers. Any questions and posting should be primarily made in our forum section as we move forward.
      In 2015 we will focus on making sure our forum continues to be the primary spot for our members to gather, ask questions, and share their ATV experiences. We are also exploring ways to update our community to newer and more up to date platforms as technology is changing, mobile connectivity is growing, and some of our sections are not as "mobile friendly" as we would like.
      It's been about 10 years now for QUADCRAZY, we're looking for another great 10 years to come. Please continue to support us by visiting www.quadcrazy.com and participating in our forums.
      Thank you and Happy Holidays from the QUADCRAZY family to yours!
    • By cherpe
      I have a 2002 450 foreman es. When doing several shifting into reverse like when plowing it starts to become troublesome to get back to a foreward gear.Have to keep pressing the shift buttom several times to get out of reverse.Has anyone had this issue ?Is there a fix to this problem? Thanks
  • Recently Browsing   0 members

    No registered users viewing this page.


×