Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Thomas Brooks

2017 Sportsman 570 X2 - Problems with EBS, transfer case and heat

Recommended Posts

Hi all,

I apologize if these have been discussed in the past. I just wanted to get this posted out here real quick, then will try searching through the forum tonight. So, I have a 2017 Sportsman 570 X2, with EPS and EBS. I have the following problems/challenges and am curious if I am not alone, and if any solutions have been found.

EBS - Holy cow! The engine braking system is so strong that Active Decent Control doesn't even seem necessary. On deceleration, it actually causes the tires to slide on dirt and asphalt! I have had the ATV for a little over a year and don't use it often. It probably has 30-50 hours on it.

Transfer Case/Transmission - I use a tow behind trimmer mower on my Very steep hill. It is not particularly heavy. While rolling downhill, I am usually in 4x4 (not with ADC, usually). The transfer case and/or transmission will suddenly pop into a neutral state. The shift lever and 4x4 switch do not move, of course. I am able to get it stopped with the brakes. Once stopped, It seems like it is engaged into gear again. That's without moving, shifting or changing anything. I do have a case open with Polaris on this one.

Heat - The ATV runs very hot. I generally use it at low speeds with a load behind it. The load is never terribly heavy. It's usually a garbage can, trimmer mower, driveway grader, trailer with a small load of firewood, etc. 

 

Bonus Question! I will post this to general too. I am a motorcyclist, riding on/off road for over 30 years. This is my 1st ATV, however. How in the heck am I supposed to operate the thumb throttle while at a full right turn? This is generally while trying to make a U-Turn. I tend to roll my hand over the top and grab the throttle from the front with my fingers. It seems very choppy, especially with the engine braking. 

 

Thanks!

Thomas

Share this post


Link to post
Share on other sites


I have a 2018 570 eps. I find the EBS to be quite strong , enough to skid the rear tires. To overcome this I add a touch of throttle and apply brakes...when decending . It's just a matter of getting used to it.

  • Thanks 1

Share this post


Link to post
Share on other sites

Thanks, I’m slowly learning to feather the throttle and brake while engine braking. With the transfer case/transmission issues I am having, it looks like I’ll be taking it into the shop. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Wiley1
      Anybody know what the valve clearance is for intake and exhaust on a 2017 sportsman 570?  I did a search but it came up with nothing.
      Thanks
    • By ATVNetwork
      news A powerful trail machine ready to tackle the hardest adventures.
      Polaris unveiled the 2021 Sportsman 850 Trail Edition ATV with factory-equipped enhancements to tackle the roughest terrain. View the full article
    • By jung4g
      The quad has done this off and on, almost since new, but it's gotten worse this year. Sometimes if I freshly charge the battery, it'll work fine, others times that won't matter. Turning the key to on it sounds like it's connecting as I go to the start position, slightly before the full turn, but it's not like there is just a sweet spot to find, it's totally erratic.
      Now the battery is basically dead so I put a new, slightly bigger AGM battery in today to replace the factory one with all of 800 miles on it, but those have lots of plowing hours included. 
      I was able to get it started once, but it still went into limp mode after just a few moments of driving it (that's another topic), so I put it back in the garage and started probing around. Now it doesn't even try to turn over.
      Is an ignition switch, the $18 shipped aftermarket variety on Amazon worth a shot? Or should I go straight for the starter? The new switch may not come for over a week, so I hate to just put my hopes in that if I'm missing something obvious. Fuses are good, so it's not something super obvious.
    • By Budman
      After purchasing a lightly used 2018 570SP (300 miles on it) I noticed that the display was flashing on and off. I remember reading awhile back that this was a common problem on the 18 model. I can't remember what the fix is. It also turns over slow even though the battery is charged. Anybody know what the fix is on this issue?
      Thanks
      Budman
    • By cody75
      2016 sportsman 450ho cranks. Good spark, removed injector getting fuel no check engine light no start
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...