Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Juan Gutierrez

hello from a new atv engine enthusiast

Recommended Posts


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By ronald webb
      So where to start my son's LT80 stop running a couple months ago. Naturally I assumed I had a carburetor issues or the peacock valve. After replacing those two items and ensuring I had a spark I started doing my homework thus finding this page. After all the post I have read the next natural thing would be compression I did a compression test today and it was only 60 after spraying WD-40 in it so off comes the cylinder head and The Jug to my surprise the cylinder walls and all the gaskets are pristine so I am totally stumped no idea why I would not have compression when everything looks brand new even the Rings look great any help would be appreciated thanks in advance
    • By JonBat68
      I have a 99 250 Quadrunner. Currently has no spark. It would run for 5 minutes, then shut off. After it cooled down about 20-30 minutes, it would start again. I ordered a new stator and found the old one was damaged (copper windings broken)  I installed the new stator, filled with oil and now it has no spark. Any assistance would be helpful
    • By Hunter19
      How are you doing guys I just joined I have a 1998 Suzuki King quad I’m having problems with high RPMs the ATV idols perfectly but soon as a throttle up it doesn’t stall but it just bogs down it has no power any suggestions thanks
    • By smitht18
      Looking for the rectifier.  Most bikes have near magneto.  It appears the KQ has it in front.
      Can someone tell me exactly where it is? 
      Bike not charging and magneto checks out ok
    • By Bryzan3
      Looking for advice on what to try next I bought this quad and it’s has spark and fuel but won’t stay running only fires when I hold the starter button in even when spraying gas into the carb it still dies right away oil was milky white so I was thinking it maybe went under water 150 psi compression so I might be wrong but not a head gasket I am stuck Cause it should stay running with the straight gas through the carb so what should I try 
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...