Quantcast
Jump to content

  • Do you own an ATV or UTV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Polaris 2002 expedition 425 speedometer needle does not work


Recommended Posts

  • 1 month later...


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Tagged Content

    • By Christian Smith
      Recently bought a Polaris 425 Xpedition. Main issue is that the quad randomly misfires sometimes. ONLY does it at idle. Everything sounds good. What should I look for? Haven't checked the plug, seems a bit hard to get to, not sure. Headlights flicker at idle as well, is this a sign of a weak stator? Help? 
  • Similar Topics

    • By Viking
      There's an electrical cable connected to the front brake lever. The parts list calls it the front stop switch assembly. There is no stop switch on this side of the handle bars. Seems to be activated by the brake lever. Anybody know what it does?
    • By sammyshin
      Hey so i have a 1990 bayou 220, and its missing the wiring harness so i went online and bought a bayou 300 wiring harness by mistake. Will it work if i use the 220’s cdi box and ignition coil?
    • By PeteSaracen
      Im fixing up a beartracker 250. Starts right up with screwdriver to both solenoid terminals and pull start. Doesnt start at all with electric start button.  Neutral light and reverse light come on when the atv is running but when it is off and the key is turned to on position, no lights come on. When button is pressed to start, nothing happens. No click in solenoid, nothing. Not too experienced with the electrical components but I have tested a few things. The Front stop switch assembly cable was broken so I replaced that hoping it would fix my electrical problem to the key bevel but still nothing. 
    • By JacobSlabach
      in this thread, I want to discuss how 4-cycle atv engines work- what the different types are...  how they are set up and which you prefer.  To start off, are the cams on ALL atv 4-strokes powered by a cam chain?  I know that on say a lawn mower or logsplitter engine, the cam is turned by the tappet, pushrods, and valve rockers.  Which is better and why?  Chain-driven cams or pushrod-driven cams?  Are the pushrods just an old version and everything is transforming to chains or the other way around...or not at all?  Just looking for some explanation, history, and downsides/upsides...
    • By yugnats
      Hi all, I was gifted this Bayou but she's been sitting quite some time. It won't crank using the factory start button but when I jumper the starter solenoid it cranks but there is no spark. The key has power coming in on the white wire and when turned on supplies power to the brown wire coming out.

      I guess I should start with testing the pickup? I heard I may be able to jumper the wires coming from the pickup with an LED bulb and it will flash? I noticed in the manual that it should have around 110 ohms resistance so I'll check that as well. One thing I noticed was that the starter circuit relay has power on one of the black wires with the key on- this doesn't seem normal as I'm assuming the black wires are grounds? I think one of them comes from the start switch, travels through the starter circuit relay and then grounds the starter relay?
      Mine is a 1991 so it has the 7 wire CDI (ignitor) and a 2 yellow wire alternator ( as opposed to the later 3 wire type ) with another 2 wires for the source coils (black & red wires ). The pickup wires are blue and black I do believe. Any help appreciated and yes I will test the pickup ASAP.

      I'm trying to understand how the system works and I don't understand what the yellow / red wire from the kill switch does- I assume it gets grounded when the kill switch is "on" and therefore grounds the CDI so it can't activate the ignition coil? I noticed in the diagram that that yellow / red wire looks like it may be grounded by the ignition key switch when in the "off" position?
      I also don't have 12v power at any of the wires going into the CDI- doesn't the CDI need to be powered? I also read on this forum that someone used a GM HEI module in place of the factory CDI just to test it for spark- does anyone have any info on that?

      I hope I'm not missing something simple!
      Here is a link to the diagram for my bike (which was posted by another user): https://www.quadcrazy.com/atvforum/topic/13742-1988-bayou-220-lost-spark/?tab=comments#comment-101193

      Any help appreciated!
       
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...