Quantcast
Jump to content

  • Do you own an ATV or UTV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

2013 Honda Rancher 420 cut off and wont dtart back


Recommended Posts

I replaced the fuel pump filter and it ran great for a week or so. Then while driving across the yard in 3rd gear it shut off and hasn't started since. It has fire and its getting fuel, all fuses are good, battery fully charged. The fuel pump relay seems to be warmer than it should be when spinning it over. Any help is appreciated!

Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Tagged Content

    • By Jeni Lynn
      2012 Rancher ES-- only when driving in 4x4 when I get to about 15-18mph there is a loud clunk in the front end and a hard downward jerk. Its almost as if its trying to downshift itself. It doesn't do it in 2 wheel drive.  I have checked the angle shift sensor and applied dielectric grease to it, changed the front end differential fluid (the old still looked good and clean) checked and adjusted the clutch. Hopefully someone can give me some more ideas. 
    • By RDALE352
      My Rancher cranks right up and runs great for a while and then it will suddenly sputter out and die. It usually cranks right back up and again runs great for a while and then same thing. Yesterday it got to where it acted like it wasn't going to crank back up a few time but eventually did. Any suggestions??
    • By redmastercraft
      Any idea what would cause the cotter pin to break and the nut to back off?  The loose hub is wollored out so its trash and the axle splines show a little wear.   I'm going to replace the hub and I'm curious how much play is acceptable before I need to replace the axle?
  • Similar Topics

    • By Belmontie
      Hi bought a 2012 kingquad ASI last year a great machine which is a delight to ride, but I find sometimes it doesn’t go into top gear just revs high at about 42mph. Any idea ???

    • By Wagnerc
      It seems like it looses fuel prime after sitting A few days.  If you ride it every day it will fire right up. Parked for a few and you have to use either to start it. 
    • By BuckBilly
      Good morning to all !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
      Let's see if we can make this a daily event.
    • By Samwise
      Been out of the atv scene for a few years. Just bought a atv. Question I have. Is their anyone who makes a lithium battery for atv's. I only ask because they have them for boats now. Buddy of mine has 2 Dakota's he runs on his. I'd only imagine you can get a really strong battery at half the weight. Any input?
    • By Ajmboy
      With this cold snap, I noticed yesterday that the battery on my grizzly was a little weak. even clicked a few times before I got it to start. I'm thinking of picking up a batter tender/ trickle charger so was wondering what people use to keep their ATV battery charged up. I was looking at these on amazon. They both have good reviews.

       
      or this one

       
      Kind of like this one because if the accessory plug

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...