Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

mikenacarato

WTB: Yamaha Blaster light bar and light

Recommended Posts

I have a 2001 Blaster

I want the front light bracket and light, mine has a headlight switch but no headlight assembly. let me know if anyone has one!!

Thanks!

-Mike

Share this post


Link to post
Share on other sites




Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Bryzan3
      Looking for advice on what to try next I bought this quad and it’s has spark and fuel but won’t stay running only fires when I hold the starter button in even when spraying gas into the carb it still dies right away oil was milky white so I was thinking it maybe went under water 150 psi compression so I might be wrong but not a head gasket I am stuck Cause it should stay running with the straight gas through the carb so what should I try 
    • By Bryzan3
      Looking for advice on what to try next I bought this quad and it’s has spark and fuel but won’t stay running only fires when I hold the starter button in even when spraying gas into the carb it still dies right away oil was milky white so I was thinking it maybe went under water 150 psi compression so I might be wrong but not a head gasket I am stuck Cause it should stay running with the straight gas through the carb so what should I try 
    • By jimybud
      Below is a quote from a response to similar question from yesterday: 
      "Easiest thing to check is trash in the main jet.  if it idles fine, then the idle circuit and low speed jet is clear.  if it bogs off idle that's when it's transitioning to the main jet." 
      I will go ahead and open up the carb and check the main jet, but please respond to this post as if the main jet is squeaky clean.
      Below is my post:
      Only starts and runs on Full chock. 
      Does not matter what position I have my "mixture" screw.   Tried it at zero, 1 turn, 2 turn, up to five turns.  Spent a few hours confirming that the position of the mixture screw does not resolve issue.
      Runs great at idle and if I slowly engage throttle, it will rev up as expected.  But, quick rev up or when I am trying to drive it, it spits and sputters and looses power.
      I also use a propane bottle and did not find any obvious leaks, and the vacuum port is hooked to fuel peacock and I also made sure to simply block the port with my finger to see if that would resolve the issue.
      New Carb (after market), New Coil, Fresh Gas.  No leaks at manifold boot, hot battery.  Good gas flow.    Runs too good to be a valve issue, or cylinder, great compression.
      I can move the choke out a tiny bit, and it will still run, but will still bog down when I try to power it up.
      I also have a 250 trail boss Polaris that I require to run at full choke, but it has power at all throttle potions.
      I suspect it is running rich as the choke is on, but will not run with it off.
      Any details would be appreciated.
    • By Michael Thornton
      Why does the 2001 grizzly not have com bearings or something to protect the head.
    • By Spike976
      So I dug my warrior out of storage replaced the carburetor with one off Amazon & it was running great. Last week it didn't want to start it would crank & I could smell gas but nothing. I replaced the starter,stator,solenoid,spark plug & coil & resistor but still not starting. Checked the stator and its at 30 ohms tried using starter fluid but nothing. I am completely lost and could use some help thank you
  • Similar Tagged Content

    • Guest Fox300exchic
      By Guest Fox300exchic
      The Hop-Up: You may be saying to yourself, “that’s a chick bike,” and you’re right. But honestly, it’s so much more than that. It’s one badass bike. http://www.quadmagazine.com/quad/features/article/0,24942,1587044,00.html
    • By alexcross324
      Hi all, I try to find this manual in the threads but you have a lot of stock here
      Cannot find this particular manual.
      I found it for YFM200 but not sure if they are the same.
      Thanks if you could help me with that.
      Im new here so if I did something wrong, please tell me.
    • By dyyjrr9
      I just got a 1991 Yamaha Moto 4 for my son and I am looking for a service repair manual. I know that the timing chain needs replaced.
    • By Srx_Man
      Hey I own stock why Yfz 450 and I'm just looking to slap a turbocharger on it.. I was just wondering if they're pretty compatible with these machines it is the carburetored version Yfz 450. I have all the piping hook ups / kit that's threw HURON SPEED an i also have turbo lined up for it gt 12.. I was just wondering what else I need to make this work? I know i would need to up the Jets and stuff for starter but Is it just that simple or do I need blow off valves and like some time on regulator on it or so forth? Trying get ideal what i would need
    • By M0BJT
      Hi Everyone
      This is my first post and I was wondering if there is anyone who can help me solve a problem I have with my Yamaha Kodiak 400 4x4 Fitted with a Mikuni Carburetor . The year of the quad is around 1998, the reason I am not sure of the date is, there wasn't any paperwork and no details on the frame either.
      The quad had a bad leak from the carb overflow which indicated that the float needle valve was blocked or passing so I replaced this and put everything back together. The quad ran really well until I took it onto some rough ground to have a ride around, a few hours later the engine started to run really rough as if the engine was flooding. I have removed the carb again and cleaned the needle valve out and the whole of the carb just in case there where any dirt behind it. Engine now runs fine again but fuel has started to run out the carb overflow again.
      I have tried everything to try and stop the fuel leaking out the overflow but its still happening. My last thoughts where to adjust the float level and its still happening.
      Has anyone got any thoughts on the problem or could suggest whats causing the fuel leaking out the overflow.
      Thanks for reading
      Kevin
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...