Quantcast
Jump to content

  • Do you own an ATV or UTV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Recommended Posts

Can anyone id this polaris? Cant find a serial number and not sure where to look! Need to figure out how to adjust the shifter as it's a bear, and pretty near zero pressure on rear brake pedal sinks it to the floor. Thanks! Was redoing a lakota and got a buyer for it and a hope a deal on this, was 1200 with all new cv joints and bushings and a few other items.

20201109_134105.jpg

20201109_134201.jpg

20201109_134125.jpg

Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By Hodadical
      I've inherited a 1995 Lakota 300... it has the knob in the center of the handbar to twist to go into reverse, but I've notice when downshifting, you don't have to have the knob turned, it will shift right past neutral and into reverse which is a little dicey if not all the way stopped. I followed the linkage back and twisting the knob seems to actuate the lever on the outside of the trans, the internals just don't seem to care about this. 
      What is the likely problem and how back is it to get to? I've never been inside of one of these transmissions.
      TIA,
      -Rob
    • By Fittzy
      So I have a Polaris  predator 500 and everything works on it but not getting spark and no power going to CDI box. Please help 
    • By chimmike
      Anyone know where to locate these, or generics? The generics I seem to find have the mount on the wrong side versus the hose outlet. PITA!
      Also, is the rear master cylinder rebuild kit any good?
    • By Jride937
      Have a 2002 Yamaha Bear tracker 250, everything was fine then one day just lost power. Battery is fine, have 12.53 volts coming out, but I have no lights no start no anything. Looking for a wiring diagram
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...