Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

TheJaspMan

December Issue of AEM released!

Recommended Posts

It's that time again! ATV Exposed Magazine has released our December issue and it has a whole new look!

This month we talk with a musician who is into the ATV scene and just came out with a new song for you to download and check out.

We interviewed three ladies as we plan on doing at least 2-3 times each year.

We also providied a quick interview with Joe Byrd founder of the Joe Byrd Quad Riding School. A training tool for racers around the world.

Starting with this issue we will now be adding weekly articles and interviews. Plus we have some international racing that will start sending photos and input into us on a consistant basis.

Plus keep checking back for our next contest starting in just a few days.

aemlogo400.jpg

Share this post


Link to post
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Forum Topics

    • Service Manuals for Download in PDF

      I found a site that sells factory service manuals(type used at dealerships)and I thought I'd pass it along.They also sell some cheaper(inferior in my opinion)manuals as well. Repair Manual Catalog Online - RepairManual.com <--They had manuals for ATV's,motorcycles,lawnmowers,trimmers,etc.I've also seen FSM's available from Rocky Mountain ATV/MC I think this would make a good sticky;if the mods or admin would allow it...

      By dirtdevil96, in ATV Forums By Brand

        
      • 24 replies
      • 208,050 views
    • Kawasaki KLF 300 Bayou 4x2 service manual download needed

      Hi there I am in need of a manual for my KLF 300 Bayou 4x2 . I've found others on here for the 4x4 model, but was wondering if I need a separate 4x2 manual. Does anyone know?

      By JCH, in Kawasaki ATV Forum

        
      • 2 replies
      • 708 views
    • Quadzilla starting issue

      Hi I have a 2008 quadzilla 320e ,engine is sound but takes a lot of starting when left a day or so turns over well misfires ,change plug and starts straight up and will run fine and restart at the touch of the button anyone point me in right direction where to look  thanks

      By Gary Patch, in General Talk - Anything Goes!

      • 4 replies
      • 67 views
    • 1993 KLF300C bayou gasket issue

      Hi everyone, Just looking for some advice on a Bayou 300 that I am working on cleaning up and rebuilding. I bought the beast for 200 and am going to be into it for about 1200 all said and done. I decided after changing the oil three times in just around three hours of driving and having it come out completely black that something was up. That and the clutches were slipping. I believe now that the previous owners had not used the correct oil for the wet clutch system. Both were toasted and nearly metal on metal. Anyway, when I started opening it up I realised there was a massive amount of sludge and gunk inside so I decided to crack open the crank case as well to clean it all up nice while I had the motor out.  This is my question now, I cannot for the life of me find a gasket any where that is for between the two crankcase halves. Is that normal. There was gasket material that was between them originally that would not be reused. Can I just use a gasket maker like ultra black or something of the sorts or am I best off to get gasket material and painstakingly cut out all the shapes and lines and get a gasket made that way? Or does someone know where I could get a gasket? Thanks in advance everyone. Byron

      By Byron Tuininga, in Kawasaki ATV Forum

      • 2 replies
      • 70 views
    • 1990 Suzuki LT 4wd need help running issue

      my atv will start right up will idle fine soon as i try to throttle up engine dies,i have changed gas,new fuel pump and lines great compression 188 lbs.new coil new spark plug adjusted valves dont know what to do also rebuilt carb,any help wanted

      By joseph, in Suzuki ATV Forum

        
      • 34 replies
      • 750 views
  • Similar Tagged Content

    • By crazynordlander
      Hi All,
      I live in Minnesota and bought a 2016 CFORCE 500 HO. I am in hope to see if there is anyone in the US that is experiencing this sudden drop off in RPM below 4000 RPM. I have uploaded some videos of my issue on YouTube. I will list three of the four I posted. The fourth can be found on my channel but it is a comparison between my Polaris 570 and my CFORCE 500.
      I quit on my first dealer because we just did not mix well together. I brought it to another CFMOTO dealer that just became a CFMOTO dealer in January 2016. They are in a large ranch and agriculture area in a neighboring state that is pretty close to where I live. They have close to every brand available. They are a much larger dealer than the first one I bought the unit from.
      I brought the unit three weeks ago to them and they have worked on it a good solid week and have given up on it. I have read reports from owners in Canada that the dealers there were aware of the issue and have had success in fixing the herky jerky drivability issue.
      I am picking it up tomorrow and bringing it back home. It has been to the trails of the Black Hills this year and was new in late April. 300 miles on it. It has never changed. Very hard to ride on the trails or when I herd livestock.
      Here are the links to my videos.



      I can't accept that this is normal operation. Does anyone from CFMOTO China scan these posts?
      I need help that CFMOTO USA has not provided.
      Thanks
      Kevin
    • By atvfarm
      Ok Im new here. I was given a cougar 250 and i put a new carb on it and it will idle great but anything above low rpms spits and sputters. also is this thing suppose to have a fuel pump or just gravity feed from petcock?
    • By atvfarm
      Ok Im new here. I was given a cougar 250 and i put a new carb on it and it will idle great but anything above low rpms spits and sputters. also is this thing suppose to have a fuel pump or just gravity feed from petcock?
    • By Pure_Michigan
      I bought this old three wheeler that I found in a barn. It looked pretty rough, but I have it running now and functioning.
      With the switch set to "run" and the key in the "on" position the electric starter does not work when I push the starter button,
      However, if I cross the solenoid it will work and it will start the engine - so I know the starter motor is good and it works.
      Now, it gets a little mysterious. When the engine is running, AND the headlight is on high beam, the electric starter will engage when the starter button is pushed.....When its already running! (when the headlight is off or on "low" the starter button does nothing, only when running and in high beam will you hear the starter motor zing when you push the starter button) So, I know the button actually works, but only after the engine is already running and the high beam is on!
      So to recap: with the key on, the starter button does nothing. crossing the solenoid will make the starter work, and after the engine is running the starter will work with the button!
      Has anyone else had this problem? Can anyone point me in the right direction on solving this one?
      Thanks!
    • By biggreen2010
      ok it will start up an run but quits a lot till it gets warm, but has a bad miss an wont idle, I have a brand new Honda carb on it, good gas flow, new plug, but when I let the throttle go below a quarter, it backfires through carb an tail pipe:confused: so it has never had any electrical work or mechanical work done...it just started all the sudden, I'm think it may have ignition coil breaking down, or cdi box going bad...anyone had this trouble before? let me know what you did to fix it. thanks:skeptic:
  • Recently Browsing   0 members

    No registered users viewing this page.


×