TheJaspMan

AEM Announces Release of Premier Issue of Print Magazine

Recommended Posts

It’s been six months in the works, but AEM is proud to announce that the very first print edition will be released tomorrow and available to order advance copies.

What you can find in this issue, as well as future issues, are some new articles and interviews not found online. It’s full color and we are excited to share it.

The cost is $5 and you can contact us if you are interested in purchasing a copy. Contact me via [email protected] to order. We will also have an online store to purchase magazines, shirts and videos later this week.

febcover.jpg

aemlogo400.jpg

Share this post


Link to post
Share on other sites
  •  Like what you are reading? Please help us by sharing this content.


Congrats on the first print! Any community articles or blogs in your magazine?

Share this post


Link to post
Share on other sites
  •  Like what you are reading? Please help us by sharing this content.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  •  Like what you are reading? Please help us by sharing this content.
  • Similar Content

    • By crazynordlander
      Hi All,
      I live in Minnesota and bought a 2016 CFORCE 500 HO. I am in hope to see if there is anyone in the US that is experiencing this sudden drop off in RPM below 4000 RPM. I have uploaded some videos of my issue on YouTube. I will list three of the four I posted. The fourth can be found on my channel but it is a comparison between my Polaris 570 and my CFORCE 500.
      I quit on my first dealer because we just did not mix well together. I brought it to another CFMOTO dealer that just became a CFMOTO dealer in January 2016. They are in a large ranch and agriculture area in a neighboring state that is pretty close to where I live. They have close to every brand available. They are a much larger dealer than the first one I bought the unit from.
      I brought the unit three weeks ago to them and they have worked on it a good solid week and have given up on it. I have read reports from owners in Canada that the dealers there were aware of the issue and have had success in fixing the herky jerky drivability issue.
      I am picking it up tomorrow and bringing it back home. It has been to the trails of the Black Hills this year and was new in late April. 300 miles on it. It has never changed. Very hard to ride on the trails or when I herd livestock.
      Here are the links to my videos.



      I can't accept that this is normal operation. Does anyone from CFMOTO China scan these posts?
      I need help that CFMOTO USA has not provided.
      Thanks
      Kevin
    • By atvfarm
      Ok Im new here. I was given a cougar 250 and i put a new carb on it and it will idle great but anything above low rpms spits and sputters. also is this thing suppose to have a fuel pump or just gravity feed from petcock?
    • By atvfarm
      Ok Im new here. I was given a cougar 250 and i put a new carb on it and it will idle great but anything above low rpms spits and sputters. also is this thing suppose to have a fuel pump or just gravity feed from petcock?
    • By Pure_Michigan
      I bought this old three wheeler that I found in a barn. It looked pretty rough, but I have it running now and functioning.
      With the switch set to "run" and the key in the "on" position the electric starter does not work when I push the starter button,
      However, if I cross the solenoid it will work and it will start the engine - so I know the starter motor is good and it works.
      Now, it gets a little mysterious. When the engine is running, AND the headlight is on high beam, the electric starter will engage when the starter button is pushed.....When its already running! (when the headlight is off or on "low" the starter button does nothing, only when running and in high beam will you hear the starter motor zing when you push the starter button) So, I know the button actually works, but only after the engine is already running and the high beam is on!
      So to recap: with the key on, the starter button does nothing. crossing the solenoid will make the starter work, and after the engine is running the starter will work with the button!
      Has anyone else had this problem? Can anyone point me in the right direction on solving this one?
      Thanks!
    • By biggreen2010
      ok it will start up an run but quits a lot till it gets warm, but has a bad miss an wont idle, I have a brand new Honda carb on it, good gas flow, new plug, but when I let the throttle go below a quarter, it backfires through carb an tail pipe:confused: so it has never had any electrical work or mechanical work done...it just started all the sudden, I'm think it may have ignition coil breaking down, or cdi box going bad...anyone had this trouble before? let me know what you did to fix it. thanks:skeptic: