Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Sign in to follow this  
utvboard

Vision X Reflex LED Smart Light Revolutionizes Performance Lighting

Recommended Posts

Algona, WA– (10/01/2009) Vision X Lighting has launched the Reflex, the brightest, most efficient and versatile LED lighting system. Each light utilizes new 10-Watt LED technology providing ultra-bright 900 lumens per LED with the lowest amp draw. Available in seven sizes from 6" to 52", and only 2.5" tall by 2.5" deep, the Reflex is designed to fit in the tightest places. Mounting the Reflex

More...

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Topics

    • By Josh Cummins
      Bought this quad a couple days ago. Got it home and couldn't get it started. Got my new starter and recoil on. Starts up great. Took it for a quick spin hot light came on. Guess my question is there a way to test the sensor? If sensor is good what would be next step? Any other common checks I should do before throwing new parts at it?
       
      Thanks.
    • By Tiffany Rowland
      I am working on a Honda sportrax I just got my daughter for get birthday and the reverse and neutral light are not working. When I traced the wire down I saw that it wasn't plugged in but I don't see where it is supposed to connect. Does any one have a general idea of where I should look?

    • By Dimelol
      I have a 2003 Kodiak 450 that i purchased a while back with around 300 hours on it. It has never ran right from the beginning. Initially i thought it was just a carburetor issue because it was all clogged up from sitting for months. It has been cleaned, rebuilt, and taken off probably about 10 times troubleshooting this problem. I have quadruple checked everything including float height ect and it is set correctly, the jets are also brand new, needle and seat have been pressure tested as well. So after all of that I am convinced that the carburetor is not the culprit. I have an issue where the idle is very choppy, almost as if it is misfiring with a rich condition on top of that. I can use a brand new plug and run the machine for just a few minutes and it will be a dry and and coated in black carbon build up. The exhaust also has a strong smell at idle. I had trouble restarting it when hot for a while, but i adjusted the valves and it seemed to solve that issue. They were both way out of tolerance (tight). The weird thing is, outside of idle it seems to run pretty well. 
      So with all that being said I have ruled out the carb/valves/compression and moved on to the ignition and this is where i have a few questions about factory specifications. I guess the main question I have is, how strict are these tolerances? And could them being off by this amount cause the issue I am having? Do all three of these parts really need to be replaced? I would like to know before I spend the money on these new parts, and it not fix my problem. Below I will list what the specs were in the service manual along with the reading i got.  This is my first experience testing ignition components. I just found it odd that all 3 are out of spec according to the service manual.
      Spark plug cap resistance: 10 kΩ at 20 °C (68 °F)
      My Reading: 8.90 kΩ
      Primary coil resistance: 0.18 ~ 0.28 Ω at 20 °C (68 °F)
      My Reading: Fluctuated between 0.4 - 0.5 Ω
      Secondary coil resistance: 6.32 ~ 9.48 kΩ at 20 °C (68 °F)
      Reading was within the specified range.
      Pickup coil resistance: 459 ~ 561 Ω at 20 °C (68 °F)
      Reading was within specified range.
      Rotor rotation direction sensing coil resistance: 0.085 ~ 0.105 Ω at 20 °C (68 °F) 
      My reading was 0.3 Ω
    • By Stacy Hanks
      I have  2000 Yamaha bear tracker 250 - igniton relay and starter relay both were replaced also the neutral switch indicator was replaced-- bike will not show light on for neutral or start when button is pushed
       
    • By Jeremy SK
      MICTUNING 20.5 Inch  light bar  choose 60% off coupon before you order    https://www.amazon.com/dp/B075F39QYK/ref=cm_sw_em_r_mt_dp_U_revnDb1PKQ6C7  
  • Similar Tagged Content

    • By tperk100
      2014 Honda 420FPA
      I installed a LED bar, but have yet to wire it in. Would like to wire it into light switch circuit for low beams, assuming it will stay on for high beams also. I am an old fart so am looking for an easily accessible place if possible. 

      Other concern is current draw. It takes 2 amps. So wherever it goes, the circuit has got to handle an additional 2 amps.
      Any help will be appreciated.

      Tomn P in Sunny Virginia Beach, Va
    • By automatcentral
      I have a new PIAA RF6 light bar that I'd like to make available for review to any interested members. Please PM me if you'd like a free lighting upgrade.
    • By Billie
      :confused:need a repair manual or help in what to look for thank you Bill
      for you muddober to make clear to you the neutral light and the gear light
      do not light up win shifting fuses are good Iuse my CAt for hunting im dissable the atv is my leag s thank you
    • By stevebula
      Hello,
      i have a baja 250u wilderness
      and the neutral light wont come on
      hence i cant start it unless i pull start it
      any input would be great
      thanks
      the quad is in neutral and rolls just no light and no start
      thanks again
    • By bodatiouskid
      Help!
      Have an 02 Kawasaki Prairie 650.I replaced the belt & when I put everything back together the 2wd-4wd lights would flash back & forth.
      I read how to reset light,but my ATV doesnt have the black & gray wire connectors where they are supposed to be.
      Anyone know how to reset lights on this model?
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...