Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

weber

2006 can am outlander 800 display screen

Recommended Posts

i have a 2006 can am outlander 800 i bought it used and when you start it up it says hi david knight i was wondering if anyone knew how to change that

Share this post


Link to post
Share on other sites


* Changed thread title to include "2006 can am outlander 800"

That's pretty cool. I wish I knew.

Share this post


Link to post
Share on other sites

I would change it to Michael Knight, make the quad all black, and install a red led light strip on the front bumper that lights from one end to the other over and over. But, I don't know how you would change it, I bet a dealer service tech would though.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Steven Workman
      So I have a Honda Fourtrax 300 year 1988. The ignition doesn’t start it with no sound. The headlights won’t turn on. It has a brand new charged battery, fuses are good, oil is good, gas is good, reverse is rusted, it shifts good, won’t jumpstart but when you try it will turn over, it will start if you jump the solenoid give it gas and spray starter fluid on the breather but it won’t stay on long but will stay on for the little time it does by itself. I don’t know what’s wrong and I need help!
    • By RockOn
      So I bought a 2001 Quad Runner 250 for my son/wife. Sorry I run a Grizzly 660.
      I’ve rode it many times with no issue.
      My son’s first time out, I could always hear him but feeling he ran it red line in first gear a lot.
      So this is what it was doing during/end of the 2-3 hour ride:
      - halfway though noticed smoke (oil) coming from front of the motor sort of under exhaust manifold. Once back at the truck, it was really noticeable. Definitely oil burning off. I’m thinking from the top end maybe.
      So quick inspection:
      - No leaks or seepage of oil that I could see
      - I pulled the plug and it’s black but not wet
      - No blue/white smoke in exhaust
      - seems to still ride fine
      - Engine still has plenty of oil
      But now that I’m looking at it back at the house - it’s a hard/won’t start when hot. It starts right up cold no problem but once it stalls when hot, have to let it sit for 10-15 before it will start again.
      It wasn’t idling before that trip so I jacked up the idle a bit as well but I think that’s a carb clean/adjustment but...
      Any input is appreciated.
      Thanks for any help.
       
      Sent from my iPhone using Tapatalk
    • By bcsman
      So need some recommended maintenance I should do with my 1998 Foreman 450ES.  I didn't get much info as to what had been done so what's the things I should perform to start me from square one?  I'm not a mechanical genius but can do the basics.  I did adjust the toe today so I'm not a nooby.
    • By ATVPete
      I replaced the main , pilot and starter jets and it will not start , it wants to try and start , this is a fuel issue I think , what part of the carburetor might be plugged up if it will not start , any ideas
       
      2008 Honda TRX450R
    • By Brian T. Aichinger
      I have a 2017 can am 570 outlander max that is having issues with the powersteering going out and the speedo quits working. anyone else having or heard of these issues?  everything else on the display cluster is working and I hear no noises as far as the powersteering unit, the dealer did change the steering unit because of the recall.
  • Similar Tagged Content

    • By Kyboy
      Iam looking for help seperating the rear brake drum and the cover. Any suggestions would be greatly appreciate
    • By pickytar
      I have a Chinese Hybird 250 or that's what I was told it was. I found 17 numbers on the frame. Will these numbers tell me exactly what it is that I have? (I know that its a 2006 from a plate on the front)
    • By data89
      2005 Arctic Cat LE 500cc. This last year the led readout has basically faded to where you can barely see it. This cat is always covered or inside, when not riding, so it's not due to sunlight fadeout I don't believe. Where does it get its' power from Is it from ECU under the seat?
    • By kiwisteve
      Hi Folks
      MY Ltf 400 has power and electric start turns motor over, but wont start...
      seems no spark
      im told stalled in paddock and wont start again
      any suggestions please
    • By tmaterman
      Hi guys! First post here...bought a Bruin, as mentioned above from a buddy. It had been parked for a few years at his house..unused. Bought it from him at a steal and put a battery in it, new gas, etc...fired right up. It is cutting out now, but I suppose that is just the carb/fuel system needs a good cleaning. Ordered a new carb and hope that gets it going good!
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...