Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

nytroman

2002 Polaris Sportsman 700 Speedometer quit working

Recommended Posts

I bought a 2002 sportsman 700 and the speedometer quit working.what could be wrong?It has the digital read out for gear selector which works just the speedometer doesnt.thanks

Share this post


Link to post
Share on other sites


Could be a sensor or a wire, but my best guess would be that whatever moves the needle itself is broken. I would check the sensors, wires and plugs, if everything looks ok, then I would take the speedometer assembly itself apart and inspect the inside.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By kgard
      Hi all, I bought a 2018 used 450 for my wife. She is having trouble with some of the real rocky trails close to our home. Her arms give out in an hour or two so I was thinking of adding power steering . Is this possible ? Anyone done this ? 
    • By Steven Alter
      I have a 2018 450 and the digital gause has started flashing on an off while driving. The backlit also goes on and off. It is worse when I hit the gas. The battery died a few weeks ago and I jumped it but its been fine until last night. Called the dealer and showed them a vid and they recommend replacing the gauge and its like 600 bucks. The machine has less than 100 hours on it. I would really hate to have to change it out. also the unit sometimes has trouble starting. Any ideas?
    • By Steven E
      Hi
      Anyone else with a 2017 sportsman with EPS, experiencing hard lock up with the CVT clutches.
      As compared to my friends 2006 Polaris 500 HO they seem to be a lot smoother engagement.
      Any ideas or is this normal for this model.   
    • By joninak
      Well, it overheated then started blowing white smoke!!
      I have it torn down & the cylinder appears to be warped. Going to have the head checked out next but in the meanwhile... Does anyone have the torque sequence/specs for the head bolts??
      TIA
       
       
    • By Rick534
      whats do you think on over all
       
  • Similar Tagged Content

    • By Jean de la Chevrotière
      View File Polaris 700 2002 Owner's manual
      Polaris 2002 700 Owner's Safety and maintenance manual
      Submitter Jean de la Chevrotière Submitted 12/01/2018 Category Polaris ATV  
    • By Jean de la Chevrotière
      Polaris 2002 700 Owner's Safety and maintenance manual
    • By priglmeier
      I own a 2002 Can-Am Quest 650.
      It will start if you massage the throttle a bit and it will continue to run. BUT if you let go of the throttle and try to let it idle it will always die warm or cold.
      It has Non-Oxy premium gas, a new gapped NGK plug, a new carb (as of today) and fresh fluids. After installing the new carb it runs exactly the same.
       
      I only have a few things that I have observed since the new carb:
      The choke still doesn't do anything. It has a good cable and it is hooked up. It on fully off. There is a cable in the top, front of the engine that splits into two connectors. The connected side is in the photo. The other side has the yellow banded section and is not connected. I do not see anything in range of this connector so I don't know if this is normal or not??? The original carb wasn't really dirty or clogged. I'll use it as a spare. I don't see this cable and connectors listed in the Can-Am shop manual. Looking for some help. I want to ride!


    • By ut1w7b
      I have a 94 sportsman 400. It sat for several years before i got it. I have cleaned the carb it will start and run for about 5 min then it will flood. I have torn it down and cant see anything wrong. has anyone else ran into this problem any hel would be great.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...