Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

tawood

Need 00-01 Trailboss front rack

Recommended Posts

Hi,

I'm looking for a front rack for a 2000 or 2001 Polaris Trail Boss. PM me if you have one you would like to sell!

Thanks,

Tim

Share this post


Link to post
Share on other sites


Yes...and I've been checking for some time. Seems like lots of racks for every year but 2000/2001.

Did you ever find one? I'm also looking for one as well. I live in Michigan.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By colin james
      View File 2018/2019 Polaris Sportsman XP 850/1000 Service Manual
      This is the factory service manual for the 2018/2019 Polaris Sportsman XP 850/1000
      Submitter colin james Submitted 08/01/2019 Category Polaris ATV  
    • By Jeremy Morris
      If you're getting that pesky leaky seal on the pinion of your front differential and the pinion has allot of play, polaris won't sell the bushing needed to repair it properly without having to shell out big bucks for the complete ring and pinion kit. 
      I have a kit with an upgraded bushing, Japanese made bearing and USmade seal
      50 shipped in the US and 55 to Canada

    • By John Victor
      My father-in-law gave my boy a 1999 350 Big Bear. It's been sitting in a barn for a bunch of years. It runs great! My boy has been riding a couple weeks now and it has developed a squeal coming from the front end when you get off the gas at speed. No noise during acceleration. At first I thought brakes. I took it for a ride and I don't think it is the brakes. I feel it is the front prop shaft U-joints, front differential or one/both axles. I pulled the fill plug on the differential and I can't find anywhere how much gear oil should be in there. My gut says up to the fill opening. It doesn't have a manual. It's wet in there, just don't see any gear oil.

      #1 Should I fill the differential with gear oil up to the fill opening?

      #2 How do I check or know if the u-joints are bad? That looks like a "Big Bear" of a job if they don't need to be replaced.

      #3 What else could it be? I don't think it is the front bearings. I jacked the front wheels off ground and no play in the right wheel. Very little play in the left wheel, looks like the lower control bushing is where that play is coming from. The rubber CV boots look original but all still intact. Wheels spin easily without any noise.

      Thanks for any help!
    • By Chase Cook
      I have a Polaris sportsman 500 and I just replace the piston in rings and head gaskets on it and I made sure the timing was exactly right it's getting gas and fire but it still won't start. It sounds like it has low compression but at the same time it sucks in air pretty good from the intake. Also the valves are adjusted to spec. It did start the first time I installed the Piston and Rings but it only stayed running for 5 seconds with starting fluid and then it shut off and then I tried to turn on the next day and it didn't do nothing and I've been going at it for three weekends now and it still ain't doing nothing. I wonder if i set the timing off a little or a lot if it would start up, because I inline the crankshaft sprocket with the crankcase timing line like it said in a manual and the two points on top of the cam sprocket to top dead center of the piston. I even took the spark plug out and stuck a camera light in there to make sure it was top dead center and it still won't do anything. AlsoI drain the carburetor some and shut d fuel petcock off to see if it was getting too much gas and that still isn't the problem. And where I live all the darn mechanics that work on Polaris ATVs are booked for two weeks which sucks and I need hope immediately or I'm just going to set the ATV on fire because I'm getting very frustrated with this crappy brand. Every other name brand ATV I worked on I got it running right and I replace the piston, rings and everything etc, and they started up fine. But this is starting to get very frustrated and I don't know who to talk to who had this problem before, who "don't have to come look at it". Cuz when they say that that means you're not going to come look at it until 2-4 Weeks later because there booked, which I don't have time for. Living in northern part of Florida sucks.
  • Similar Tagged Content

    • By jefafa123
      so I seem to have some trouble getting my old 85 trail boss to put out a spark. when I first got it it fired just fine but had no compression. After I rebuilt the top end and tried to start it there was no spark so I got on the internet and ordered a used coil that came off of the same bike and it worked and ran good for about two weeks. When I really got the engine going good it would lose power and start to bog down but would quickly recover after a few seconds. Then one day it wouldn't starts and I found that it was not firing at all. Now I`ve put a brand new coil and there is still no spark. Everyone I know seems to think its the cdi box. However when I search on the internet everything points to the stator. Is there a way of testing either one?
    • By Joel
      Had a starter issue so I pulled it out cleaned it up and it
      Started so I took it for a spin and it died in the field I tried starting again and it seems to be jammed somewhere in where wants to turn the clutch but seems stuck any suggestions ??
    • By guitarzan
      Hello fellow members,
      I recently tore down my grandsons 1995 250 Polaris Trail Boss to replace the rings. Problem is, its been bored over and now mics at 72.60 at the top, and 72.54 at the bottom. I only honed the cylinder to remove the glaze.
      What size over piston and rings do you think I should use?
    • By Tim-ANC
      I love the 09 450 King Quad I just got. However the racks are anemic. I just happen to have a spare vintage (91-98) KQ rear rack and noticed the front frame attach struts are the same distance apart. Then the gears in my head started turning.

      I drilled holes through the side of the struts on the spare rack. Cut out a T-bar from a scrap bumper from a vintage KQ for the back attach point. Now I have a man size rack on my machine.

    • By Austinhuntman
      I went hunting this weekend and discovered that my crossbow is hard to carry on my kq. I carry deer on the front and I have a tool box and a gun boot on the back. Any ideas for how to carry it it is a Barnett jackel. Pics would be great
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...