Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

wjslam

2004 Yamaha Bruin 350 4x2 high idle when hot

Recommended Posts

New to forum and ATVs, so here goes. Bruin 350 has been rarely used, especially recently. Changed oil and filter, new plug, cleaned air cleaner and filled with fuel w/ Sta-bil added. Rode for 1-2 hours with no problems. When coming to a stop and left idling in neutral, idle increases to perhaps twice normal rpm. Jabbing throttle has no effect...when it returns to idle, still idles high. If I shut off the motor, it backfires once through exhaust pipe. When restarted, it idles normally for 10-20 seconds and then increases again. I don't want to jump to any conclusions at this point, and I do not have experence with small engines; however, I'm pretty good with Ford FEs. I appreciate any help/advice!

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By 06kfx440
      It’s been a pleasure serving all of you. I can not ride anymore. My illness has turned to the worst and I can barely walk anymore. I will still be here helping where I can. I might just get an oddsey and work the sh!t out of it. But I’m done. I didn’t want to be in this situation. But I have to take it. It’s been so much fun here guys!
       
       
      Sent from my iPhone using Tapatalk
    • By Dra O
      posted a while back - it was running at one point - I have all the plastic shroud off - it's down to frame and engine now
      -fuel pump: when line from petcock is attached, no fuel comes out other side to carb; the line to the carb is open (can blow through it); I thought when I cranked engine that the pump would spit out fuel on other side but it does not; I removed fuel pump and opened it up - diaphragm looks good - but internal areas had lotsa calcification build up - I cleaned this out and dried it good - the clear plastic pieces (?diaphragms) aren't broken - the spring w/ steel ball on end moves freely; am putting it back on tomorrow; but can anyone answer about the pump? isn't it supposed to pump fuel through it... to other side... to carb? puzzling
      -along with fuel pump: I replaced petcock 3 weeks ago (gas tank had rusty fuel in bottom - cleaned it out prior to new petcock); when I turn petcock arrow NOT to on or reserve, fuel comes out of line; when I turn it to on or reserve, fuel doesn't come out; puzzling
      -I don't know what's on back of fuel pump - it's a valve that has a hose coming out of it - looks like it goes to engine/carb - I haven't traced this out yet - what is it?
      -can squirt gas on air filter and engine will run for 2-3 seconds then stop - fuel in top of carb (under diaphragm) does same
      -it likely needs carb rebuild - will get to this - but something isn't allowing fuel to get from fuel pump to carb
      -I THINK it has a mikuni model x carb - diaphragm is ID 26mm  OD 68mm - hard to find inexpensive diaphragm, I guess because it's a model x
      -last thing - I replaced solenoid due to old one clicking; I HAVE to be charging the battery or it won't start/turn over - battery just goes dead; but if charging, it'll turn over nicely; i'm guessing it's a bad battery
      -any help appreciated - I've never owned an ATV before - inherited this beast from grandparent in-law
    • By James Jezewski
      Hey everyone! New to ATVs, hoping to learn a bunch off this site.
    • By therealjohnsmith
      I just bought these in the fall as a pair and of course they were running awesome with no problems at that time.
      One of them now will only start with starting fluid. It runs great once it's started, but absolutely refuses to start without a squirt of the good stuff.  The other one starts just fine, but dies after it gets warm. The only way to keep it running is to keep the throttle up. It won't run at an idle, and keeping it running has the throttle too high to shift.  Any ideas or suggestions are very much appreciated!!!
      Thank you,
      John from Shelley, Idaho
  • Similar Tagged Content

    • By Trenton
      Hello. I am a new member as of today. I had a quick question to ask. I recently was driving mt HONDA RANCHER 2004 GPSscape 400 and my display stopped working. I was driving the atv and all of a sudden the speedometer and the service lights went out. Also the lights stopped working. I am still able to shift gears, change from 2wd to 4wd, and can still select if I want EPS or Auto. I have checked my fuse box and have changed a few of them around. It did not change anything. I was wondering if anyone had any idea of what had happend. Thank you for your time- Trenton 
    • By LTZ-Zach
      So i was riding the other day and my quad randomly shut off. It started back up and ran completely fine for a little while and then it started idling terribly.
      I cleaned the carb and changed all the jets and everything except the float due to the rebuild kit not coming with one and it actually runs worse then it did before.
      It will run and idle decent now but when I give it gas it dies.
      Does anybody know what could be wrong?
      I also changed the spark plug and air filter along with the oil and oil filter.
       
    • Guest Fox300exchic
      By Guest Fox300exchic
      The Hop-Up: You may be saying to yourself, “that’s a chick bike,” and you’re right. But honestly, it’s so much more than that. It’s one badass bike. http://www.quadmagazine.com/quad/features/article/0,24942,1587044,00.html
    • By alexcross324
      Hi all, I try to find this manual in the threads but you have a lot of stock here
      Cannot find this particular manual.
      I found it for YFM200 but not sure if they are the same.
      Thanks if you could help me with that.
      Im new here so if I did something wrong, please tell me.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...