Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Recommended Posts

I'm having trouble with the E-ton thunder 90. The electric start has stopped working & for a while the horn would still work but has stopped as well. List of what I've done so far. Made sure the battery was good even tried my battery from my quad tonight & it did nothing I cleaned all plugin connection and put dilect grease on all of them. I pulled the starter and put some juice to it and it works. I pulled the housing apart for the horn and starter button it's good and clean inside. I checked the fuse on the hot wire comming off the battery It has the spline part comming out the side cover for a kick starter so I used vice grips to start it and checked the kill switch button it works and the key switch is working. I don't see any other fuses I can change unless their covered up. I have no owners manual for this quad.

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Dwight Williams
      Ok, so I bought this scream of a deal the other day - a 94 King Quad 300 for $40.00.  It's been sitting outside with no carburetor on it for about a year.  Its rusty, missing some parts, wiring is all cut up and spliced etc.  No seat, no racks but the plastic is all there minus the headlight housing.  Anyway, who can pass up a $40.00 quad right?  I get it home and looked at the sight glass for oil level, it's about 1/2 oil and 1/2 water.  I drain it, refill it and turn the motor by hand (recoil starter is missing) and it turns over just fine.  I worked on the wiring for about an hour and got it to turn over with the electric starter and got enough of it sorted out to get a spark.  Did a quick compression test, 70 lbs.  Wet test bumped it up to 90.  Ok, so rings and cylinder washed out with water for a year, not too surprised.  I thought 'what the hell' and sprayed some starting fluid in it and it ran for about 2 seconds - enough to show  it's got life.  Since then the compression has gotten worse, I can't get enough pressure to activate the carb diaphragm, therefore no fuel pump either.  The compression is now around 60.
        Anyway, my question is....is it worth it to try to get this thing going?  I tore the top end down today and the cam and one of the rockers is pretty worn.  I figured a top end job would be about $100 or so, depending on the condition of the cylinder but I'll probably have to put a cam and rockers in it as well.  Doing some research on ebay I figure I'll have to spend about $500-$700 to make the whole machine right again.  Much less just to make it run and use as-is but I won't really like it until it's right.  I don't mind doing the work, I actually enjoy it but I'm concerned about what all that water did to the rest of the internals, I can't really test it all out until I can make it run.
      I know it's a basket case but I'm not into it much at all, even if I do the top end and find something else wrong I'm still not out much.  I'm leaning toward ordering the top end parts and going from there unless you can convince me otherwise - any way to check the rest of the internals without tearing it down?  I plan on flushing the oil cooler before I do another oil change, I've drained it twice now and it gets milky almost immediately just turning the starter - I suspect the oil cooler is polluted badly.
       
      I'll get some pictures today if anyone want to see them.
       
      thanks!
    • By Adrian Ciotinga
      Hello,
      I recently picked up an ‘07 KFX 700. All was going well, rode it about 40 miles, when it started bogging at low speeds. If I kept the revs higher, I was just fine. Also, a persistent issue since I picked it up is the fairly difficult start (but it is abnormally cold right now and the quad is jetted for the dunes at summertime).
      Regarding the complete lack of idle, I have to rev it a couple times to get it to idle after starting it, after which it’s 50/50 whether it remains idling. I don’t have low fuel, but all of this began after I rode it pretty hard and the radiator fan kicked in. Might be overheating, just wanted to hear your opinions.
    • By Skhot K
      Hello! I picked up a YFM400 and I would love to talk shop with knowledgeable co-owners, and I'd love input about the machine from anyone here who clearly knows more than I do! Cheers from NY
    • By YamahaBB350
      I have a Yamaha Big Bear 350 and the reverse doesn’t work, it shifts from low to high easily but it won’t go back to reverse. I’m new to this stuff, so I’ll take any help. Any ideas? 
    • By Mike8623
      OK guys, Ive got a 1996 suzuki king quad 300. Just where and how do you get to the CDI unit on these? Is there a way to check these if you dont have the suzuki tool or meter?
  • Similar Tagged Content

    • By outodoors
      I recently purchased a Suzuki lt50 quadrunner? for my son, when i got it home I was able to get it running. But it had been sitting so I figured best thing to do was to clean out the tank and to start with fresh gas, replace spark plug etc. Now it wont start. So now I have a very frustrated 4 year old who really wants to use it but I am at a loss, I am a certified auto mechanic but I can not seem to figure out why this wont fire, I have spark, I have fuel (although not as much as I think it should), the bowl on the carb is full, but no start. Help please,
      Also can someone point me to a place to get a service manual for this thing?
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...