Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Goodwrench

2005 Suzuki Eiger 400 - Mud/Fender Extensions

Recommended Posts



Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By mmmPUDDIN
      I've had this machine for 2ish years, has ran great up until winter. Sometime during then, I managed to break the exhaust right before the muffler. The summer before it had a hard time idling, but we fixed it by cleaning the carb, and messing with idle. Near the end of last year, the only way for it to fire was the have full choke, and full throttle, and the engine bogged down and you had to keep on throttle for 25mins. Over winter, the throttle had dislocated, and I got it back in place. We got it running, and all was good. Spring came along, and now it doesn't start at all. A fluid is coming out of the exhaust, and I'm told it could be water from over winter. I checked the airbox, and the air filter isn't for this quad, it also is barely sucking air. There appears to be little to no compression, based on this. I'm pretty sure the engine is flooded, as the spark plug produces a spark, but is oxidized. I don't know how the previous owner treated it, or when it's last oil change was. A bolt on the engine has either oil or gas seeping through it,abd was loose. I tightened it and it consisted. The engine is basically positioned in the rear, and it needs a good clean, I don't have a pressure washer, so I can get the built on dirt off. any recommendations on how to get the beast started again?
    • By Ron Boyd
      I was wondering if the complete headlight assembly from a 06 yfz450 would fit my 05 raptor 660r looking for a quick responses I found a set new for 25 bucks and either way dont want to pass up but was qurious.
    • By John Dunn III
      Just bought a LT 230 anything I should watch for. It runs and drive good. Just don't want no surprises 
    • By mrfartsalot
      I have a 2001 suzuki quadmaster 500 4x4 automatic and i was wondering witch atvs it shares parts with i know it shares some with artic cat. Any info would be helpful.



    • By crochet homemade
      I have bought a 1996 suzuki king quad 300 and I have noticed that it smokes but I have put oil in it and plenty of gas had to fix shifter bc the nuts and bolts came out somewhere. I have had to replace the wire for the starter but now when I try to start it it wont idle at all and when it does run it smokes really bad like a whitish blue I guess, and it likes to stall a lot. So anybody can help me out please and thank you

      10000000_310855426253462_714534016610467840_n.mp4
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...