Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

jeffreyscott

need a little help with fluids

Recommended Posts

im going to change all the fluids in my polaris sportsman 500 ho but all i found was the oil filter so far and i have no manual on it so if could get a little help i would really appreciate it and what type of oil and gear oil could i use besides that hi dollar polaris stuff thanks jeff:skeptic:

Share this post


Link to post
Share on other sites




thanks alot for your time i got it and it worked just fine this time i dont no what is the problem with you sendit.com but for some reason it wont let pull it up thanks jeff

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Christian Brindle
      I have a 2000 Polaris Sportsman 500. A year or so ago we got it running after replacing the kill switch. It ran great but after some use for a couple months it got a flat tire and for some reason we just forgot about it and it sat for some time. Before it sat i replaced the gas cap, fuel filter, fuel pump, petcock, battery, starter relay, oil and oil filter. I recently went to start it and it started so quickly and without choke or throttle but the ATV wouldn't move till about 1/4 throttle and it wasn't really a smooth ride until 1/2 throttle. it also would bog out randomly after you came to a stop and sounded like it was getting too much fuel. I cleaned the carb and adjusted the air/fuel screw to 1 3/4 turns out.  I also messed with the idle and the throttle cable adjuster up on the handlebars. It's safe to say it now runs worse than when i started working on it 2 days ago. It takes more effort to get started and bogs out idling after about 30 seconds. I tried adjusting the idle but every time i do it'll get to a sweet spot but after driving it down the driveway and back the idle will go up and down to the point where i can't put it in gear because the gears will grind. Any thoughts or ideas would be greatly appreciated. Thanks
    • By StolenATV
      Red Honda Pioneer 700 side x side and child’s Polaris outlaw 50cc both on black Echo ATV trailer stolen 12:30 pm Last Night 10/14/19 from S Garfield St and Mississippi, in Denver, CO seen going south from 1100 block. . I have reported this information to the police. Suspect Vehicle Black Power Ram Truck w/ NY plates
      The post Stolen Red 2017 Honda Pioneer 700-4 deluxe and Gray multi-colored 2019 50cc Polaris Outlaw appeared first on STOLEN 911.
      View the full article
    • By Flipper Tiffany Roper Jones
      All I have been through everything. Bought brand new.
      Throttle safety switch 
      Cam and rockers
      ECM
      Carborator
      Stator
      Fuel safety switch 
      Battery
      Everything every forum has spoken of I've bought sealed airbox completely tight unplugged black wire on trans. I have literally done everything in the book.Checked oil today full of gas anyone no anything what might b wrong. Next I'm taking head off and making sure valves seat any ideas.
    • By Larry Fox
      I have a 2017 1000s. Should I be worried that it will catch fire? 
    • By Larry Fox
      Just bought this ATV. Wondering if my gauge from a 2003 will plug in and work. I know mine does not have a fuel gauge, but if the rest works, I am in. 
  • Similar Tagged Content

    • By Mustangiiman01
      Since I am new to having a quad I am looking as to how you check the oil and transmission   I have a 1998 Suzuki king quad  4wd  engine is a 280. I have found a plug at the back of it that says 10 w 40 on it. And a site glass up under front of back wheel on right side.  And looks like there is a plug above it.  Now do I put  the oil in the back plug till it starts to run out  or somewhere else to check it  site glass seems a little far from it.  Or site glass maybe for transmission.  Thx for any help
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...