Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Recommended Posts

Does anyone know where to get a winch mount for a 1995 Kodiak 400? I can't seem to find one anywhere on the internet.

Share this post


Link to post
Share on other sites


wparker68

did you get a mount? I am looking for one for my 95 Kodiak 400 4x4

Do you have a model or part number

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Tagged Content

    • By M0BJT
      Hi Everyone
      This is my first post and I was wondering if there is anyone who can help me solve a problem I have with my Yamaha Kodiak 400 4x4 Fitted with a Mikuni Carburetor . The year of the quad is around 1998, the reason I am not sure of the date is, there wasn't any paperwork and no details on the frame either.
      The quad had a bad leak from the carb overflow which indicated that the float needle valve was blocked or passing so I replaced this and put everything back together. The quad ran really well until I took it onto some rough ground to have a ride around, a few hours later the engine started to run really rough as if the engine was flooding. I have removed the carb again and cleaned the needle valve out and the whole of the carb just in case there where any dirt behind it. Engine now runs fine again but fuel has started to run out the carb overflow again.
      I have tried everything to try and stop the fuel leaking out the overflow but its still happening. My last thoughts where to adjust the float level and its still happening.
      Has anyone got any thoughts on the problem or could suggest whats causing the fuel leaking out the overflow.
      Thanks for reading
      Kevin
    • By Billie
      :confused:need a repair manual or help in what to look for thank you Bill
      for you muddober to make clear to you the neutral light and the gear light
      do not light up win shifting fuses are good Iuse my CAt for hunting im dissable the atv is my leag s thank you
    • By kiwisteve
      Hi Folks
      MY Ltf 400 has power and electric start turns motor over, but wont start...
      seems no spark
      im told stalled in paddock and wont start again
      any suggestions please
    • By greatwhite
      I looked through many of the threads and could find it was wondering if anyone could post a link to a PDF Service Manual 2008 Kodiak 450.
      I found one for 2005 but I am sure there are differences.
      Thanks all
    • By izzydum1
      Any ideas on what would make a coil not fire? She was running fine, then began slow start. Now wont start at all.
  • Similar Topics

    • By Hodadical
      I've inherited a 1995 Lakota 300... it has the knob in the center of the handbar to twist to go into reverse, but I've notice when downshifting, you don't have to have the knob turned, it will shift right past neutral and into reverse which is a little dicey if not all the way stopped. I followed the linkage back and twisting the knob seems to actuate the lever on the outside of the trans, the internals just don't seem to care about this. 
      What is the likely problem and how back is it to get to? I've never been inside of one of these transmissions.
      TIA,
      -Rob
    • By RCNY1
      Hi folks, I recently purchased I believe an 02 Kodiak 4 x 4 it was stored outside, put a new battery in it still nothing kept playing around with the shifter suddenly the neutral light came on and it cranked right over no problem few days later same issue this time I can’t get the light to come on anything common I should be looking for ?
    • By fortininers
      Hi all, 
      just bought a 2005 Yamaha Kodiak 450. Was curious about any major issues Some of you might of had. Will be using in winter conditions with a snow plow.
      thanks!
    • By Spartacus Stroppel
      So I have a 2001 Kawasaki prairie 300 I could not find tough country snow plow... it's a older plow too boot... so I made the plow mount and updated the plow with some skids.
      Mount plate is 1/4 steel plate and so are the pin points
      The skids are off a moose plow. I got some plumbing black pipe for holders to weld to the blade and braced it with pieces left over from the plow mount 1/4 steel...
      1/4 plate cost $45
      Skids cost $24
      U bolts and other hardware where $20 
      I got the blade free







  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...