Quantcast
Jump to content

  • Do you own an ATV, UTV or SxS? Join our Community Forum!

    QUADCRAZY ATV Community and Forum are FREE to join! We keep our ATV, UTV, and SxS forums clean and user friendly. All first time posters in our forums will have to wait to have their content reviewed and approved. Once your first ten posts are approved, you will no longer need to go through a forum post approval process. To bypass the approval process with immediate access and a NO ADS experience in our ATV, SxS, and UTV forums, consider subsribing to a Premium Membership

2012 CAN-AM RENEGADE 1000---$3.500 (Maple Grove)


Recommended Posts

(This Ad is from QUADCRAZY Classifeds, click "More" to find out how to contact the person who placed this ad.)

2012 CAN AM RENEGADE 1000 PERFECT CONDITION 67 HOURS 370 MILES UNREAL MACHINE, 6" CATVOS CUSTOM POWDER COATED LIFT,FRONT AND REAR GORILLA EXTREME DUTY AXLES, TRIANGLE ATV SNORKLE KIT INSTALLED BY TRIANGLE THEMSELVES, EPI MUDDER CLUTCH KIT WITH EPI MU...

More...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Forum Topics

    • By huntindog
      I am in the process of puting it back together after replacing the DPS gearbox.
      The manual I have states that it will need to be flashed by a dealer. Is this still true?
      Also , I have a mystery bolt That I cannot remember where it goes. M6x 70 or so.  Hex head with a flat washer.I will try to attach a pic.
      Pic is no go for now....Cox issue I will try again later
      TIA
    • By Sofaspud
      My 2008 can-am Outlander 800r is having hard shifting issues. Does anyone have a fix for this ?
    • By Uglyside38
      Anyone have experience using Meier aftermarket plastics? OEM ones are shot on my quad I'm restoring and I have them "Frankenstein'd" for now...🤦🏼‍♂️😬
      Just curious on opinions on Meier as that seems to be the only place I can find any type of replacements. (And they're pretty pricey!)
    • By carlneedwindshield
      does anyone know if Flex A Fab has good stuff for my Maverick?
    • By Gwbarm
      Im finishing up on the Big Bear, just tying up some loose ends and its done.
      My next project I actually bought first, but the Big Bear seemed like it was more challenging so tackled it first. Now looking the Eiger over im not so Sure.
      I bought this Suzuki Eiger, almost a year ago, rear wheels locked up, but it ran fairly well. It was so bad that it took 3 Big Guys to get it on my trailer. All the parts were there it ran. He wanted 600.00 and I offered him 400.00. a plus it had the original Kei Hin carb on it.
       
       

       

      You might ask, why would you want something so ugly, it is often referred to as the ugly sister to the King Quad. I actually like the Eiger I have this one and also a 2007. I have riden them before, they are strong a true beast, I am a fairly Big Guy 6' 3" 195 pds, and it fits me good, but what I really like is the wide foot print and low center of gravity , not so easy to turn over.
      So I get it home and I don't have 3 big guys to help me get it off my trailer, but I do have a John Deere, hooked it up and drug it off the trailer,an afterthought I should have used a couple of furniture moving dolly's under the rear wheels, oh well. Maybe I didn't ruin the already stuck rear end or transmission I was sure which, I was fairly sure it wasn't locked brake drums, after all that they should have popped free.
       This is what I have done so far. It's off the trailer I took the drive shaft bolts loose, they were tight, had to get a 3 foot cheater, I thought they were going to break. Got them out and now I can roll it around. I checked the shifter, this is a manual shift Eiger LTF400F. Foot shifter moved didn't seem to be going to any gear, but it was hard to tell, the shifter on the tank which has Low, High, and Reverse did not move. I took it apart and oiled it up good still wouldn't move. Thought the cable was stuck so I unhooked it from the linkage and cable moved freely. Looked at the linkage closely and it was stuck. I tapped it lightly, very lightly , with small hammer and it freed up kind of, but still stiff. I could tell this side cover had been off before and put back very sloppily. This is kind of where i left off except the plastics are all off, you might have seen me working on them in another post. Nothing I have done so far has helped, my next step was to take the side cover off the engine to see what's going on in there, but installing my Granite counter top, numerous honeydews, and the big bear kind of slowed down my progress. I did determine that it wasn't the rear end, that's actually what I thought it was going to be. If anyone has any ideas, they would be appreciated.  
       
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...