Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Recommended Posts



I'm assuming its an electic fuel pump? What YMM is your ATV?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Brad Leeson
      What's going on party people? First, thank you for allowing me the opportunity to be here. I recently purchased a 2005 yrs 450 and have yet to run the bike at full throttle. The bike fires up, idles, seems like everything runs fine except a little popping when you let off the throttle or until you hit 5th gear. It runs strong; no bogging or sluggishness until you hit 4th gear and open it up. Then it begins to act like it's out of gas or the about to be out. I can pull over and sit for 5-10 min and it runs strong again until you open the throttle. I have the carb off the bike to clean and wrote down a list of factory and what I found installed. I also listed other key factors and hope someone can help and explain. I'm new to the scene and have no prior mechanical experience but my theory is worst case scenario I have to take it to the shop anyway so why not learn. I actually enjoy it. Lol. Thanks a million. Hope to get back on the trails soon. 

    • By David Barsukoff
      Hey, I just bought the kids a LT80 and noticed a small puddle under the machine after they were riding it for a bit. I'm wondering if anyone knows why the fluid coming from the fuel shut off is a red colour, and would have any ideas of where this issue is coming from? I haven't had a real good look at it yet, thought I would ask first. 

    • By Alex91
      I have a 92 suzuki king quad that seems to be getting way to much fuel in my spark plug hole as I took out plug cranked it over and covered myself in fuel I cleaned carb and fuel filter and fuel pump all seems fine any other ideas
    • By Zach Jump
      Hello...first post.
      Have a problem I have not been able to figure out.  
      While back the fuel pump went out...replaced it.  I got maybe 30 minutes..maybe less before the new one went out.
      Replaced it again...same thing. Now I am sitting with two more new fuel pumps in reserve but do not want to experiment and blow out another until I have a clue of what could be wrong.
      Have checked electrical...seems to be fine but I am no expert. Also the fuse is just fine.
  • Similar Tagged Content

    • By Brad Leeson
      What's going on party people? First, thank you for allowing me the opportunity to be here. I recently purchased a 2005 yrs 450 and have yet to run the bike at full throttle. The bike fires up, idles, seems like everything runs fine except a little popping when you let off the throttle or until you hit 5th gear. It runs strong; no bogging or sluggishness until you hit 4th gear and open it up. Then it begins to act like it's out of gas or the about to be out. I can pull over and sit for 5-10 min and it runs strong again until you open the throttle. I have the carb off the bike to clean and wrote down a list of factory and what I found installed. I also listed other key factors and hope someone can help and explain. I'm new to the scene and have no prior mechanical experience but my theory is worst case scenario I have to take it to the shop anyway so why not learn. I actually enjoy it. Lol. Thanks a million. Hope to get back on the trails soon. 

    • By Paul Maple
      I have a 1999 Sportsman  500, it was running fine, than started to lose power in the winter, I adjusted the idle screw and away I went, than a few weeks ago it died, I have found that i am flooding the engine, compression was at 70PSI and due to the compression release mech. i assume i am good as it compared to the same PSI on a 2000 sportsman 500 i have. i cannot start the atv unless i go full throttle and it starts an runs for about 30 sec than dies, again it is flooded. i ordered a new carb off ebay as i could get one for around $40. put that in same issue, i have checked the timing, (good), valves out of adjustment i adjusted to .006 still same issue, i have found the exhaust lobe and rocker arm to have some wear, i have ordered new ones, but am looking for any other input in this area as well. would the exhaust cam and rocker arm cause the engine to flood? i have used a bore scope and the piston liner has good cross hatching still? any input would be great.
    • By Christopher Lee
      What should I do?
    • By Resurgence Small Engine Inc.
      This past spring, Jonathan worked on a 1991 QuadRunner 250 that came with the fuel pump removed. We didn't find good information about connecting it online, so we made a video.
      Below is the link to watch Jonathan describe the connections on the Suzuki fuel pump. This applies to both the Quadrunner and King Quad ATV models.
       
      Hope you find it informative!
      Resurgence Small Engine Inc.
    • By jnahnet
      Fuel line hose has a pinprick hole. And tips, suggestions or warnings about how to change it out would be appreciated.

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...