Quantcast
Jump to content

break pads


Recommended Posts

  • 2 weeks later...
  • 2 months later...
  • 11 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Forum Topics

    • By dalton7545
      ive had an account for years.   cand dowload a manual tho   havent posted enought so here is a post
    • By cosmacart
      Hi all, iam from ohio and i have a 2013 yamaha rhino SE black . I might sell it but i dont know what its worth. So can anyone give me an idea what to ask for it?? This is not a scam,,its only a question thanks in advance!!
    • By dvs1961
      Just bought a new hisun ,been shopping for a year or more for a sxs   best bang for the buck...Are there any lift kits out there for a 2022 Hisun 750 sector ? links thanks
       
    • By Gwbarm
      I just heard Tommie Smothers died, I watched his show in the 60s, it was a great show one of the best. He will be missed, if not for Mom liked you best, then definately for YOYO MAN and his state of YO.
    • By 97kingquad
      Okay so I bought this 1997 sazuki king quad from a guy and he had it for a few years. 
      He had it registered and on the trails last year but he said it bogged and backfired when he would try to drive it. so it sat for a year. 
      I bought it for 800 bucks and got it running that night and it ran great for a few days 
      But I parked it the other night and went to start it again and it was really hard to fire up and when I did it was bogging and idling high then low again.
      So I took the carb out and cleaned it (ended up doing it twice because it was still doing the same thing) 
      Now today I have it running slightly better, but it is still like 20% 
      I have been looking it up and trying to figure it out but I can't find the issue, has anyone else had this problem? I'll attach a video of it running and giving some throttle 
×
×
  • Create New...