Quantcast
Jump to content

  • Do you own an ATV or UTV? Join our Forum!

    Join QUADCRAZY ATV Forum today for FREE! We keep these forums clean and user friendly. All first posters will have to wait to have their content reviewed and approved. Once your first post is approved, you will no longer need to got through an approval process. To gain immediate approval and a NO ADS experience, consider subsribing to our Premium Membership.

Yamaha Breeze 125 - Ignition Problem


dlow8
 Share

Recommended Posts

Hello everyone. I have a yamaha breeze that I am having some trouble with. I have a fully charged battery, but when I turn the key I don't get in dash lights (neutral) or headlights... I checked the fuse above the right side tire, and found that it was good. When I shift the quad into reverse, the "reverse light" illuminates, but when I go back to neutral I get nothing. Any help on where to start would be appreciated. I do have a tester, just need to know where to start. Thanks.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


×
×
  • Create New...