Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

outodoors

New here needing some help

Recommended Posts

I recently purchased a Suzuki lt50 quadrunner? for my son, when i got it home I was able to get it running. But it had been sitting so I figured best thing to do was to clean out the tank and to start with fresh gas, replace spark plug etc. Now it wont start.:aargh: So now I have a very frustrated 4 year old who really wants to use it but I am at a loss, I am a certified auto mechanic but I can not seem to figure out why this wont fire, I have spark, I have fuel (although not as much as I think it should), the bowl on the carb is full, but no start. Help please,

Also can someone point me to a place to get a service manual for this thing?

Share this post


Link to post
Share on other sites


Did you clean the carb? If not, try that. Remove both jets to make sure that they are clean and blow everything out.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By JustRandy
      After looking at the wire diagram I saw the blue w/black stripe wire is coming from the neutral and reverse lights looking for ground thru the neutral and reverse switches. If it finds ground, the lights come on. The same wire also comes from the neutral relay looking for ground at the same neutral and reverse switches. So it was easy to trick the relay into thinking the engine is in neutral all the time without having the light on all the time. Just cut the blue w/black wire at the relay and ground it. Easy
      Sorry the pics aren't better




      Now it starts in any gear and indicator lights work as they should.
    • By Jeff Miller
      I'm trying to troubleshoot a starting issue. For a while, maybe a year sometimes I would hit the starter button and I'd hear a single loud click, but the starter wouldn't turn. Usually if I could pull the pull start or roll it in gear it would then start. (now I'm thinking that was coincidence) Now it only clicks. I tried to check what I could, battery is good, solenoid clicks strong, cleaned all connections (which were 80% clean anyway). I started thinking the starter wasn't spinning. I pulled it and it spins freely. The gear that it contacts in the engine-I can wiggle it maybe 1/16th to 1/8th inch back and forth. When I reinstall the starter I feel it jerk when I hit the button. I'm thinking maybe it's the starter clutch? It seems when there's a problem with them they usually just spin freely and don't engage at all. Is it possibly something is causing it to lock? I'm a bit lost now.
    • By pablo Blake
      Its in pretty rough shape and its gonna be my first atv, I worked on bikes before but nothing to do with quads. Anyways the quad has some problems and im tryna figure out what to focus on first. So the U joints i think are shot. The bike starts first try every time ussually have to give it a lil gas with the throttle and revs right up, idles fine but its running REALLY rich 3 starts and my brand new plug was pitch black

      Bike is L model

      video-1577465068.mp4

      Its using the original mikuni carb but im not the best at fixing the carbs and wondering if there is anywhere online that would be able to either walk me through it or help me with it i didnt see a air mixture screw so it seems like im gonna half to open it up and adjust like the float and a couple other things
    • By Jerry Hebert
      1985 Lt50 no spark from aftermarket coil . Are these Suzuki coil specific ??
    • By flyinbrian365
      View File 1987-90 Suzuki LT 500R Quadzilla Service Manual
      1987-90 Suzuki LT 500R Quadzilla Service Manual. Full version clear pages
      Submitter flyinbrian365 Submitted 07/21/2020 Category Suzuki ATV  
  • Similar Tagged Content

    • By hangingon
      I'm having trouble with the E-ton thunder 90. The electric start has stopped working & for a while the horn would still work but has stopped as well. List of what I've done so far. Made sure the battery was good even tried my battery from my quad tonight & it did nothing I cleaned all plugin connection and put dilect grease on all of them. I pulled the starter and put some juice to it and it works. I pulled the housing apart for the horn and starter button it's good and clean inside. I checked the fuse on the hot wire comming off the battery It has the spline part comming out the side cover for a kick starter so I used vice grips to start it and checked the kill switch button it works and the key switch is working. I don't see any other fuses I can change unless their covered up. I have no owners manual for this quad.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...