Quantcast
Jump to content

IDFYF8

Members
  • Content Count

    2
  • Joined

  • Last visited

Community Reputation

10 Good

About IDFYF8

  • Rank
    Forum Beginner
  • Birthday 10/26/1971
  1. It's a 2009 and the hop only occurs during loss of traction times with more than 1/3 throttle.
  2. Hey All, This is my first post about my first quad, so needless to say, I'm a newby! My wife suprised me with a brand new Suzuki 500 axi for Christmas and I absolutely love it, but I do have a couple of issues I need to work through. First, the tires are ITP Terracross 26x9x12 front and 26x11x12 rear. They are 1" taller and wider than stock. Shouldn't be an issue, right? I went through some snow covered forest roads today and discovered I'm suffering severe wheel hop on the front when clawing for traction. The stock size tires did NOT do this, but then again, they just spun (stuck) in similar conditions. The Terracross tires just chewed down and I kept going forward. Never got stuck but I was afraid I was going to snap an axle or blow the front diff. I powered down and kept the hop to a minimum but I'm VERY uncomfortable with the setup as it is and am considering putting the stock tires back on but hate their lack of traction. HELP. Seriously, any suggestions. I cranked the front spring settings up two notches to try to remove the severe dive this quad has, but it did not help much. The front suspension just seems WAY too soft. Thanks for any advice you can offer! Jim

×
×
  • Create New...