Quantcast
Jump to content

Search the Community

Showing results for tags 'lt80'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Community Discussion
    • General ATV Discussion
    • General Talk - Anything Goes!
    • New Members Area!
    • Where To Ride Your ATV
    • ATV Picture and Video Sharing
    • ATV Racing & ATV Events
    • ATV & Off Road Modifications
    • ATV Tires and Rims
    • This vs. That ATV & Off Road Comparisons
    • ATV Trailers, Haulers, and Attachments
    • Hunting, Camping, & Outdoors Forum
    • ATV Laws, Legal Issues, and Policing
  • Regional ATV & Off Road Forums
    • Northeast ATV & Off Road Forum
    • Midwest ATV & Off Road Forum
    • South ATV & Off Road Forum
    • West ATV & Off Road Forum
    • Other Region ATV & Off Road Forum
  • ATV Manufacturers
    • ATV Forums By Brand
  • UTV Side x Side Manufacturer Specific
    • UTV & Side by Side Forums By Brand
  • Other Powersports, Offroad, and All Terrain Vehicles
    • Kids ATVs and Youth Off-Road
    • ATC 3-Wheeler Forum
    • Dirt Bike Forum
    • 4X4 Trucks and Jeeps
    • Water, Snow & Other Powersports
  • QUADCRAZY Classifieds
    • ATV For Sale? Post it here.
    • Stolen ATVs
  • QUADCRAZY Supporters
    • ATV Links & Partners
  • ATV News, Magazine Articles, Product Reviews
    • ATV News, Articles & Press Releases
    • New ATV Products, Reviews & Tests
    • Manufacturer & Aftermarket Promos
  • QUADCRAZY Announcements & Support
    • Announcements/Support
    • Website How To & Feedback
  • Yamaha Grizzly Owners's Topics
  • New York ATV Riders's Group Forum
  • Michigan ATV Club - St Helen, Mio, West Branch, Rose City's Lets ride Michigan trails this season!
  • Michigan ATV Club - St Helen, Mio, West Branch, Rose City's Up coming season
  • Kawasaki Bayou 220 Restoration and Repairs's Topics
  • Ride Red's Ride Red Forum
  • Ride Red's Videos
  • NYC 2 Poconos/ Scotrun ATV Riders's ATV Upgrades
  • NYC 2 Poconos/ Scotrun ATV Riders's Quads
  • Mechanics Club's Topics

Categories

  • ATV News and Articles
  • ATV New Products & Reviews
  • ATV Racing & Events
  • ATV Ride Reports
  • ATV and UTV Vendors

Calendars

  • Community Calendar
  • ATV Racing Events
  • ATV Poker Runs and Riding Events
  • ATV Swap Meets
  • Other ATV & Off Road Events

Categories

  • ATV Repair Manuals
    • Arctic Cat ATV
    • Can-Am BRP ATV
    • Cannondale ATV
    • CFMOTO ATV
    • Hisun ATV
    • Honda ATV
    • Kawasaki ATV
    • Kazuma ATV
    • Kymco ATV
    • Polaris ATV
    • Suzuki ATV
    • Textron Off Road ATV
    • Yamaha ATV
    • Other ATV
  • ATV Owner Manuals
    • Arctic Cat ATV
    • Can-Am BRP ATV
    • Cannondale ATV
    • CFMOTO ATV
    • Hisun ATV
    • Honda ATV
    • Kawasaki ATV
    • Kazuma ATV
    • Kymco ATV
    • Polaris ATV
    • Suzuki ATV
    • Textron Off Road ATV
    • Yamaha ATV
    • Other ATV
  • UTV Side by Side Repair Manuals
    • Arctic Cat UTV
    • Can-Am BRP UTV
    • Hisun UTV
    • Honda UTV
    • Joyner UTV
    • John Deere UTV
    • Kawasaki UTV
    • Kubota UTV RTV
    • Polaris UTV
    • Textron Off Road UTV
    • Yamaha UTV
    • Other Brands UTV
  • UTV Side by Side Owner Manuals
    • Arctic Cat UTV
    • Textron Off Road UTV
    • Can-Am BRP UTV
    • Hisun UTV
    • Honda UTV
    • Joyner UTV
    • John Deere UTV
    • Kawasaki UTV
    • Kubota UTV RTV
    • Polaris UTV
    • Yamaha UTV
    • Other Brands UTV
  • Other Files

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


About Me


My Garage

  1. So where to start my son's LT80 stop running a couple months ago. Naturally I assumed I had a carburetor issues or the peacock valve. After replacing those two items and ensuring I had a spark I started doing my homework thus finding this page. After all the post I have read the next natural thing would be compression I did a compression test today and it was only 60 after spraying WD-40 in it so off comes the cylinder head and The Jug to my surprise the cylinder walls and all the gaskets are pristine so I am totally stumped no idea why I would not have compression when everything looks brand new even the Rings look great any help would be appreciated thanks in advance
  2. I rebuilt the top end, rebuilt the carb, and replaced the reed. Starts, runs and idles but has no power. Cant barely move itself with no one on it. Air filter ok. Sounds like its bogged down with throttle open. Compression test showed 140 psi. Plug looks good. Gaskets look good. Im lost. Any suggestions??????
  3. 1989 Suzuki LT80 want to add a headlight and tail light. Wondering if anyone here has done it. Looks like I will likely have to fab up my own brackets for each, but just seeing what others may have done. Thanks
  4. Hello everybody I am in search of an lt 80 kids quad rear swing arm. The one on my kids quad broken and am looking for replacement. If you guys know of any upgrades or swaps I could od I would appreciate that also. Thanks
  5. Are there any mechanics out there who have experience replacing a voltage regulator/rectifier with one that is not stock. Manufacturer doesn't make the part anymore for my 1987 Suzuki LT80 Quadsport. I can't find a used one either. Dealer said I might be able to use a similar one, but wires would have to be spliced. I'm not sure if that would work or harm the electrical system. Any feedback would be appreciated.
  6. Just got this bike for the boy and fires right up and has good power but just seems noisy. Has a pretty decent ticking/almost knocking sound at idle and low rpm. First thought was rod bearing or wrist pin but riding it when you get into the high rpm’s it pretty much goes away. I did notice some oil coming off of one of the exhaust flange bolts. Any experience with a bad exhaust gasket sounding like that? Or could it be the clutch ? Any help would be appreciated !
  7. Hey guys, hope you can help me out here. I was gifted an early 90s LT80 and it had sat outside for a couple years. Upon inspection I noticed the wiring harness was all chewed up and had couple splices. I tried to get it to work and was getting nothing when I pressed the start button so instead of messing around with it more. I just ordered a new wiring harness along with a starter relay. I have everything hooked up but the clip on the new harness for the CDI/coil is 4 prong when the cdi/coil is 2 prong. Is there anyway I can splice this into the two prong adapter or do I need to get a new cdi and coil. Also is there a way to test the start stop switch on this as I’m narrowing down why I am getting nothing when I try to start it. Relay doesn’t even click. I have sliced the brake switch and the reset button wires together and am getting nothing. Shouldn’t it still be turning over without spark if the coil isn’t connected? Please help and thank you Sent from my iPhone using Tapatalk
  8. Hey all hopefully someone can help me out here. I found a 1985 lt80 laying around at the yard where I work and it’s missing some parts. Obvious things I noticed were carburetor fuel tank seat. Is there someone out there that has maybe a picture of one of these motors assembled so I can see what I’m working with and what I’m missing? I ordered a new carb and got it installed to the existing cable but I’m not sure what else it needs as I’m not expert on these little engines. Any help would be greatly appreciated
  9. Please help. Iv got an 1990 lt80 that will not charge the battery. I can’t seem to find the answer to the problem. Is it the rectifier or the Cdi box or something different all together. I can’t seem to find any rectifiers for it so I’m stumped and I don’t have a manual to read up and find the answer.
  10. Friend of mine picked up an LT80 that needs some work. The manufacture date is 11/1986 The fuel and vacuum lines for the carb were all disconnected. I picked up a new card and was hoping someone on here has a photo or knows how the lines are hooked up Thanks in advance
  11. Picked up an LT80 (unknown year) for $200 recently for my girls. Not running at the moment, but does turn over. I’m thinking the carb needs to be rebuilt or replaced, as it appears to be leaking 2 stroke oil. Anyway, I’m excited to have something to wrench on in my (limited) spare time
  12. View File 2002-2006 Suzuki LT80 Service Manual 2002-2006 Suzuki LT80 Service Manual Submitter Admin Submitted 06/29/2019 Category Suzuki ATV  
  13. Version 1.0.0

    8 downloads

    2002-2006 Suzuki LT80 Service Manual
  14. Version 1.0.0

    5 downloads

    1996-2001 Suzuki LT80 Service Manual
  15. 1996-2001 Suzuki LT80 Service Manual View File 1996-2001 Suzuki LT80 Service Manual Submitter Admin Submitted 06/29/2019 Category Suzuki ATV  
  16. Version 1.0.0

    9 downloads

    1988-1995 Suzuki LT80 Service Manual
  17. View File 1988-1995 Suzuki LT80 Service Manual 1988-1995 Suzuki LT80 Service Manual Submitter Admin Submitted 06/29/2019 Category Suzuki ATV  
  18. Version 1.0.0

    105 downloads

    1987-2006 Suzuki LT80 Service Manual
  19. ve a 1997 suzuki lt80 and when i try to turn it's as if the brakes are applied. it does not turn freely....i dont what to do to correct this...please help with suggestions...thank you
  20. 1987-2006 Suzuki LT80 Service Manual View File 1987-2006 Suzuki LT80 Service Manual Submitter oxidized_black Submitted 12/14/2016 Category Suzuki ATV  
  21. loud clicking, snapping noise under load when accelerating.
  22. I have been trying to get this suzuki to run right it starts great and idles for about 1 or two minutes. Carb rebuilt,new reed assembly,new fuel tank valve. everytime you give it a little gas it falls dead. Tried all I know but lost has a goose, only thing I havent done is a new spark plug but it seems to spark good when I check it. Alls I need now is a stick of dynomite and a match. Please any ideas you can direct me in I would appreciate Iam to old to loose any more brain cells on this Thanks All
  23. Hi I'm Jack Moore known all over as LT80. I welcome any LT80 questions. Ask away!
  24. Hi.. I was riding my lt80 through a very wet woods when all of a sudden, every time i went to put the revs on to go faster the quad was just revving right but not going anywhere like a belt was slipping or something, any suggestions please.. Would be a great help thanks
  25. This thing will not fire or even smoke. Spark looks good enough. So far I have replaced the plug (NGk), cleaned the flywheel-magneto, cleaned the carb & reeds, replaced both crank seals . Any input apreiciated. This things drivin me nuts!
×
×
  • Create New...