Quantcast
Jump to content

Search the Community

Showing results for tags 'lt80'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Community Discussion
    • General ATV Discussion
    • General Talk - Anything Goes!
    • New Members Area!
    • Where To Ride Your ATV
    • ATV Picture and Video Sharing
    • ATV Racing & ATV Events
    • ATV & Off Road Modifications
    • This vs. That ATV & Off Road Comparisons
    • ATV Trailers, Haulers, and Attachments
    • Hunting, Camping, & Outdoors Forum
    • ATV Laws, Legal Issues, and Policing
  • Regional ATV & Off Road Forums
    • Northeast ATV & Off Road Forum
    • Midwest ATV & Off Road Forum
    • South ATV & Off Road Forum
    • West ATV & Off Road Forum
    • Other Region ATV & Off Road Forum
  • ATV Manufacturer Specific
    • ATV Forums By Brand
  • UTV Side x Side Manufacturer Specific
    • UTV & Side by Side Forums By Brand
  • Other Powersports, Offroad, and All Terrain Vehicles
    • ATC 3-Wheeler Forum
    • Dirt Bike Forum
    • 4X4 Trucks and Jeeps
    • Snowmobile Forum
    • Jet Skis, PWC, and Boating Forum
  • QUADCRAZY Classifieds
    • ATV For Sale? Post it here.
    • Stolen ATVs
  • QUADCRAZY Supporters
    • ATV Links & Partners
  • ATV News, Magazine Articles, Product Reviews
    • ATV News, Articles & Press Releases
    • New ATV Products, Reviews & Tests
    • Manufacturer & Aftermarket Promos
  • QUADCRAZY Announcements & Support
    • Announcements/Support
    • Website How To & Feedback
  • Yamaha Grizzly Owners's Topics
  • New York ATV Riders's Group Forum
  • Kawasaki Bayou 220 Restoration and Repairs's Topics
  • Ride Red's Videos
  • Ride Red's Ride Red Forum
  • NYC 2 Poconos/ Scotrun ATV Riders's ATV Upgrades
  • NYC 2 Poconos/ Scotrun ATV Riders's Quads

Categories

  • ATV News and Articles
  • ATV New Products & Reviews
  • ATV Racing & Events
  • ATV Ride Reports

Calendars

  • Community Calendar
  • ATV Racing Events
  • ATV Poker Runs and Riding Events
  • ATV Swap Meets
  • Other ATV & Off Road Events

Categories

  • ATV Repair Manuals
    • Arctic Cat ATV
    • Can-Am BRP ATV
    • Cannondale ATV
    • CFMOTO ATV
    • Hisun ATV
    • Honda ATV
    • Kawasaki ATV
    • Kazuma ATV
    • Kymco ATV
    • Polaris ATV
    • Suzuki ATV
    • Textron Off Road ATV
    • Yamaha ATV
    • Other ATV
  • ATV Owner Manuals
    • Arctic Cat ATV
    • Can-Am BRP ATV
    • Cannondale ATV
    • CFMOTO ATV
    • Hisun ATV
    • Honda ATV
    • Kawasaki ATV
    • Kazuma ATV
    • Kymco ATV
    • Polaris ATV
    • Suzuki ATV
    • Textron Off Road ATV
    • Yamaha ATV
    • Other ATV
  • UTV Side by Side Repair Manuals
    • Arctic Cat UTV
    • Can-Am BRP UTV
    • Hisun UTV
    • Honda UTV
    • Joyner UTV
    • John Deer UTV
    • Kawasaki UTV
    • Polaris UTV
    • Textron Off Road UTV
    • Yamaha UTV
    • Other Brands UTV
  • UTV Side by Side Owner Manuals
    • Arctic Cat UTV
    • Textron Off Road UTV
    • Can-Am BRP UTV
    • Hisun UTV
    • Honda UTV
    • Joyner UTV
    • John Deer UTV
    • Kawasaki UTV
    • Polaris UTV
    • Yamaha UTV
    • Other Brands UTV
  • Other Files

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Location

miles from

About Me


My Garage

Found 10 results

  1. ve a 1997 suzuki lt80 and when i try to turn it's as if the brakes are applied. it does not turn freely....i dont what to do to correct this...please help with suggestions...thank you
  2. I rebuilt the top end, rebuilt the carb, and replaced the reed. Starts, runs and idles but has no power. Cant barely move itself with no one on it. Air filter ok. Sounds like its bogged down with throttle open. Compression test showed 140 psi. Plug looks good. Gaskets look good. Im lost. Any suggestions??????
  3. LT80

    Welcome from LT80

    Hi I'm Jack Moore known all over as LT80. I welcome any LT80 questions. Ask away!
  4. ronald webb

    Suzuki LT80 nightmare

    So where to start my son's LT80 stop running a couple months ago. Naturally I assumed I had a carburetor issues or the peacock valve. After replacing those two items and ensuring I had a spark I started doing my homework thus finding this page. After all the post I have read the next natural thing would be compression I did a compression test today and it was only 60 after spraying WD-40 in it so off comes the cylinder head and The Jug to my surprise the cylinder walls and all the gaskets are pristine so I am totally stumped no idea why I would not have compression when everything looks brand new even the Rings look great any help would be appreciated thanks in advance
  5. evlsnke

    lt80 suzuki

    loud clicking, snapping noise under load when accelerating.
  6. phantomcowboy

    lt80

    I have been trying to get this suzuki to run right it starts great and idles for about 1 or two minutes. Carb rebuilt,new reed assembly,new fuel tank valve. everytime you give it a little gas it falls dead. Tried all I know but lost has a goose, only thing I havent done is a new spark plug but it seems to spark good when I check it. Alls I need now is a stick of dynomite and a match. Please any ideas you can direct me in I would appreciate Iam to old to loose any more brain cells on this Thanks All
  7. Hi.. I was riding my lt80 through a very wet woods when all of a sudden, every time i went to put the revs on to go faster the quad was just revving right but not going anywhere like a belt was slipping or something, any suggestions please.. Would be a great help thanks
  8. This thing will not fire or even smoke. Spark looks good enough. So far I have replaced the plug (NGk), cleaned the flywheel-magneto, cleaned the carb & reeds, replaced both crank seals . Any input apreiciated. This things drivin me nuts!
  9. im new at this and need all the help i can get!! my two oldest kids wore it out and i need to get it ready for the youngest son so any help would be great thank you very much
  10. Bandit

    LT80 problems

    I have been working on this quad for a buddy. When he brought it over it didnt run. Well removed the carb and cleaned well...then changed the o-rings and changed the spark plug. After all that i put it back together and hit the starter. It started up after cranking a while and ran for about 5 min. and then bogged and died. And wouldnt restart.I cranked for a while and it kinda speeds up like it gonna start but just wont. I let it set for awhile and bam it started agian..and then the same thing, after about 5 min. of running it just boggs and dies. I did a compression check and got 125, so im ok there. But i did notice a lot of oil on top of head. I cleaned it off and when i ran it till it died i noticed that all that oil was back. Could i have a blown head gasket?

×