Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Sign in to follow this  
oxidized_black

2005 - 2006 Yamaha 250YFM Bruin/2007 - 09 Yamaha BigBear 2WD

Recommended Posts



Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Forum Topics

  • Similar Tagged Content

    • By BradF80
      Hello all,

       I registered on this site because I just purchased a new to me 2005 Yamaha Bruin 250 2wd. This seems to be the only place to get diagrams so I'm hoping I can download them sooner or later. The guy I bought it from said it had no spark. And it truly does not have spark...lol

      I haven't looked into much on it. Looks like he replaced the ignition switch and the stator. I'm thinking CDI box but I want to check the coil first.

      I look forward to helping others out on the electrical end of the world. I am an ASE certified automotive electrical technician. If it's 12v, I can usually figure it out.
    • By Karen
      Yamaha BRUIN 350 Quad
      Hi, think water got into the tank, have managed to drain fuel (not the best experience) and empty the carb of fuel ........ so it starts now and runs however, it cuts out on fuel and won’t restart, it will restart on reserve ?  When I turn it off and back onto fuel, it will start again.  If I take for a short run on fuel it will cut out again and only restart on reserve 😳. Any ideas what else I can check.  Many thanks
    • By Scoopeddad
      I have a 1994 big bear and I am starting to have issues starting. I put in a new starter and selnoid as the at stopped starting with the electrical but will still start with the pull cord. Where and what now should I be looking at to check? If I turn key to on and the switch to on then hit the start button, the bike clicks and then nothing. Lights still work but no response to the starter. Stumped now. Any help would be greAt.
    • By oxidized_black
      View File 2004 - 2008 Yamaha Grizzly YFM660 Service Manual
      2004-2008 Yamaha Grizzly YFM660 Service Manual
      Submitter oxidized_black Submitted 12/14/2016 Category Yamaha ATV  
    • By oxidized_black
      2004-2008 Yamaha Grizzly YFM660 Service Manual
  • Recently Browsing   0 members

    No registered users viewing this page.


×