Quantcast
Jump to content

  • Do you own an ATV or UTV? Join our Forum!

    Join QUADCRAZY ATV Forum today for FREE! We keep these forums clean and user friendly. All first posters will have to wait to have their content reviewed and approved. Once your first post is approved, you will no longer need to got through an approval process. To gain immediate approval and a NO ADS experience, consider subsribing to our Premium Membership.

Rzr 800


kleedian
 Share

Recommended Posts

Hey guys, i just picked up a 2010 Rzr 800, it was running just fine then wham. it lost all tension in the shifter. it will literally just slide back and forth and do nothing. If i rev the engine just a bit it will allow me to go into gear, but it grinds as it finally hits fowrward, reverse ect.

This is my first Rzr and I am not very happy at this point...

Any and all help will be appreciated.

Link to comment
Share on other sites

Dream Car Giveaway

Sounds to me   like something has come loose  in the  linkage between  your  shifter  and  transmission, quite possibly  in  the  shifter mechanism   in the transmission itself.  It  is not  moving the  gears into  full mesh.  It  could  be something as simple as the  shift cable  coming  loose and  out of  adjustment or  mean  you  have to  go into the transmission.

I  found a download for the  2011 Rzr 800 and  added it to the  library.  Here's   the  link to  it.

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...