Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Woodemp

Need service/repair manual for 2007 Polaris Sportsman 450

Recommended Posts

Hi. 

 I need a service/repair Manuel for my 2007 Polaris Sportsman 450. Anyone know where i can download one. Tks

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Zad
      1994 Polaris 300 2x4 project won’t start. Seems like we have spark and have tried straight starting fluid in cylinder and still not getting a fire.   Kind of has me stymied 
    • By donerightautomotive84
      Ok so 2000 sportsman new.caltric carb new fuel pump new jug and piston new cdi and coil finally get to start it and itll idep for 5 to 10 seconds and die what am i missing people any help id love ya forever lol
      Sent from my LM-Q720 using Tapatalk
    • By Rooftop777
      Can't figure out whats wrong, battery good, charging fine but speedometer needle flashing. I know my fuel sending unit is not working but atv was working well last year. Now it was blowing fuses. I did engine code check but none there. Gas gauge flashes and shows FUEL in capital letters. Need help as just cannot figure this out,
      I might pull the fuel pump out and put new float as likely saturated. Don't know if that would give me all these problems ??
      thanks
    • By Chase Cook
      Have a 2001 polaris sportsman 500 4x4 atv and when I put coolant in the radiator it starts leaking from the exhaust. The valves are sealed but it stopped making compression. Do I need to just replace the head? I just rebuilt the hole top end and this is the only thing +valves that I have not replaced and was wondering if that is why it's not starting up. Need answers please.
    • By Brian Simmons
      A buddy of mine . had a friend redo his top end . It was running great  . then it like locked up  but then it started again !!! then it seemed like it locked up again ??? Could he have done something wrong  ??? Could it be bad ??? Please let me know what you think it could be ??? Please help !!! i want to know how much it will cost to fix or if he should part it out ???
      PLEASE HELP !!!
  • Similar Tagged Content

    • By bodon
      Anyone know what the fuse terminal marked UNSWITCH  does  .  Even with the key off it is causing a drain on my battery and I'm trying to figure out  what that terminal goes to.  It's a 10 amp fuse. If I pull it the "short" goes away.  Thanks in advance.
    • By Outkast7222
      Had a spark-plug break off, had to pull the head to get it extracted. Where the heck is the timing mark on the crank? Do I need to pull the stator or flywheel to find it? When I pulled the head I had the mark on the cam lined up pretty good but I cant remember if it was perfect and don't want to reassemble a tooth off and have to go back through the bear of pulling this thing back apart.
      Thanks guys!
    • By Chase Cook
      Hi I just got an Polaris sportsman 500 4x4 ATV the other day. I got it real cheap but I started to go into it because it didn't have compression so I bought a new piston and ring kit for it and installed it, but now when I try to start it all it does is shoot fire out the exhaust or the intake of the carburetor. And a timing is top dead center.;I think I can't really tell another way if it is or not. when I put it together I made sure to piston was on top and the cam lobes where facing down where are the cam sprocket is facing up. It has gas and spark. It did start a couple minutes ago but it didn't stay running and now it won't start. Do you think the valve need to be adjusted more to close better?I'm fixing to try that out and if that don't work what is the problem? Also I made sure everything was together good and right and change the oil and changed out the radiator fluid.
    • By Brian Sosebee

      I just rebuilt my 03 sportsman 400. Put everything back together added oil per the manual. Pinched off the oil tank vent line 2" away ran for 45 seconds then cut it off. Check oil level and it was still way high so I wasn't confident that it primed so I did it again. Checked again and it's the same. Remove the oil filter and it is dry. I did the procedure again and the same results.

      I'm worried to keep trying this as the only oil in the engine is what I used to lubricate the parts when reassembling the piston. The crankcase was drained as well.
      I Removed the oil tank and checked all the lines for obstructions and the screen filter and the vent hose and everything is clear. I even pulled a small vacuum on the oil tank while it was pulled off to make sure there were no leaks. The dipstick cap was on tight so I'm not sure why this thing is not priming.

      Anyone have any suggestions. I thought about pre-priming the oil lines from the oil tank to the crankcase to hopefully help the system prime. I'd like to be able to add some oil to the crankcase to so I wouldn't feel so bad about running the engine for another 60 seconds without oil. I dropped just a little bit of oil in the spark plug hole to help condition the sleeve right now.

      What do I do? Anyone had or heard of an oil pump failure on these. Btw oil pump is working fine before I did the top-end rebuild and the oil pump was not touched.

      Please help!!! Thanks all for any and all help.
    • By jay rear
      Hi im new to the site. I have a 99 sportsman 500. I has been sitting for about a year now. I bought a new battery for it the other day and now i dont have any power to anything but the winch. Any help would be great. I already cut the pouch and checked voltage on both sides of the circuit breaker. 
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...