Quantcast
Jump to content

  • Do you own an ATV or UTV? Join our Forum!

    Join QUADCRAZY ATV Forum today for FREE! We keep these forums clean and user friendly. All first posters will have to wait to have their content reviewed and approved. Once your first post is approved, you will no longer need to got through an approval process. To gain immediate approval and a NO ADS experience, consider subsribing to our Premium Membership.

2000 Suzuki King quad lt-f300 won't start


Buck Mccovey
 Share

Recommended Posts

Hi all I was give a king quad 300 and the ignition was gone and no battery so I purchased both items and it still won't start the reverse or neutral lights will not light up so I went through the wire harness and check every break point and cleaned them and still nothing also tried the start in any gear mod with blue/black wire to ground  and still nothing need help 

Link to comment
Share on other sites

Dream Car Giveaway
  • Ajmboy changed the title to 2000 Suzuki King quad lt-f300 won't start
5 hours ago, Buck Mccovey said:

It's a 2000 and where is neutral switch I've changed the solenoid and also the relay 

It may be just the relay that you changed, so might not be your issue. Looking at this parts diagram I don't see a separate switch. https://www.suzukipartshouse.com/oemparts/a/suz/50d0a5def870022c2c534c66/wiring-harness-model-x-y

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...