Quantcast
Jump to content


New to the Forum


Coyote251

Recommended Posts

  • 4 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Forum Topics

    • By newguy024
      Just got into ATV riding just last week, never had much money so i couldnt afford to buy anthing, so now at the age of 34 i just bought a 1987 suzuki quadrunner 300 for 500$ took it out a few times and what a rush of excitement to go through that first mudhole haha!
    • By Gwbarm
      I Ran across this video today comparing an aftermarket to OEM Carb on Suzuki Vinson, thought it might generate some interest, it is quite long but informative.
       
    • By NZrider
      My king quad 700 runs rough when cold then won't start some times but not often when it's hot. And occasionally smoke's a lot when it's cold I'm guessing that's rings but I'm worried unless it's causing the other problems
       
       
       
      All help is appreciated thanks
    • By jatho
      Has anyone else had an issue on older king quads where the oil would leak from the top of the head (due to a failed gasket) and drip onto the hot exhaust? Mine got so hot one time it caught fire. Just wondering if this is a common issue, as I've seen the same thing happen on multiple bikes that were the same model. 
    • By mkibbe
      My 2014 750 king quad stalls sometimes when I touch or turn the handlebars,the problem has gotten worse,my machine has 475 miles and is only trail ridden,I have a new factory battery and i have 14.2 volts when the quad is running and 13.3 on the battery when not running,also using a multimeter there is no change in volts when turning the bars until it does stall,If I pull the 40 amp power steering fuse it will not stall.......I've been told its the ECU,Hate to buy one if thats not the problem,but its kinda leaning towards that,,,,,need some opinions.

×
×
  • Create New...