Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Coolster3150DX2

Coolster 3150DX2 first oil change and messed up?

Recommended Posts

I bought my first ATV(Coolster 3150DX2) back in February 2016 and built it with help. I also had help with emptying the "shipping oil" out and putting in a new bottle of 15w-40.
So I warmed up the engine a few minutes and took off the 17mm and drained the oil and noticed a spring and strainer flew out into the drip pan. I have NO idea on what order they go back in. I watched several videos about it, all of them said that I made a mistake. Supposedly their are two size bolts down there, 14mm and 17mm. The 14mm shouldn't be touched, but I don't see any other bolt that is down there. 
Please help.
I will attach a couple pictures.

20180404_162434 - Copy.jpg

20180404_162709.jpg

20180404_163559.jpg

Share this post


Link to post
Share on other sites


You took  out the  oil filter  plug.  The  screen  goes in first, screen facing out . then  the  spring  and finally the plug..

The  other  bolt you  show is the right one ..  Here  is an excellent  video  of the  drain   and removal / replacement  of the  oil filter screen.

 

  • Like 1

Share this post


Link to post
Share on other sites
On 4/4/2018 at 8:28 PM, davefrombc said:

You took  out the  oil filter  plug.  The  screen  goes in first, screen facing out . then  the  spring  and finally the plug..

The  other  bolt you  show is the right one ..  Here  is an excellent  video  of the  drain   and removal / replacement  of the  oil filter screen.

Thank you. 

I took out the correct 17mm and more oil came out. It's running good again, but it was smoking a little. It wasn't the exhaust but it looked like the oil was smoking or something. It's not smoking anymore though.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Ajmboy
      Tonight is the first presidential debate and it should be a record breaker for viewing. Might as well have a mini poll here on QUADCRAZY to see how they stack up. Make your choice in the poll and feel free to comment in this topic. I'm going to pin this topic and keep it going through the elections in November. 
    • By HeWasRidinDirty
      This 700 was run out of oil. Seized the con rod to the crank....yada yada. So, I rebuilt the engine and now it will start and run for about 5 seconds and die. I replaced the fuel pump with a cheapie from ebay and it didn't change. I replaced the O-rings on the injector and still didn't change. So, the tech at the Yamaha shop said that the most likely problem is the cheapo fuel pump. I got another more expensive one and it still didn't change things. I asked him where the power to the injector comes from and he said the CDI box. But since the thing does run a little, he  ruled that out. Any thoughts?????
    • By Steve Howard
      Ran find shut down the quad next day would start and idle when you try to accelerate it would start popping through the carb got a rebuild kit soaked it in chem clean after break down for 12 hours on slow vibrate reassembled and adjusted per manual still the same thing any help would be really appreciated thanks and happy ridding  
    • By gareth leifheit
      Ive got a Big Bear 350 4x4 that has been sitting for a couple years. It was put away running but now the pull start wont move and the starter wont turn it either. Any ideas what I can lube up or bang around to loosen it up? Thanks
    • By domesticated
      So we bought three Kymco quads spring of 2017 and put them through the test all summer in north central WA mountains.  My boys MXU 270 surprised the hell out me several times when I thought for sure id have to pull it through some muddy spots but he cruised on though like it was 4 wheel drive(which it isn't).  Really a well built great beginner quad even for younger riders as it comes with the restrictor rings that only allow for about 25mph till they are ready for higher speeds which this tops out at about 45mph which is plenty for mountain trails.  
      The wife's MXU450i is about the smoothest running, and shifting quad I have ever been on.   Has great pep for a 450 and with on the fly 4x4 she has gotten up every where I've gone(despite my best efforts).  She is only 5' tall and really likes the narrower seat on the 450, something to keep in mind if your considering a 500 as that will put you on the wider body which may not be as comfortable a ride for some.
      I really have only have one complaint about my 700i and that it isn't a 1000 .  Super comfortable to ride and plenty of power.  Rode these all season with no issues what so ever.  To be honest the quality of these machines is definitely comparable to Yamaha, Suzuki, or Arcticat.  The main reason I bought these was the price.  I was able to score all three for about $14,500 after tax as the dealer had been sitting on them for about a year since no one around here wanted to take a chance on an unknown brand which worked out very well for me.  The mxu270 came with decent undercarriage guards and plates but the skid plates on the 450 and 700 are plastic so defiantly replace if your riding in rocky areas.  I made mine out of 3/16'' aluminum using the plastic plates that came on them as a template.  Only took about $100 and a weekend but you can also buy these if your not a cheap as I am.




  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...