Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Dominic Delmatto

06 Polaris sportsman 500 HO EFI questions

Recommended Posts

Looking at getting an 06 sportsman 500 HO EFI and just was wondering if someone could let me know any issues with them that are common and I’m just a little hesitant cause we have a 2012 sportsman 500 ho butnits got a carb not EFI. Didn’t know if Polaris had issues with the early EFI and the stopped production to work out the bugs or if was just an option they had? Thanks for the info!

Share this post


Link to post
Share on other sites


On 6/21/2018 at 1:41 PM, Dominic Delmatto said:

Looking at getting an 06 sportsman 500 HO EFI and just was wondering if someone could let me know any issues with them that are common and I’m just a little hesitant cause we have a 2012 sportsman 500 ho butnits got a carb not EFI. Didn’t know if Polaris had issues with the early EFI and the stopped production to work out the bugs or if was just an option they had? Thanks for the info!

Welcome to QUADCRAZY. You best bet is to use the search feature up top to see if other topics have been posted with any issues. Try these search results and scroll through and see if anything jumps out at you. It's a good way to do some research.

https://www.quadcrazy.com/search/?q=polaris sportsman 500&sortby=relevancy&search_in=titles

Share this post


Link to post
Share on other sites

I had a 2006 sportsman 700 EFI, I didn't have any problems with the EFI  but I did have problems with the Tbap sensor wires breaking.  Not a big deal to replace but annoying since it goes into limp mode and runs like crap.  Also the hall effect speed sensor goes out often in them, there is a replacement that uses larger gauge wires to help prevent breaking.

If you have any other questions, I replaced a bunch of things on mine when I had it since it was rolled over when I bought it.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Rooftop777
      Can't figure out whats wrong, battery good, charging fine but speedometer needle flashing. I know my fuel sending unit is not working but atv was working well last year. Now it was blowing fuses. I did engine code check but none there. Gas gauge flashes and shows FUEL in capital letters. Need help as just cannot figure this out,
      I might pull the fuel pump out and put new float as likely saturated. Don't know if that would give me all these problems ??
      thanks
    • By Chris Cowell
      Hey fellas. So I have a 2012 yfz450r. I work on the road for a living and went to a job and let a friend of mine borrow my wheeler while I was gone. Well, we know how that all turns out. I come home and it’s not running. Swears up and down he just went out to start it one day and wouldn’t start. Well, I start fooling with it and figure out the fuel pump is bad. I replaced the pump a couple days ago and brand new battery. When I go to start it, the engine light blinks every time I hit the start button. So, I decided to try and pull start it. It’ll turn over strong and half-ass run until I pull in the clutch and dies. Then the fuel light came on. I can hear the pump turning on and doing it’s job. Now, when I turn on the key the fuel light stays on, and same deal with engine light blinking every time I hit the start button. Can anyone help me out at all? This has been a NIGHTMARE. Super appreciative for any help. Thanks. 
    • By Chase Cook
      Have a 2001 polaris sportsman 500 4x4 atv and when I put coolant in the radiator it starts leaking from the exhaust. The valves are sealed but it stopped making compression. Do I need to just replace the head? I just rebuilt the hole top end and this is the only thing +valves that I have not replaced and was wondering if that is why it's not starting up. Need answers please.
    • By JacobSlabach
      hey so never ran into this before but i recently got a 04 honda rubicon 500.  bought it from my doctor not running and the front brakes were locked up.   cleaned the carb and it fired right up and runs great.  these model atvs have drum brakes front and rear.  not a fan.  lost all brakes on this one when i hit some water and it got inside the rear drum case.  so i ordered new shoes for the rear end no biggie.  front is more complicated.  has hydraulic drum brakes not sure who thought that was a good idea but the pistons in the drums rusted and locked up from it sitting with moisture in the drums.
      so i had a choice to make- 1. buy new brake pistons ($120 for a set of 4) or 2. order super atv's disc brake conversion kit for $250.  i HATE drum brakes so i went with the conversion kit.  it said it was easy to install with no specialty tools.  so i order it and turns out i have to press the studs out of my hubs to get the disc on.
      anyone ever done this and if so how?
    • By bodon
      Anyone know what the fuse terminal marked UNSWITCH  does  .  Even with the key off it is causing a drain on my battery and I'm trying to figure out  what that terminal goes to.  It's a 10 amp fuse. If I pull it the "short" goes away.  Thanks in advance.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...