Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Toneloc

2004 Polaris Magnum 330 4x4 - Overheat Light & AWD engage

Recommended Posts

Hey Guys, 

I think I've got a bad ECU, but wanted to know if anyone has had similar problem before forking over the $200 for a new one.

Bought this rig from a buddy last winter.  Buddy let me know on issue before purchasing.

Occasionally the overhead light would comes on...even in winter rides.

I have followed fan trouble shooting, it powers up when direct connected to 12 V power supply and draws correct amps per manual.

Just recently, the light has come on when unit is cold and first started up. 

Or sometimes if not on right away, overheat light will come on right after starting within a minute or two into ride.

When fan comes on seems like it cycles on and off more than it should...

Oil level is good and hoses seems fine....one hose will be hotter than the other when checking, so that tells me the oil is flowing through the cooler.

Any ideas what temps should be from oil out and return?  I could check with infared heat gun...

And most recently, now I just had an issue where the light for the AWD does not come on right away now after switching on.  Comes on and off intermittent when switch engaged.

What do you guys think...is my ECU on the fritz?

Thanks ahead guys...any other ideas to trouble shoot would be appreciated.

Toneloc.

 

 

Edited by Toneloc
Forgot to add Magnum model

Share this post


Link to post
Share on other sites


best way is to get a friends ecu an test it. could easily be something other than the ecu...better to try it out before spending 200

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Andrew Paul
      Hi to all im new to here so here gos quadzilla xlc 300cc  and in 3 gear i get no drive and a lot of nasty nises can ony one help thanks andy.ps also what other engine gos in with no mods to do as im not that good thanks
    • By bradley nelson
      Im cool with the police in my area so i can ride on public roads.
    • By Kaj Colum
      Have a Bayou 400. sometimes when I press the start button i hear the solenoid click but the starter does not engage. Here is the strange thing though, when that happens if I kick the kick start just once then press the start button starter engages normally. Any ideas?
       
    • By Michael P
      Hi i have bayou 400 when i turn it over i get one little spark and that's it? New cdi ,switch, and a used regulator/retifier,new battery any suggestions would be greatly appreciated
    • By Brandon Bollinger
      Doesnt seem to make the sound all the time. Mostly does it under load or going up an incline. Its kind of like a clunk and or grinding noise, Kind of hard to decipher. Today while going up an incline it actually stopped and it sounds like something spinning and then it ingauged again and it would move. I checked the clutches and installed a new belt before it did that also. Rear drive shaft seems ok where U joint is too. Has all new rear CV shafts and bearings and al new bushings in rear arms. Also flushed out the rear Diff with no shavings. Any ideas or where to check. 
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...