Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

BigSkyKingQuad

Mid 90's Suzuki King Quad Need Info and Exact Year

Recommended Posts

Hello Everyone.

I was just given a mid 90's King Quad. I got her running today. I have so many questions. I'm Tony from Florence Montana. It runs excellent. I want to change fluids and have some fender work to do. Anyone here have some info on finding out exactly what year, what manual to get, etc? Thanks in Advance. Thank you all for this Forum! 

20180923_160452.jpg

Share this post


Link to post
Share on other sites


@BigSkyKingQuad Welcome to QUADCRAZY! I broke out your reply to the new member topic and created this new topic for you so any replies to your questions are separate from the topic started by someone else 😁

Can you take a look on the frame and see if you see a VIN number stamped somewhere? It might also be on a small metal plate maybe left rear area of the ATV. If you find the VIN number, you'll easily identify what year this king quad is.

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Reece Bowen
      x   just bought this expedition 425 and the Speedo needle does not work. The lights work for the shift indcator. So is this an electronic Speedo or cable? Is there a way to fix it or will I have to replace the unit? Thanks for any help you can provide.
    • By DUBLT
      Looking to purchase a windshield for my ATV, suggestions of what to buy with quality in mind and will fit without doing any modifications. 
    • By Mark Hill
      Hi everyone bought my son a project wheeler and got it up and running but it won’t go in reverse.  It’s a 2002 2003 bombardier rally 200. I have been searching for causes on line had have a couple ideas what it may be but still looking  for advice and help
    • By Ted Aregi
      I've got a king quad 750cc has anyone converted the fuel pump relay to a stronger fuel pump relay on there king quad?
    • By josephnbl91
      My four wheeler when i first got it seemed like it was very slow when i first got it and it had no throttle response so i replaced the belt and cleaned all of the rollers thinking that would solve the problem from what i read on the forums. well it turned out that it wasnt. so i went to the next thing i took out the injector to check it out and i seen that there was a tiny bit of debree in it so i cleaned it and it seemed to improve a little bit. but still did not solve the problem. i later found out how to find the trouble codes out from the lcd screen using a paper clip on the diagnostic port and it showed the code which stood for no codes C00. i also forgot to mention that the throttle position censor is working perfect. before i started all of this the four wheeler ran just not to its potential. after my friend and i did the trouble code test the bike wouldnt even start anymore and the injector would spray for a few seconds for the start up then it stops and the fuel injection light comes on and blinks. the four wheeler wouldnt start anymore. i took it over to the local shop and they hooked it up to the computer to see if there was any codes and it still showed it was free of codes. they hooked it up to the fuel pressure gauge and we found that it was making 22 pounds and it should be making around 43. i then bought a new fuel pump and put it in. it now starts and runs for a few seconds and then it stalls out and the fuel injection light comes on again. which then leads me to think it is the ecu now but i want to be sure before i invest around $500 more into it. any opinions on whether or not anyone thinks this is the problem or if they have had a similar problem before would be really appreciated. sorry for writing a novel and not spelling very well. also i forgot to put the year in the title it is a 2007
  • Similar Tagged Content

    • By DUBLT
      Looking to purchase a windshield for my ATV, suggestions of what to buy with quality in mind and will fit without doing any modifications. 
    • By Ted Aregi
      I've got a king quad 750cc has anyone converted the fuel pump relay to a stronger fuel pump relay on there king quad?
    • By Brandon Bollinger
      Doesnt seem to make the sound all the time. Mostly does it under load or going up an incline. Its kind of like a clunk and or grinding noise, Kind of hard to decipher. Today while going up an incline it actually stopped and it sounds like something spinning and then it ingauged again and it would move. I checked the clutches and installed a new belt before it did that also. Rear drive shaft seems ok where U joint is too. Has all new rear CV shafts and bearings and al new bushings in rear arms. Also flushed out the rear Diff with no shavings. Any ideas or where to check. 
    • By Jeremy Murray
      My 300 king quad will crank and crank off the start button but will not start but you can pull the pull rope a few times and it will start help me
    • By My kiwi shed
      Hi there everyone. Just seeing if there is advice on a problem I have before I start digging too deep. 
      I recently bought this creally nice 2004 King quad ltf300 with only 2400km..
      Everything things works great except when engaged into 4wd or diff lock it has a clicking noise ( sounds like broken teeth etc) are the front diffs known to blow?  Or the transfer from engine?
      I am yet to test on some loose ground to see if I'm getting drive at front .
      I will be driving in to find problem in next few weeks but thought I'd see if anyone might know what it is first. Cheers


  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...