Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

BigSkyKingQuad

Mid 90's Suzuki King Quad Need Info and Exact Year

Recommended Posts

Hello Everyone.

I was just given a mid 90's King Quad. I got her running today. I have so many questions. I'm Tony from Florence Montana. It runs excellent. I want to change fluids and have some fender work to do. Anyone here have some info on finding out exactly what year, what manual to get, etc? Thanks in Advance. Thank you all for this Forum! 

20180923_160452.jpg

Share this post


Link to post
Share on other sites


@BigSkyKingQuad Welcome to QUADCRAZY! I broke out your reply to the new member topic and created this new topic for you so any replies to your questions are separate from the topic started by someone else 😁

Can you take a look on the frame and see if you see a VIN number stamped somewhere? It might also be on a small metal plate maybe left rear area of the ATV. If you find the VIN number, you'll easily identify what year this king quad is.

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By 06kfx440
      My retaining wall fell 20 feet up my driveway from the entrance. I called my insurance company and was told that there isn’t a lot they can do.
       
      So I called the town to see who built it and the old homeowner did 4 years ago! With no contractor! And the building department passed it for inspection.
       
      There is no geo grid, no drainage, and dirt as a backfill. I bet you I can pull the rest down by hand.
       
      My question is who is responsible? This is not right.
       
       
      Sent from my iPhone using Tapatalk
    • By Shane Pillar
      Talk about what kind of atv you have and what you do with it.
    • By davefrombc
      View File Quad Runner 250 King Quad 1987 - 1998
      Service manual  for  King quads  250  and 300
      Submitter davefrombc Submitted 01/28/2017 Category Suzuki ATV  
    • By Christian Smith
      Recently bought a Polaris 425 Xpedition. Main issue is that the quad randomly misfires sometimes. ONLY does it at idle. Everything sounds good. What should I look for? Haven't checked the plug, seems a bit hard to get to, not sure. Headlights flicker at idle as well, is this a sign of a weak stator? Help? 
    • By Shook
      Hi I have a 2000 big bear 400 and i just put a new carburetor on it and it idles fine but when you try to accelerate it sounds like it is going to die, so when it sounds like it is going to die I will give it more throttle then it will go just fine.
  • Similar Tagged Content

    • By LMI
      I wanted to share an experience and a fix.
      Headed out was following a pole line, was looking for a cross track that may take me to this speckle trout looking spot on a creek.  All paths and semi paths... failed.  Second objective was to reach a speckle trout lake that has been recently stocked... followed 1 trail to dead end, followed second trail to dead end.... while investigating options on foot and the quad idling it died.
       
      It wouldn't start.  eventually it did... and when it did … it was essentially a pinned idle.  activating the throttle did seem to speed it up but it wouldn't knock out of the racing idle.  couldn't put it in gear at that idle speed.  got towed out.
      when I first got the quad, I ran it off a trail and buried it pretty good in the soft snow... eventually winched out.  It wouldn't start.  eventually did and it was fast idling.  not as fast as this last time. but still fast.  it eventually seemed to settle and I got it in gear and by the time I was back to the truck was acting ok.  chalked it up to the bike being at a bad angle in the snow.
      My investigation last year lead to the throttle position sensor TPS.  how to jumper the diag block to see the sensor position on the display,.  I focused on this nearly sure it was a detuned sensor or broken sensor again this time.
       
      I tore down the front plastic and stuck my head into the TPS area to see what I could see.  What I found was that the throttle body assembly had actually come out of the mounting area (not sure what it is called).  the ring clamp was loose I could move it easily.  Hopeful, I tore down the air intake assembly above it (air filter...etc) removed a sensor clip and a hose.
      I backed off the clamp some more and was able to reseat the throttle body assembly.  put some blue lock tite on the clamp screw.  When I was cleaning off the air intake assembly to ensure I dropped nothing down the intake, I noticed the underside of the air intake "box" also had a clamp.  this screw was completely missing.
      I went to the hardware store, bought a metric replacement (brought clamp with me), seated the assembly, settled the clamp blue lock tite that as well... 
       
      quad fired right up, idled normal, idled up without hesitation and dropped right back off.  Cost of solution $3.87 CND for a pack of 5 metric screws.  moral of my story was don't assume an idle issue is a throttle position sensor problem... there are a number of other factors including air pressure, which I believe was my issue.
       
       
       
    • By Andrew Serrano
      I have a 2000 Suzuki LTF -300 King Quad. My problem is it will start up great, very fast. It will run fine until it gets hot and I turn it off.  If I let it sit for a bit it will not start until I hold the throttle wide open and crank on the starter for quite some timr, acting has if flooded.....but I checked the spark plug one time this happened, went to change thinking it was flooded but only found a dry Plug????  It starts like if flooded but plug was dry, it takes awhile to start, then to get going I have to really rev it to get it clear and going...Thanks any suggestions would be great, thanks everybody in advance...!!!
    • By Andrzej Polak
      hi
      Where installing a winch to KINGQUAD ltf300?? someone have any pic?
    • By Gus Drake
      I'm helping the widowed neighbor out to do some oil changes on her quads. Any recommendations on what type of oil to run in these machines?
    • By Kristpj
      I know this tooic has been addressed by many, I’ve looked through many forums and pages. I did not find anything like the problem i have.
      I have a 2007 Kingquad 450. I have a new fully charged battery. When i turn the key, the dash flashes and seems to struggle before getting fully lite. We can hear a small relay near the computer clicking, i think it is the fuel pump relay. When i turn off the engine kill switch and press the starting button relays click and all the power shuts off, i turn the key off, engine kill switch then start over, power is there. Atv will start with pull start, but not elextricly. if i try to use my winch, all power cuts and engine dies. 
       
      Can anyone tell me what it may be? or has anyone fsced an issue like this before?
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...