Quantcast
Jump to content

Search the Community

Showing results for tags 'king quad'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Community Discussion
    • General ATV Discussion
    • General Talk - Anything Goes!
    • New Members Area!
    • Where To Ride Your ATV
    • ATV Picture and Video Sharing
    • ATV Racing & ATV Events
    • ATV & Off Road Modifications
    • ATV Tires and Rims
    • This vs. That ATV & Off Road Comparisons
    • ATV Trailers, Haulers, and Attachments
    • Hunting, Camping, & Outdoors Forum
    • ATV Laws, Legal Issues, and Policing
  • Regional ATV & Off Road Forums
    • Northeast ATV & Off Road Forum
    • Midwest ATV & Off Road Forum
    • South ATV & Off Road Forum
    • West ATV & Off Road Forum
    • Other Region ATV & Off Road Forum
  • ATV Manufacturer Specific
    • ATV Forums By Brand
  • UTV Side x Side Manufacturer Specific
    • UTV & Side by Side Forums By Brand
  • Other Powersports, Offroad, and All Terrain Vehicles
    • Kids ATVs and Youth Off-Road
    • ATC 3-Wheeler Forum
    • Dirt Bike Forum
    • 4X4 Trucks and Jeeps
    • Water, Snow & Other Powersports
  • QUADCRAZY Classifieds
    • ATV For Sale? Post it here.
    • Stolen ATVs
  • QUADCRAZY Supporters
    • ATV Links & Partners
  • ATV News, Magazine Articles, Product Reviews
    • ATV News, Articles & Press Releases
    • New ATV Products, Reviews & Tests
    • Manufacturer & Aftermarket Promos
  • QUADCRAZY Announcements & Support
    • Announcements/Support
    • Website How To & Feedback
  • Yamaha Grizzly Owners's Topics
  • New York ATV Riders's Group Forum
  • Michigan ATV Club - St Helen, Mio, West Branch, Rose City's Lets ride Michigan trails this season!
  • Michigan ATV Club - St Helen, Mio, West Branch, Rose City's Up coming season
  • Kawasaki Bayou 220 Restoration and Repairs's Topics
  • Ride Red's Videos
  • Ride Red's Ride Red Forum
  • NYC 2 Poconos/ Scotrun ATV Riders's ATV Upgrades
  • NYC 2 Poconos/ Scotrun ATV Riders's Quads
  • Mechanics Club's Topics

Categories

  • ATV News and Articles
  • ATV New Products & Reviews
  • ATV Racing & Events
  • ATV Ride Reports

Calendars

  • Community Calendar
  • ATV Racing Events
  • ATV Poker Runs and Riding Events
  • ATV Swap Meets
  • Other ATV & Off Road Events

Categories

  • ATV Repair Manuals
    • Arctic Cat ATV
    • Can-Am BRP ATV
    • Cannondale ATV
    • CFMOTO ATV
    • Hisun ATV
    • Honda ATV
    • Kawasaki ATV
    • Kazuma ATV
    • Kymco ATV
    • Polaris ATV
    • Suzuki ATV
    • Textron Off Road ATV
    • Yamaha ATV
    • Other ATV
  • ATV Owner Manuals
    • Arctic Cat ATV
    • Can-Am BRP ATV
    • Cannondale ATV
    • CFMOTO ATV
    • Hisun ATV
    • Honda ATV
    • Kawasaki ATV
    • Kazuma ATV
    • Kymco ATV
    • Polaris ATV
    • Suzuki ATV
    • Textron Off Road ATV
    • Yamaha ATV
    • Other ATV
  • UTV Side by Side Repair Manuals
    • Arctic Cat UTV
    • Can-Am BRP UTV
    • Hisun UTV
    • Honda UTV
    • Joyner UTV
    • John Deer UTV
    • Kawasaki UTV
    • Polaris UTV
    • Textron Off Road UTV
    • Yamaha UTV
    • Other Brands UTV
  • UTV Side by Side Owner Manuals
    • Arctic Cat UTV
    • Textron Off Road UTV
    • Can-Am BRP UTV
    • Hisun UTV
    • Honda UTV
    • Joyner UTV
    • John Deer UTV
    • Kawasaki UTV
    • Polaris UTV
    • Yamaha UTV
    • Other Brands UTV
  • Other Files

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Location

miles from

About Me


My Garage

Found 45 results

  1. Looking to purchase a windshield for my ATV, suggestions of what to buy with quality in mind and will fit without doing any modifications.
  2. I've got a king quad 750cc has anyone converted the fuel pump relay to a stronger fuel pump relay on there king quad?
  3. Hi there everyone. Just seeing if there is advice on a problem I have before I start digging too deep. I recently bought this creally nice 2004 King quad ltf300 with only 2400km.. Everything things works great except when engaged into 4wd or diff lock it has a clicking noise ( sounds like broken teeth etc) are the front diffs known to blow? Or the transfer from engine? I am yet to test on some loose ground to see if I'm getting drive at front . I will be driving in to find problem in next few weeks but thought I'd see if anyone might know what it is first. Cheers
  4. I have bought a 1996 suzuki king quad 300 and I have noticed that it smokes but I have put oil in it and plenty of gas had to fix shifter bc the nuts and bolts came out somewhere. I have had to replace the wire for the starter but now when I try to start it it wont idle at all and when it does run it smokes really bad like a whitish blue I guess, and it likes to stall a lot. So anybody can help me out please and thank you 10000000_310855426253462_714534016610467840_n.mp4
  5. Doesnt seem to make the sound all the time. Mostly does it under load or going up an incline. Its kind of like a clunk and or grinding noise, Kind of hard to decipher. Today while going up an incline it actually stopped and it sounds like something spinning and then it ingauged again and it would move. I checked the clutches and installed a new belt before it did that also. Rear drive shaft seems ok where U joint is too. Has all new rear CV shafts and bearings and al new bushings in rear arms. Also flushed out the rear Diff with no shavings. Any ideas or where to check.
  6. hi Where installing a winch to KINGQUAD ltf300?? someone have any pic?
  7. posted a while back - it was running at one point - I have all the plastic shroud off - it's down to frame and engine now -fuel pump: when line from petcock is attached, no fuel comes out other side to carb; the line to the carb is open (can blow through it); I thought when I cranked engine that the pump would spit out fuel on other side but it does not; I removed fuel pump and opened it up - diaphragm looks good - but internal areas had lotsa calcification build up - I cleaned this out and dried it good - the clear plastic pieces (?diaphragms) aren't broken - the spring w/ steel ball on end moves freely; am putting it back on tomorrow; but can anyone answer about the pump? isn't it supposed to pump fuel through it... to other side... to carb? puzzling -along with fuel pump: I replaced petcock 3 weeks ago (gas tank had rusty fuel in bottom - cleaned it out prior to new petcock); when I turn petcock arrow NOT to on or reserve, fuel comes out of line; when I turn it to on or reserve, fuel doesn't come out; puzzling -I don't know what's on back of fuel pump - it's a valve that has a hose coming out of it - looks like it goes to engine/carb - I haven't traced this out yet - what is it? -can squirt gas on air filter and engine will run for 2-3 seconds then stop - fuel in top of carb (under diaphragm) does same -it likely needs carb rebuild - will get to this - but something isn't allowing fuel to get from fuel pump to carb -I THINK it has a mikuni model x carb - diaphragm is ID 26mm OD 68mm - hard to find inexpensive diaphragm, I guess because it's a model x -last thing - I replaced solenoid due to old one clicking; I HAVE to be charging the battery or it won't start/turn over - battery just goes dead; but if charging, it'll turn over nicely; i'm guessing it's a bad battery -any help appreciated - I've never owned an ATV before - inherited this beast from grandparent in-law
  8. My 300 king quad will crank and crank off the start button but will not start but you can pull the pull rope a few times and it will start help me
  9. I have a 2013 KQ I bought it new but rolled it a few years ago. I have replaced the left lower A-arm and left tie rod, the steering is still a little sketchy as I just eye balled the alignment. But the major issue is the left front tire cambers out at the top and has wore the tire bald. Tires have about 2000 miles on them but other 3 are half tread and left front is a slick.. I can not see anything else bent and don't know what to do..
  10. I wanted to share an experience and a fix. Headed out was following a pole line, was looking for a cross track that may take me to this speckle trout looking spot on a creek. All paths and semi paths... failed. Second objective was to reach a speckle trout lake that has been recently stocked... followed 1 trail to dead end, followed second trail to dead end.... while investigating options on foot and the quad idling it died. It wouldn't start. eventually it did... and when it did … it was essentially a pinned idle. activating the throttle did seem to speed it up but it wouldn't knock out of the racing idle. couldn't put it in gear at that idle speed. got towed out. when I first got the quad, I ran it off a trail and buried it pretty good in the soft snow... eventually winched out. It wouldn't start. eventually did and it was fast idling. not as fast as this last time. but still fast. it eventually seemed to settle and I got it in gear and by the time I was back to the truck was acting ok. chalked it up to the bike being at a bad angle in the snow. My investigation last year lead to the throttle position sensor TPS. how to jumper the diag block to see the sensor position on the display,. I focused on this nearly sure it was a detuned sensor or broken sensor again this time. I tore down the front plastic and stuck my head into the TPS area to see what I could see. What I found was that the throttle body assembly had actually come out of the mounting area (not sure what it is called). the ring clamp was loose I could move it easily. Hopeful, I tore down the air intake assembly above it (air filter...etc) removed a sensor clip and a hose. I backed off the clamp some more and was able to reseat the throttle body assembly. put some blue lock tite on the clamp screw. When I was cleaning off the air intake assembly to ensure I dropped nothing down the intake, I noticed the underside of the air intake "box" also had a clamp. this screw was completely missing. I went to the hardware store, bought a metric replacement (brought clamp with me), seated the assembly, settled the clamp blue lock tite that as well... quad fired right up, idled normal, idled up without hesitation and dropped right back off. Cost of solution $3.87 CND for a pack of 5 metric screws. moral of my story was don't assume an idle issue is a throttle position sensor problem... there are a number of other factors including air pressure, which I believe was my issue.
  11. I have a 2000 Suzuki LTF -300 King Quad. My problem is it will start up great, very fast. It will run fine until it gets hot and I turn it off. If I let it sit for a bit it will not start until I hold the throttle wide open and crank on the starter for quite some timr, acting has if flooded.....but I checked the spark plug one time this happened, went to change thinking it was flooded but only found a dry Plug???? It starts like if flooded but plug was dry, it takes awhile to start, then to get going I have to really rev it to get it clear and going...Thanks any suggestions would be great, thanks everybody in advance...!!!
  12. Hi, im looking to increase the power of my 1995 king quad 300. I was wondering what other people are doing to increase the power of their quads. Are there any big bore kits, would putting bigger jets in the carb do much? Just wondering what I could do. Sent from my iPhone using Tapatalk
  13. I have a 92 suzuki king quad that seems to be getting way to much fuel in my spark plug hole as I took out plug cranked it over and covered myself in fuel I cleaned carb and fuel filter and fuel pump all seems fine any other ideas
  14. as the topic says I'm interested in brands of mufflers ur using. I want a quiet (drive up on moose quiet) but performance type. Whos got what? Mines seen better days
  15. I'm helping the widowed neighbor out to do some oil changes on her quads. Any recommendations on what type of oil to run in these machines?
  16. Bought a 2019 king quad 500 AXi few weeks ago. What are peoples feelings on the break in time and fees a dealer charges. Not sure if i should do the break in service myself. Thanks
  17. Just picked up my new quad from dealership. Drove it onto truck felt for brush guard to touch front of bed. There isn't one. Asked dealer. Says they don't come with one have to order it. They looked it up not available for at least 30 to 90 days. Winch mounting plate either. Been riding suzuki's since 1973. So i guess it will have to sit in garage till accessories are available. This is my fourth Suzuki ATV they all came with brush guards. Can't even imagine the damage you could get without it.
  18. Hi all, new to the forum, looking forward to getting some help/advice on maintaining an 18 yr old atv! So my King Quad 300, recently started running really rough (otherwise ok til this point) at anything more than idle. After started, choke on/off, doesn't seem to matter, it shutters (Not sure how else to explain it) really bad when given throttle. I can let the engine run for several minutes, but this never improves. Fuel pump checks out ok, and I don't see any gas in the fuel pump vacuum line. I am a novice on a carburetor, but I need to see what's going on, so after taking it apart, I have a question about this plastic part with an o-ring that is above the jet needle. Appears as if someone rebuilt this carb, because it is extremely clean...so I am wondering if this plastic part looks to be typical for this carb...or not. Thanks in advance for the help!
  19. I have just ordered a Suzuki King Quad 300 which should be here this week - it is described as "with slow running needing attention" I am as a matter of course going to put a new spark plug in, change the oil and oil filter and blow out the air filter with compressed air - anything else I should consider? Also, the headlights do not work - I want to change them out for LED ones anyway though.
  20. I have an 05 King Quad 700 that has in the past had to have the stator replaced twice. For the past six months it has been down hard as I cannot get it to fire. I have replaced the coil (which is the code that came up) and now I have a friend replacing the stator. I want to see if the new stator does the trick. Drain the old fuel, and replace with 100% Ethanol free fuel, and see if that does the trick. The local Suziki dealer will not work on it as it is over 10 years old. So the nearest dealer is 90 miles away. The last thing I can do after that (provided the other fixes do not work) is replace the ECM/ECU. I also read that there was a recall on the ECM/ECU, so I need to check on that. All of the grounding has been checked, so if anyone has an idea, I would greatly appreciate the insight. Kindly, David
  21. The saga of the fan continues. The Pin attempt in the fan shaft failed. I then moved on to trying to weld the fan hub to the fan shaft. I took it for a run the weld broke. Now it was truly F'ed. To recap the dealer price, they want $400 + CND for a replacement fan assembly. I searched all sorts of after market places and no one carried one. Ebay had some used ones but they were $120 USD + Conversion rate for something as old as what I have. I went to Amazon and eventually settled on this. amazon link What I found... and was amazed... was that the fan mounted to the Suzuki fan assembly bracket. I was prepared to manufacture my own mount conversions... It also came with "Harpoon mounts" (nylon zip tie like things that go straight through the rad. Anyways it mounted to the original bracket. It fit perfectly. Cut the electrical plug off replaced it with the Suzuki... all good. Let the quad heat up, thermo coupler kicked in the fan circuit, polarity was right... all was good.... Fan is under the circuit fuse rating. so I finally have a solid fan solution. $34 CND vs $400+ CND
  22. Hi looking for help. My 700 fuel pump won’t cycle when I turn key on also my digital dash is not displaying anything it does light up yellowish but nothing else. If I pour fuel in the intake it will start for second
  23. Does any one know the proper adjustments for all the jets in the carb., I just replaced all the jets and I'm getting a lot of backfire also it seems like it isn't getting fuel or bugs down while idling and or riding any help would be great. Thanks
  24. Hello Everyone. I was just given a mid 90's King Quad. I got her running today. I have so many questions. I'm Tony from Florence Montana. It runs excellent. I want to change fluids and have some fender work to do. Anyone here have some info on finding out exactly what year, what manual to get, etc? Thanks in Advance. Thank you all for this Forum!
  25. Was using the quad the other day to shuttle wood from my pickup to my wood pile. When the job was done I turned off the Quad and heard a bit of a racket from the front end. When I got down underneath the sound seemed to be coming from the fan housing. fan was moving in spurts and not quickly... much like a computer case fan that's had it's day. What I know. Temp sensor is ok, as the fan tries to activate fan is getting some voltage as it is attempting to spin. When I first bought it used I tested the fan direct to battery and it was fine. The fan was working ok even not direct wired as I went on a couple of rides and when stopped and idling the fan did run Seems to be free spinning with my finger read up in the manual and they require me to drop the rad. now I'm not opposed to that as the rad has some damaged areas I want to try and straighten out. But if I can get the fan working without, I can leave the rad as it is until next year. Fan assembly is about 300 bills, any work arounds or alternatives? I even thought large computer case brushless fan. smaller ones are about $7 larger ones better quality probably far below the 300. They run standard 12v DC. Anything I should be doing before dropping the rad... other than check for obstructions even though it seems to spin, and trying to hardwire it to the battery again for a test to see if it acts the same?

×
×
  • Create New...