Quantcast
Jump to content

Search the Community

Showing results for tags 'king quad 300'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Community Forum
    • General ATV Discussion
    • General Talk - Anything Goes!
    • New Members Area!
    • Where To Ride Your ATV
    • ATV Picture and Video Sharing
    • ATV Racing & ATV Events
    • ATV & Off Road Modifications
    • ATV Tires and Rims Forum
    • This vs. That ATV & Off Road Comparisons
    • ATV Trailers, Haulers, and Attachments
    • Hunting, Camping, & Outdoors Forum
    • ATV Laws, Legal Issues, and Policing
  • Regional ATV & Off Road Forums
    • Northeast ATV & Off Road Forum
    • Midwest ATV & Off Road Forum
    • South ATV & Off Road Forum
    • West ATV & Off Road Forum
    • Other Region ATV & Off Road Forum
  • ATV Manufacturer Forums
    • ATV Forums By Brand
  • UTV and SxS Manufacturer Forums
    • UTV & Side by Side Forums By Brand
  • Other Powersports, Offroad, and All Terrain Vehicles Forums
    • Kids ATVs and Youth Off-Road
    • ATC 3-Wheeler Forum
    • Dirt Bike Forum
    • 4X4 Trucks and Jeeps
    • Water, Snow & Other Powersports
  • QUADCRAZY Classifieds Forum
    • ATV For Sale? Post it here.
    • Stolen ATVs
  • QUADCRAZY Supporters
    • ATV Links & Partners
  • ATV News, Magazine Articles, Product Reviews
    • ATV News, Articles & Press Releases
    • New ATV Products, Reviews & Tests
    • Manufacturer & Aftermarket Promos
  • QUADCRAZY Announcements & Support
    • Announcements/Support
    • Website How To & Feedback
  • Yamaha Grizzly Owners's Topics
  • New York ATV Riders's Group Forum
  • Michigan ATV Club - St Helen, Mio, West Branch, Rose City's Lets ride Michigan trails this season!
  • Michigan ATV Club - St Helen, Mio, West Branch, Rose City's Up coming season
  • Kawasaki Bayou 220 Restoration and Repairs's Topics
  • Ride Red's Ride Red Forum
  • Ride Red's Videos
  • NYC 2 Poconos/ Scotrun ATV Riders's ATV Upgrades
  • NYC 2 Poconos/ Scotrun ATV Riders's Quads
  • Mechanics Club's Mechanics Club Topics
  • Polaris Sportsman Club's Riding
  • Polaris Sportsman Club's Wrenching

Categories

  • ATV News and Articles
  • ATV New Products & Reviews
  • ATV Racing & Events
  • ATV Ride Reports
  • ATV and UTV Vendors
  • ATV/UTV Repair and Maintenance

Calendars

  • Community Calendar
  • ATV Racing Events
  • ATV Poker Runs and Riding Events
  • ATV Swap Meets
  • Other ATV & Off Road Events

Categories

  • ATV Repair Manuals
    • Arctic Cat ATV
    • Can-Am BRP ATV
    • Cannondale ATV
    • CFMOTO ATV
    • Hisun ATV
    • Honda ATV
    • Kawasaki ATV
    • Kazuma ATV
    • Kymco ATV
    • Polaris ATV
    • Suzuki ATV
    • Textron Off Road ATV
    • Yamaha ATV
    • Other ATV
  • ATV Owner Manuals
    • Arctic Cat ATV
    • Can-Am BRP ATV
    • Cannondale ATV
    • CFMOTO ATV
    • Hisun ATV
    • Honda ATV
    • Kawasaki ATV
    • Kazuma ATV
    • Kymco ATV
    • Polaris ATV
    • Suzuki ATV
    • Textron Off Road ATV
    • Yamaha ATV
    • Other ATV
  • UTV Side by Side Repair Manuals
    • Arctic Cat UTV
    • Can-Am BRP UTV
    • Hisun UTV
    • Honda UTV
    • Joyner UTV
    • John Deere UTV
    • Kawasaki UTV
    • Kubota UTV RTV
    • Polaris UTV
    • Textron Off Road UTV
    • Yamaha UTV
    • Other Brands UTV
  • UTV Side by Side Owner Manuals
    • Arctic Cat UTV
    • Textron Off Road UTV
    • Can-Am BRP UTV
    • Hisun UTV
    • Honda UTV
    • Joyner UTV
    • John Deere UTV
    • Kawasaki UTV
    • Kubota UTV RTV
    • Polaris UTV
    • Yamaha UTV
    • Other Brands UTV
  • Other Files

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


About Me


My Garage

  1. Bucking started about a month ago and works ok after 1/2 hour warmup. Today while working on it i discovered that if i put the ignition switch in LIGHT position it runs fine right from the start. I'm stumped! Any idea why this could be?
  2. My friends KQ 300 starts fine and runs, as soon as you put it in gear and try to accelerate its bucks and farts like crazy, not moving... I cleaned carb and it worked good for 1 day... now back to same problem.... could it be such as a bent valve????
  3. Okay so I bought this 1997 sazuki king quad from a guy and he had it for a few years. He had it registered and on the trails last year but he said it bogged and backfired when he would try to drive it. so it sat for a year. I bought it for 800 bucks and got it running that night and it ran great for a few days But I parked it the other night and went to start it again and it was really hard to fire up and when I did it was bogging and idling high then low again. So I took the carb out and cleaned it (ended up doing it twice because it was still doing the same thing) Now today I have it running slightly better, but it is still like 20% I have been looking it up and trying to figure it out but I can't find the issue, has anyone else had this problem? I'll attach a video of it running and giving some throttle
  4. Hey everybody, Just curious on some opinions on my recent buy. I'm a big fan of the drivetrain and transmission in the Suzuki King Quad 300 and QuadRunner 250 4wd models. I've been wanting one of either model for quite some time, and recently picked up a really nice shape one for 1500. I just wanted to get some opinions on whether you'd be more hesitant to get something this old, if there are newer options that are comparable. Also just keep in mind this is coming from someone not super mechanical. Key factors: Engine doesn't appear to have any leaks Had to replace the battery for $100, no biggie Front left CV boot is torn (not yet sure if the axle has damage) Starts right up with the tap of the button every time (so far) Idle was a bit low and was shutting off when warm. Adjusted the idle. Now it will only shut off occasionally on a hill if I'm not rolling or giving it gas. Has a Harbor Freight Badland winch with a wireless remote (brand new, tested and working) Has brand new shocks and brakes Shifting gears and changing between 2wd/4wd/diff lock/high/low/super low all seem fine. Rides pretty good, tight steering, takes the bumps pretty good as I have pretty rough trails. Brand new tires Over 2000 miles, that's quite a bit, but it seems well cared for. Plastics are almost all there. It's really only missing a small bit of the black mud flap in the rear. Has minimal stitching in the front, and it's got the usual scuffs. All of the lights work just fine (Neutral, Reverse, high and low beams) Tested the charging system and that works And I think that's just about all I can think of at the moment. It mostly seems to be complete and all there. I was a little hesitant about getting something that old, as parts are always a concern. Looks like most parts are available, but axles seem to be hard to get if you want something brand new. I really wanted a 2000's model but I couldn't pass up the price.
  5. How do I get rid of my rev limiter? I need to get to higher rpm's
  6. I'm relatively new to the King Quad 300's, what sort of things should I be servicing/checking every year or so to ensure the bike continues to run smoothly? i.e when the bikes in for an oil change what sort of things should I check over at the same time.
  7. Have just brought a King Quad 300. Is there a fuel filter located somewhere? And is it easy to access for cleaning etc? Any other filters on the bike that I should check/clean/replace while I'm at it Many Thanks
  8. One 1998 Quadrunner 250 4x4, two 90's King Quad 300's worth of parts. Fenders are garbage..
  9. I was gifted four King Quad 300's, they were used to tow portable snow guns around the slopes. All of the plastics are trashed and racks bent up from rolling down the mountain. The lone Quadrunner is a 98, and will be the initial point of focus, as it reportedly ran before being parked in the field of lost dreams.
  10. Hey all, new to the forum. I just bought a 2001 King Quad, and the clutch is slipping. I adjusted the play with no improvement, so before I go through the trouble of replacing the clutch disc, I want to see if motor oil in it is the problem. My question is Rotella T4 ok to use? I run in my motorcycles with no issues but I thought I'd get your input.
  11. Hi All, I have a 1992 Suzuki King Quad 300. I got it in rough, picked apart condition on Facebook marketplace. The previous owner was not mechanically inclined and threw parts, and deleted parts to get this to "run". To give you an idea of what I am dealing with he put a non vacuum carb on with a separate fuel bladder mounted on the rear rack. I live in CT and things are a bit high here so I got the atv with a plow for $400. The atv came with (3) Carbs, 1 OEM, (2) petcocks 1 OEM. What I have done / found is the neutral safety switch was ate by mice (probably the original problem), fixed that, reinstalled (cleaned and put in a new needle and seat) OEM carb, the diaphragm is a little clapped out but still flexible, installed new Fuel pump, cleaned and reinstalled OEM petcock (non vacuum) has slight drip every now and again as I did not replace the tank side gasket when I installed and installed a brand new battery. doing all that the quad fires and runs but briefly. On the handle bar the choke paddle is broke off, I ordered that and looks like you need to remove the grip to install so haven't done yet and If i can get some direction on that as well, So that is "floating" in the carb as I do not have the correct choke cable connector, I took the one off the Chinese carb and it somewhat holds it in place. The air box and system are gone and it has a stubby K&N cone filter on it currently. So the way I start it is pop off the air filer, hold my hand over the carb to get a good enough vacuum to get to the bowl, then it will run for a few seconds. The tank is filled to the top, to help it out. Does anyone think I am missing anything before purchasing the entire air box system (If I can find it). This will be a yard machine for work and will not be taken out recreationally, cool little machine I would like to keep it, but unsure if I will spend the money on a airbox system as it for sure seems I am not pulling a good enough vacuum with out it.
  12. Very tired of the Chinese carburetors. I don't have an original. Which of these would be best, and how to make the cable connections? https://www.powersportsid.com/mikuni/mikuni-vm-series-round-slide-carburetor-2051282452.html?vehicle=11510 Also, any idea on what size the muffler clamp is?
  13. Just started to bog in gear. Chineses carb. Taken apart and cleaned. Starts good, runs good, throttles good sitting there but as soon as try to go it will bog. Plug is black so I cleaned and adjusted needle downwards. Kinda lost at this point…ideas? Thanks in advance.
  14. Bonjour ,je démarre mon vtt SUZUKI KINGQUAD 300 avec un booster pack puis le vtt démarre et roule quelques secondes et le booster pack tombe en connexion inverses puis le moteur s eteint . Je met la cle a off ensuite j ett le+set set set set set set se
  15. I'm fitting a new carb on my King Quad LTF300. From China. Only one I could find in UK. I think it should have 2 vacuum ports. The vacuum port for the petcock is silver coloured. I can feel the pulsing vacuum. Putting the tube to the petcock there operates the petcock100% perfectly. I can't identify the vacuum port for the fuel pump. The new carb is identical to the old EXCEPT that in what I think is the 2nd old fuel vacuum position is a brass upright port with a very small hole. When running, there is no vacuum I can feel and putting the fuel pump vacuum line there does not give a decent fuel flow - only a small trickle. Is this the fuel pump vacuum port - see photo? The carb came with a silver coloured screw-ended 1.5 inch long loose port in the box. See photo. Is it intended that you unscrew the brass port somehow and put in the silver one? I'd really appreciate your help At the moment I can only do 10mph in a stuttering fashion on the level! Andrew Devon UK and put in the silver one?
  16. Hi everyone, I have a Suzuki King Quad 300. I live in 4.5 acres which is quite rocky with a lot of ups and downs. With the solid rear axle it is a very hard ride and can only be ridden quite slowly. Is 5 psi too low? At that pressure it is a lot more forgiving.
  17. Tie pretty much sums it up. I've been. Trying to and can't figure it all out.
  18. Is there anyway to lube the cables to help them move easier? Thanks in advance
  19. What mods has anyone done to their KingQuad 300? Has anyone removed the pin preventing diff lock in gears other that SuperLow? Any issues with that? Has anyone removed counterbalance shaft to gain more power? How bad were the vibrations after? Anyone use their KingQuad for plowing snow? Anyone mount a snowblower to their KingQuad? How do you handle the weight? Do you add counter weight to the rear? I've heard of replacing the suspension for solid struts? Anyone done that swap b4? Anyone else have constantly fouled plugs? I can't seem to find the cause? Torching the plug has become a starting ritual for me. Why did Suzuki design the rear brake to only 1 wheel Does SuperLow only have 1 gear? I haven't been able to shift above first? Does anyone else have an unreasonable high idle at the recommended 2 5/8 turns out. I need to turn out like 6 turns to get it to idle right. Might be related to by constantly fouled plugs. Has anyone replaced the starter solenoid? Is there a way to do it without removing the whole front end plastics and rack?
  20. Hi All I hate to ask a really stupid question but I've done all sorts of google searches and can't find any rock solid answer to my question. I realize my 95 model king quad has two different "clutch" units on it. One consist of several plates of fiber discs mixed with steel plates whereas the other clutch is a centrifical clutch that uses springs and weights to engage and disengage. My question is, what is the purpose of each of these? I sorta understand the spring and weights clutch but haven't the foggiest idea of what the other one does with the stack of fiber discs and plates. If you can explain this it would be great. Thanks Ray
  21. Went out to start the KG, and it started with no problem, idled for about 2 minutes and then died. Will crank but not start. Shot some starter fluid and started but then quit running. Assumed a fuel delivery problem. Separated the gas line before the fuel filter, cranked the engine, and no gas coming thru the line. Questions: Should I be getting fuel pumped up thru the line when disconnected? I did check the pet cock and it is working as it should. Any other suggestions you all might give me to check. Thanks everyone.
  22. I got a 1996 300 king quad 4x4 wondering if a 1998 500 king quad engine will fit and will it hook up to the 300 transmission thanx
  23. I have a small oil leak from the valve cover. Doesn't affect the oil level, more of an annoyance as it creates smoke from burning off the exhaust pipe. I can't seem to find a replacement valve cover gasket, so I'm curious if it even has a valve cover gasket. If not, any ideas on why it would leak?
  24. View File 1999-2004 Suzuki LT-F300/300F King Quad Service Manual 1999-2004 Suzuki LT-F300/300F King Quad 300 Service Manual Submitter Mech Submitted 12/28/2021 Category Suzuki ATV  
  25. 45 downloads

    1999-2004 Suzuki LT-F300/300F King Quad 300 Service Manual
×
×
  • Create New...