Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

PKR

No Name quad carburators

Recommended Posts

Does anyone know if and where you can get parts for a no name carb. My neighbor has one on a 1989 Yamaha 350 big bear and it is leaking gas around the seal on the accelerator pump. (see pic).

Any and all help would be appreciated

 

Thanks

PKR

Carb 2_LI (2).jpg

Share this post


Link to post
Share on other sites


I have a parts carb for a warrior 350. Same carb. What do you need? Just that seal?

Sent from my SM-N920V using Tapatalk

Share this post


Link to post
Share on other sites

Thanks for answering my call for help.

All I need is the seal as shown in the picture. If you don't need the one you have and are willing tp part with it I would be interested.

How much would you want for it?

Thanks 

PKR

Share this post


Link to post
Share on other sites

That's great, very much appreciated.

If you can send the rubber seal COD via regular mail I will pay for the shipping when it gets here.

My mailing address is 

Phil Reid

PO Box 2786

Lloydminster, Sask.

Canada

S9V 0Z1

Thanks again

Share this post


Link to post
Share on other sites


Do you want just the seal or the whole carb. Nothing is wrong with it. I just sold the machine and no longer need it.

Sent from my SM-N920V using Tapatalk

  • Like 1

Share this post


Link to post
Share on other sites

The seal is all I need. The carb I have is basically new so I shouldn't need anything else.

Thanks for asking

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Colby Calk
      I recently got a 98 warrior 350 that 'needed the carb adjusted' but the reality is it has no spark. I have a new spark plug, plug wire, ignition coil, battery, and cdi box. I checked continuity and took apart and inspected the starter/kill/light switch on the handle bar, and it all looks brand new and checked out. The key switch seems to be working properly, as when off, nothing works, but when switched on, lights and electric starter button work. It turns over fine, and as I just stated, all the lights work. I took all the plastics off and traced all the wires, and only one had a small cut in it, but it was only through the rubber sheathing, not the wire itself (the blue one coming from the stator). I cleaned some grounds, made sure both relays work, and still nothing. I pulled the stator cover and looked at the stator itself, and it looks great. No broken wires or connectors or anything. Still, no spark. I'm at a loss. Where do I go next? Any help is appreciated.
    • By Dra O
      posted a while back - it was running at one point - I have all the plastic shroud off - it's down to frame and engine now
      -fuel pump: when line from petcock is attached, no fuel comes out other side to carb; the line to the carb is open (can blow through it); I thought when I cranked engine that the pump would spit out fuel on other side but it does not; I removed fuel pump and opened it up - diaphragm looks good - but internal areas had lotsa calcification build up - I cleaned this out and dried it good - the clear plastic pieces (?diaphragms) aren't broken - the spring w/ steel ball on end moves freely; am putting it back on tomorrow; but can anyone answer about the pump? isn't it supposed to pump fuel through it... to other side... to carb? puzzling
      -along with fuel pump: I replaced petcock 3 weeks ago (gas tank had rusty fuel in bottom - cleaned it out prior to new petcock); when I turn petcock arrow NOT to on or reserve, fuel comes out of line; when I turn it to on or reserve, fuel doesn't come out; puzzling
      -I don't know what's on back of fuel pump - it's a valve that has a hose coming out of it - looks like it goes to engine/carb - I haven't traced this out yet - what is it?
      -can squirt gas on air filter and engine will run for 2-3 seconds then stop - fuel in top of carb (under diaphragm) does same
      -it likely needs carb rebuild - will get to this - but something isn't allowing fuel to get from fuel pump to carb
      -I THINK it has a mikuni model x carb - diaphragm is ID 26mm  OD 68mm - hard to find inexpensive diaphragm, I guess because it's a model x
      -last thing - I replaced solenoid due to old one clicking; I HAVE to be charging the battery or it won't start/turn over - battery just goes dead; but if charging, it'll turn over nicely; i'm guessing it's a bad battery
      -any help appreciated - I've never owned an ATV before - inherited this beast from grandparent in-law
    • By Ben Lennon
      Hi guys new to this forum and thought I’d jump on as I’ve just bought my first quad a Kawasaki bayou klf300c 89 model. It had starting issues when I bought it so I’ve gone thru and replaced the cdi, voltage regulator and starter solenoid aswell as rebuilt the starter motor after all this it was still free spinning on electric start so I pulled the stator cover off to find the fly wheel wasn’t spinning so replaced the one way clutch bearing put it all back together and still not engaging at all. I’m at a loss and looking for some ideas on we’re to look next to solve the problem
      cheers Ben 👍
    • By raybob
      I have it all but can find where the vacuum line on the carb goes its a 2000 suzuki 500 quadmaster I know where the two vent lines go but not the bigger vacuum line goes it has vacuum on this line. need help. Ray
       
    • By Chase Cook
      I have a Yamaha 350 in at once to try to fire up but won't. It's getting gas fire air and it has a lot of compression but still struggles to start check the timing it's top dead center valves are good valves are adjusted everything's working but won't fire I put my hand over the carb suck in gas and it tries to but it makes a lot of black smoke. Also when I put my hand over do you carb and tried to start it there's black black nasty stuff in the gas. So I don't know if it's trying to burn too much or what it is the gas tank clean and it anything to do with the gas it's with it firing. Took the spark plug out and it's pure black. What is dried up black not nasty corroded wet looking. Need help to solve the issue
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...