Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

grizzlysixsixty

New from north tx

Recommended Posts



16 hours ago, grizzlysixsixty said:

Got me a grizzly it’s funbit I need to fix it here and there. 

Welcome to QUADCRAZY! I have a 2004 yamaha grizzly 660. 

 

Share this post


Link to post
Share on other sites

how do you like that backrest on it? i thought about getting one of them. but idk.. give me some pros and cons of it please

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Tahj
      I am looking to see why my 2005 Grizzly  660 won't crank. I have set the valves but suspect a loose timing chain.
      When working to remove the valve cover I found a "cap tensioner case" - parts #25  - #299 on Babbitts site.
      The  cover seems to bridge the valve cover and the cylinder head. What the hell is it and what surprises will I  find if I remove it?
      Uncharted territory for me.
    • By David Cameron
      The small waterline insert for the hose that goes from the water pump cover to the thermostat housing has corroded off. I only need the insert on top and behind the thermostat housing that the hose goes over and can't find just the insert. It looks like it may be pressed in. I've have been told the entire motor housing needs to be replaced. The pic with the red line indicates where the hose and insert would be and the insert looks like the pic of the water pump  Any ideas would be really appreciated.
       
       



    • By Tahj
      I bought a "project" Grizzly 660, I think it has been a few people's project. The PO had it for a while and did not have time to work on it. He said the battery was good, but I don't know how he knew because the display was blank, no lights and won't crank or run. 
      I found a nest under the front cover, by the CVT inlet, a chewed thru wire and a few more without insulation. Rewired those from the connector (black 3 wire to the display) and replaced the fuse as suggested by a search from this site. That got the display working and power to other circuits. 
      I replaced the aftermarket start switch with a used OEM switch from eBay. Then it would crank a little, and started once for a few seconds. 
      I'm a small engine mechanic - mowers, snow blowers, etc. In my small engine work I have had a number of rider mowers that would crank about a half turn and then stop. The owners have suspected a bad battery and changed it with no improvement. Setting the valves to spec usually fixed this.

      I set the valves on the Grizzly without solving the crank problem. I wonder if the timing chain could be off - slipped a tooth. 
      I don't know any way to check for this without pulling the head and looking at the timing marks on the cam gear. 
      Is there another way to check for proper timing?
       
    • By YamahaGrizzly
      So I tried something a little different and had a editor edit my last video! I think it turned out great! let me know what you think in the comment section of the video on youtube! dont forget to like and subscribe!  
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...