Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Joe Peters

1988 Yamaha Moto4 YFM350ERU

Recommended Posts

I have been in process of restoring my YFM350ERU, now I can not get a spark to my plug. I was told it could possibly be my CDI. it was sparking fine when we rebuilt engine but now I have no spark. is there a way to test the CDI. I have looked for a CDI board on the web but it is NA.. ant help would be greatly appreciated.

thanks JOE

Share this post


Link to post
Share on other sites


The cdi boxes are available on eBay. New and used.  I really don’t think it’s your cdi though.  Especially since you said you had spark before the rebuild. So unless you left it out where it was wet and moisture got inside  or burnt it out by hooking something up wrong my guess is it’s prob fine. 

 Have you double checked all of your wiring connections as well as looking for any banged wires that may have happened while putting the motor back in or pinched ? 

Have you tested the stator coil, regulator and secondary coils ? Easy test with an ohm meter.  Double check your kill switch.  

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Colby Calk
      I recently got a 98 warrior 350 that 'needed the carb adjusted' but the reality is it has no spark. I have a new spark plug, plug wire, ignition coil, battery, and cdi box. I checked continuity and took apart and inspected the starter/kill/light switch on the handle bar, and it all looks brand new and checked out. The key switch seems to be working properly, as when off, nothing works, but when switched on, lights and electric starter button work. It turns over fine, and as I just stated, all the lights work. I took all the plastics off and traced all the wires, and only one had a small cut in it, but it was only through the rubber sheathing, not the wire itself (the blue one coming from the stator). I cleaned some grounds, made sure both relays work, and still nothing. I pulled the stator cover and looked at the stator itself, and it looks great. No broken wires or connectors or anything. Still, no spark. I'm at a loss. Where do I go next? Any help is appreciated.
    • By Chris2018
      I have a 1996 Kawasaki Mojave KSF250. I have no manual on it and it has a no spark issue. If anyone could give me a hand with this or would possibly have a manual would appreciate it. 
    • By Tiffany Rowland
      I recently purchased an 07 Honda sportrax and when I was checking the spark plug I saw the boot was ripped nearly in half. When I removed the plug it was blackened and covered in oil. How can I thoroughly clean the plug hole and remove any debris that is in there? Is there a small tube like vacuum or something of the sort made for stuff like this? The machine my dentist has would be perfect, maybe they do rentals! 😁
    • By Tiffany Rowland
      I am working on a Honda sportrax I just got my daughter for get birthday and the reverse and neutral light are not working. When I traced the wire down I saw that it wasn't plugged in but I don't see where it is supposed to connect. Does any one have a general idea of where I should look?

    • By Tiffany Rowland
      I recently purchased an 07 Honda sportrax and when I was checking the spark plug I saw the boot was ripped nearly in half. When I removed the plug it was blackened and covered in oil. How can I thoroughly clean the plug hole and remove any debris that is in there? Is there a small tube like vacuum or something of the sort made for stuff like this? The machine my dentist has would be perfect, maybe they do rentals! 😁

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...