Quantcast
Jump to content


Hisun HS 750 Crew UTV Service Manual


Ajmboy

Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Forum Topics

    • By mkibbe
      My 2014 750 king quad stalls sometimes when I touch or turn the handlebars,the problem has gotten worse,my machine has 475 miles and is only trail ridden,I have a new factory battery and i have 14.2 volts when the quad is running and 13.3 on the battery when not running,also using a multimeter there is no change in volts when turning the bars until it does stall,If I pull the 40 amp power steering fuse it will not stall.......I've been told its the ECU,Hate to buy one if thats not the problem,but its kinda leaning towards that,,,,,need some opinions.

    • By STLJ
      Gday all,
       
      Been trying a couple different ways now to download a manual. Not sure what I am doing wrong but could someone walk me thru it?
      I go to DL page and click on link
      get a pop up for a PDfixer or something
      close that and then hit download button and no go
      tells me I have reached my limit but I have never DL anything ever. 
    • By Clydaho
      2022 Sector 550, 414 miles on it and the gas gauge reads empty.  I topped off the gas and it didn't change.
      There is no fuse that I could find.  No access at the gauge cluster.
      Wiring on the top of the tank looks good, properly connected.
      Could the sending unit in the tank be stuck or broken?
      Has anybody removed the tank lid?  Any tricks?  
      Any other ideas?
      Thanks for any help,
      Clyde
    • By rgeiser
      View File 2003 Polaris Ranger 400-500 service manual
      2003 Polaris Ranger 400-500 service manual
      Submitter rgeiser Submitted 04/18/2024 Category Polaris UTV  
    • By skittle021
      So I've got a Hisun 550 that I was doing some work on that required removing the CVT and it's housing. Upon attempting to reinstall the clutch, sheaves, etc, I found that the belt no longer fits - it's far too wide. None of the parts have been replaced, they're all OEM. Exactly the same parts as what I took off a few weeks ago.
      To be more specific, my belt is 1.25in wide, but the gap between the clutch and the primary sheave is only 7/8in wide. I'll include a few photos to explain.
      Has anyone ever experienced such a bizarre problem? Any help at all would be appreciated, I've been stuck on this for a month. I'm open to just about any suggestion.
      Photos: 
       





×
×
  • Create New...