Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Sign in to follow this  
StolenATV

STOLEN ATV: Suzuki LT 80 Quad And Honda Dirt Bike

Recommended Posts



Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Topics

    • By Curtis01
      OK, sooo  I finally did the old skid plate and screen removal to clean out my oil sump during an oil change...  This bike only has a couple thousand miles on it.  Runs like a top still...  Very few issues over the years after buying it used.
      But boy I wasn't expecting to see this!  Piece of a circlip, stuck up in the screen, and a another shard of metal and maybe a piece of gasket material.  Nothing in the oil but that...  Pristine otherwise, and still runs like a top.  Always has.
      Soooo, is it a wrist pin clip?  That's the only thing I can think of like this that could end up in there.  But definitely wanted to throw it out to guys that have seen the innerds of these more than I have.
      The valves on this thing are still within the factory spec even.  Been a really good lil workhorse...
      Any other ideas?

    • By ronald webb
      So where to start my son's LT80 stop running a couple months ago. Naturally I assumed I had a carburetor issues or the peacock valve. After replacing those two items and ensuring I had a spark I started doing my homework thus finding this page. After all the post I have read the next natural thing would be compression I did a compression test today and it was only 60 after spraying WD-40 in it so off comes the cylinder head and The Jug to my surprise the cylinder walls and all the gaskets are pristine so I am totally stumped no idea why I would not have compression when everything looks brand new even the Rings look great any help would be appreciated thanks in advance
    • By billyz57
      New to Quadcrazy, Has any Yamaha owners had similar issue?
      1987 Yamaha YFM 350 Starts on Pull, but just spins on starter, and won't start.
    • By Chrism
      Hi all, new to this forum so thanks in advance for the help.

      I have recently brought a 2013 power steering fuel injected foreman 500.

      It has a crack in the front casing and was running rough. I have since replaced the front engine casing and this has made no difference to the engine performance.

      It starts and idles but bogs down and starts to die once throttle is applied.

      It maybe be but it also sounds very load.

      I have uploaded a video link of it.
       
       
       
    • By Countryboy57
      Hello I’m new here and I need help finding out what kind of quad I recently got for free. When I looked up the vin all it showed was 2004 and made in China. Any help will greatly appreciated thanks.
       

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...