Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

mrfartsalot

What atvs share parts with a 2001 suzuki quadmaster 500?

Recommended Posts

I have a 2001 suzuki quadmaster 500 4x4 automatic and i was wondering witch atvs it shares parts with i know it shares some with artic cat. Any info would be helpful.

67697817_2866409116720836_6493308515040362496_n.jpg

68530217_972237879779248_7370839199118786560_n.jpg

67687254_348394196092197_7118181387085021184_n.jpg

  • Like 1

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Jeff Miller
      I'm trying to troubleshoot a starting issue. For a while, maybe a year sometimes I would hit the starter button and I'd hear a single loud click, but the starter wouldn't turn. Usually if I could pull the pull start or roll it in gear it would then start. (now I'm thinking that was coincidence) Now it only clicks. I tried to check what I could, battery is good, solenoid clicks strong, cleaned all connections (which were 80% clean anyway). I started thinking the starter wasn't spinning. I pulled it and it spins freely. The gear that it contacts in the engine-I can wiggle it maybe 1/16th to 1/8th inch back and forth. When I reinstall the starter I feel it jerk when I hit the button. I'm thinking maybe it's the starter clutch? It seems when there's a problem with them they usually just spin freely and don't engage at all. Is it possibly something is causing it to lock? I'm a bit lost now.
    • By Tanner J Hawley
      Hey so i have a 85 Suzuki lt230s and it runs just fine except for some reason idk but wen i put it in gear and let off the clutch it wont move but the shifter goes threw all gears so idk what or how i would go about fixing it or were to even start?? Any help would b very much appreciated
    • By Dizzy siege
      my brakes do not engage and the right hand lever kills the engine and reverse makes a loud clicking crunch sound i think it wont engage into reverse all of the way. I NEED HELP PLEASE 
    • By Orangejbird
      My Dad's 03 Manual Vinson has milky oil. He changed oil and ran it everyday for a week being sure to keep it running for an hour each time. Fresh oil is getting milky again..
      Thinking it's the water pump seal. Has anyone here successfully changed the seal or even replaced the whole pump assembly?
  • Similar Tagged Content

    • By muletrain60
      Machine ran fine one day, next day nothing. Replaced the coil still no fire. Battery is fine, have lights, dash indicators, etc with key on. Cranks over, just no fire.  How do I check the CDI?  Also what is the probability of the stator being bad?  Thoughts?
    • By skymankila69
      I traded my dirt bike for a 2000 arctic cat 500 semi automatic. when i went to go pick it up the guy said it didn't get spark, so i thought it was going to be something simple like a coil. well it wasn't. first thing i did was take all the plastics off to get easy asses to every thing. so i bought a brand new battery for it seeing if it got power, it didn't. the dash wouldn't light up neither would the lights, so then i tried to see if the starter worked it didn't so i jumped the solenoid and the starter started turning over the motor. so i bought a new starter solenoid, when i installed it the electric start still wouldn't work , so i bought a new kill switch and starter switch that goes on the handle bars, when i installed it, the electric start still wouldn't work. so then i went to see if i could get spark by pull starting it, i didn't get any spark, so i bought a new spark plug, and guess what, still no spark, so then i bought a new coil for it to see if that would fix it. so i installed the new coil and guess what no spark still and still no power to the dash. so to sum it up i'm not getting any power any where to the four wheeler. so i cleaned all the leads and plugs and still nothing. so then yesterday i took the wiring apart to see if their was any frayed wires, and no their wasn't. does any one have any ideas what this could be i'm up for anything. also if any one knows how to bypass all the wiring just to get it to start i open to that to, or if someone knows where  i can get a wiring diagram.
    • By bubby
      its like the rearends locked but u can put it in 4x4 it pulls put it in gear it boggs down like somethings holdin it back
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...