Quantcast
Jump to content

  • Do you own an ATV or UTV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

parallel twin firing order?


Recommended Posts

  Something i have wondered for years is about the firing order of a parallel twin.  Yes i am aware of both pistons going the same direction at the same time, but do both cylinders fire at the same time or at different times? Just being curious since i have always wondered.  

Link to post
Share on other sites


Parallel twins don't fire at the same time. While one piston is on the way up to fire the other is on the way down.  They are designed like this so there is a constant velocity power band and produce a lot more torque. 

Tandem twins have the pistons firing at the same time as the pistons are at the same location on the crank shaft.  These are a pain in the ass to dial in since the air/fuel delivery to the cylinders has to be very close because they both fire together.    

  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By David Land
      I have an 05 King Quad 700 that has in the past had to have the stator replaced twice.  For the past six months it has been down hard as I cannot get it to fire.  I have replaced the coil (which is the code that came up) and now I have a friend replacing the stator.  I want to see if the new stator does the trick.  Drain the old fuel, and replace with 100% Ethanol free fuel, and see if that does the trick.  The local Suziki dealer will not work on it as it is over 10 years old.  So the nearest dealer is 90 miles away.  The last thing I can do after that (provided the other fixes do not work) is replace the ECM/ECU.  I also read that there was a recall on the ECM/ECU, so I need to check on that.  All of the grounding has been checked, so if anyone has an idea, I would greatly appreciate the insight.
       
      Kindly,
       
      David
    • By Zad
      1994 Polaris 300 2x4 project won’t start. Seems like we have spark and have tried straight starting fluid in cylinder and still not getting a fire.   Kind of has me stymied 
    • By Bryson Bailey
      Hey I have a Kawasaki buyou I put a new carburetor on it and a brand new spark plug coil and still firing up could you know what my problem is anyone please
    • By Hunsaker Tim
      2004 700 twin peaks 
      When i get to about 10 mph i get a very (tinny ) noise from the right side of the engine / clutch area.
      originally I thought maybe something got caught between axle and skid plate ie : rock and was just rubbing producing that sound.
      I took off the skid plate and drove it and still had same sound.
      Checked the lug nots and they were a bit loose , tightened them and still same noise.
      Took off the what looks like an inspection plate on top of clutch cover and looked inside this apart and it is dry of any fluid.
      Not sure if there should be any fluid in there or not had clutch replaced 2 yrs ago with nominal riding since.
      I do not have the time or knowledge to take this apart and try and diagnose. The only repair areas around here are absolutely terrible.
      The shop I normally do the work are 2.5- 3 mos. behind. Any suggestions would be greatly appreciated.
      Thank, you
    • By Jeff Miller
      I'm trying to troubleshoot a starting issue. For a while, maybe a year sometimes I would hit the starter button and I'd hear a single loud click, but the starter wouldn't turn. Usually if I could pull the pull start or roll it in gear it would then start. (now I'm thinking that was coincidence) Now it only clicks. I tried to check what I could, battery is good, solenoid clicks strong, cleaned all connections (which were 80% clean anyway). I started thinking the starter wasn't spinning. I pulled it and it spins freely. The gear that it contacts in the engine-I can wiggle it maybe 1/16th to 1/8th inch back and forth. When I reinstall the starter I feel it jerk when I hit the button. I'm thinking maybe it's the starter clutch? It seems when there's a problem with them they usually just spin freely and don't engage at all. Is it possibly something is causing it to lock? I'm a bit lost now.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...