Quantcast
Jump to content

Leota Quad Trails on New to us Machines 5-10-20


Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Forum Topics

    • By Gwbarm
      I have been exploring all the options available, so many, its hard to choose. I have kind of narrowed it down to the Honda Pilot, Subaru Outback, and Kind of looking at the Outlander, although its a little small,  the new one is nice looking. Just wondering if anyone has any recommendations or gripes with any of these rides. I have driven Jeeps for the past 25  years and they have been great, but their price point has gotten to high. Expieriences good or bad would be helpful. Thanks!
    • By Admin
      View File 2006-2011 Honda Rincon TRX 680 FA/FGA service manual
      2006-2011 Honda Rincon TRX 680 FA/FGA service manual
      Submitter Admin Submitted 04/09/2024 Category Honda ATV  
    • By DrtyGrlKristin
      Just thought I'd start a new thread for newbies to the site!
      If you're new here, tell us who you are, where you're from and what you ride!!!
      Lets get to know each other a little better shall we?
      I'm not new to the site, obviously, but...
      I'm Kristin from Denver!!! I ride a 2008 Yamaha Rhino. She's my muddy baby!!!!!! Several aftermarket parts on her. She's good to me! We try and ride every weekend. This weekend we're off to MOAB! :woot:
    • By Tuzz
      Bucking started about a month ago and works ok after 1/2 hour warmup.  Today while working on it i discovered that if i put the ignition switch in LIGHT position it runs fine right from the start.
      I'm stumped!  Any idea why this could be?  

    • By Drillbit
      Hey all,
      I need some input on a problem I'm having with my Kodiak 400 that keeps fouling plugs. First off, I've done a lot of work to this thing, most of it all in good fun. Brake work, cv joints, u joints, carb kit, checked valve lash, compression good, changed all fluids, etc... My problem is it keeps fouling plugs very quickly. I can put a new (manual recommended plug) in and it starts right up, runs great, idles great, picks up good. Doesn't stutter at all. I ride it for 1/2 a mile, it cuts off and won't start back up. I let it sit overnight thinking maybe it got to hot. Try to start it the next day, nothing. Put a new plug in, fires right up, runs great for another 1/2 mile or so, dead. The plugs come out and look carbon fouled with dry black soot on them. I don't know if this is a fuel/air mixture problem or a ignition problem. A couple of things that I noticed is I never need to pull the choke out to start it. Also, when it starts it automatically idles high like an automatic choke would do, then it comes back down to a good idle. Also I noticed that the air/fuel mixture needle valve screw does nothing when I adjust it in or out. I can screw it all the way closed and the motor still runs and idles good. Any advice would be greatly appreciated. I'm almost leaning to a ignition breaking down the plugs??
      Thanks! 
×
×
  • Create New...