Guest Fox300exchic

Member Question

Recommended Posts

Guest Fox300exchic

This young lady has some questions about her quad. She has a Raptor 660 and I dont know anything about those. Here's her name and maybe someone can help her out for me. ( Macklee53 ) Thanks!

Share this post


Link to post
Share on other sites
  •  Like what you are reading? Please help us by sharing this content.


Guest Fox300exchic

Thats what I told her to do.

Share this post


Link to post
Share on other sites
  •  Like what you are reading? Please help us by sharing this content.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  •  Like what you are reading? Please help us by sharing this content.
  • Similar Content

    • By Admin
      We have added a map of the 100 most recent visitors with their locations powered by Google. You can view it under the "BROWSE" section of the site. You can also click on the tacs to view who it is.
      Navigate to the "BROWSE" section, then to "MEMBER MAP" .
      Or click HERE :smile:
    • By patricknperkins
      Ok, so got this thing, assembled, and even added acid/assembled the battery with a solid trickle charge and the battery is fine.
      As far as I can tell, I have checked all the fuses I can find, but I have ZERO power to anything. Even the console will not light up when turned to ON.
      Is there some sort of hidden parental/child disconnect or safety switch that I'm not aware of? ANY help would be appreciated.
    • By pickytar
      I have a Chinese Hybird 250 or that's what I was told it was. I found 17 numbers on the frame. Will these numbers tell me exactly what it is that I have? (I know that its a 2006 from a plate on the front)
    • By Forrester
      Hi I have a 300 king quad breaking down when throttled . Starts and idles awe sum only revs up when I turn lights on and eventually blew high beam and then only revved on low which eventually blew .. Now with no lites no revs just idle
    • By upper_tanker
      Hey all, new guy here. I am wondering if anyone has one of these machines, that can possibly take a picture/tell me where the hoes goes from the timing chain cover. I took this machine apart in the fall of 2014, planning to rebuild the top end, and didn't get around to doing it until about a month ago. motor is back together, and I'm just curious as to where this hose goes. One end has a plastic ribbed fitting in it.
      Also, the rear upper nipple on the carburetor.....what goes there? is that just a breather also or?
      I have the rubber piece that slides into the rear of the gas tank with 3 hoses: 2 go to the rear, and 1 is just a clear piece of hose that isn't connected anywhere.
      I have another one of these machines, but it is 5 hours away.
      I guess that's what I get for waiting a year and a half to put it back together lol.
      Thanks